summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-12 21:44:59 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-12 21:44:59 +0000
commit1489948c98ce8aaff342c2f61c7e852d60304ee6 (patch)
tree3d6bd9a6d1ebe56c85ed5752cbf287dcf4723d29 /net-ftp/easyftp
parentfix src_uri Rik switched to bz2 (diff)
downloadgentoo-2-1489948c98ce8aaff342c2f61c7e852d60304ee6.tar.gz
gentoo-2-1489948c98ce8aaff342c2f61c7e852d60304ee6.tar.bz2
gentoo-2-1489948c98ce8aaff342c2f61c7e852d60304ee6.zip
Added a gcc3.2 fix
Diffstat (limited to 'net-ftp/easyftp')
-rw-r--r--net-ftp/easyftp/ChangeLog6
-rw-r--r--net-ftp/easyftp/easyftp-6_beta.ebuild5
-rw-r--r--net-ftp/easyftp/files/easyftp-gcc3.2.diff11
3 files changed, 18 insertions, 4 deletions
diff --git a/net-ftp/easyftp/ChangeLog b/net-ftp/easyftp/ChangeLog
index 5fb6c15e1351..1c1a48358f4d 100644
--- a/net-ftp/easyftp/ChangeLog
+++ b/net-ftp/easyftp/ChangeLog
@@ -1,11 +1,13 @@
# ChangeLog for net-ftp/easyftp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/easyftp/ChangeLog,v 1.1 2002/05/27 00:58:52 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/easyftp/ChangeLog,v 1.2 2002/10/12 21:44:59 vapier Exp $
*easyftp-6_beta (26 May 2002)
- 26 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+ 12 Oct 2002; Mike Frysinger <vapier@gentoo.org> easyftp-gcc3.2.diff :
+ Added a tiny patch to make it work in gcc3.2 #9037
+ 26 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/net-ftp/easyftp/easyftp-6_beta.ebuild b/net-ftp/easyftp/easyftp-6_beta.ebuild
index e36586bcef6e..6e905c7bed48 100644
--- a/net-ftp/easyftp/easyftp-6_beta.ebuild
+++ b/net-ftp/easyftp/easyftp-6_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/easyftp/easyftp-6_beta.ebuild,v 1.4 2002/09/23 20:10:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/easyftp/easyftp-6_beta.ebuild,v 1.5 2002/10/12 21:44:59 vapier Exp $
S=${WORKDIR}
DESCRIPTION="An EASY GUI FTP Client (QT based)"
@@ -14,10 +14,11 @@ LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
src_compile() {
+ patch -p0<${FILESDIR}/easyftp-gcc3.2.diff
emake || die
}
-src_install () {
+src_install() {
exeinto /usr/bin/
doexe easyFTP
dodoc README
diff --git a/net-ftp/easyftp/files/easyftp-gcc3.2.diff b/net-ftp/easyftp/files/easyftp-gcc3.2.diff
new file mode 100644
index 000000000000..06d4a0af2c1e
--- /dev/null
+++ b/net-ftp/easyftp/files/easyftp-gcc3.2.diff
@@ -0,0 +1,11 @@
+--- connectioninformationtext.cpp.orig 2002-10-12 20:12:00.000000000 -0400
++++ connectioninformationtext.cpp 2002-10-12 20:12:11.000000000 -0400
+@@ -5,7 +5,7 @@
+
+ #include "connectioninformationtext.h"
+
+-ConnectionInformationText::ConnectionInformationText( QWidget * parent = 0, const char * name = 0 ): QTextEdit( parent, name )
++ConnectionInformationText::ConnectionInformationText( QWidget * parent, const char * name ): QTextEdit( parent, name )
+ {
+ this->setReadOnly( TRUE );
+ }