summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-05-04 17:18:38 +0000
committerMike Frysinger <vapier@gentoo.org>2013-05-04 17:18:38 +0000
commitfa3b0c97892d7901c2615cb330631e1e9e347436 (patch)
tree2c8fa8846c7a96b1d4c45dd3ed0d62dd03d0c00d /net-fs
parentMask USE=profile for net-analyzer/wireshark (bug #468404). (diff)
downloadgentoo-2-fa3b0c97892d7901c2615cb330631e1e9e347436.tar.gz
gentoo-2-fa3b0c97892d7901c2615cb330631e1e9e347436.tar.bz2
gentoo-2-fa3b0c97892d7901c2615cb330631e1e9e347436.zip
Disable mount sloppy test since it violates the sandbox #453778 by Konstantin Münning.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog7
-rw-r--r--net-fs/autofs/autofs-5.0.7-r1.ebuild20
-rw-r--r--net-fs/autofs/files/autofs-5.0.7-mount-sloppy.patch17
3 files changed, 31 insertions, 13 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index da6468fcd4f9..e10ff8f2e1f6 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.148 2013/05/03 19:14:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.149 2013/05/04 17:18:38 vapier Exp $
+
+ 04 May 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/autofs-5.0.7-mount-sloppy.patch, autofs-5.0.7-r1.ebuild:
+ Disable mount sloppy test since it violates the sandbox #453778 by Konstantin
+ Münning.
*autofs-5.0.7-r1 (03 May 2013)
diff --git a/net-fs/autofs/autofs-5.0.7-r1.ebuild b/net-fs/autofs/autofs-5.0.7-r1.ebuild
index 1762d244e227..c611f6d6a778 100644
--- a/net-fs/autofs/autofs-5.0.7-r1.ebuild
+++ b/net-fs/autofs/autofs-5.0.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.1 2013/05/03 19:14:13 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.7-r1.ebuild,v 1.2 2013/05/04 17:18:38 vapier Exp $
EAPI=5
@@ -28,13 +28,15 @@ IUSE="hesiod ldap mount-locking sasl"
REQUIRED_USE="sasl? ( ldap )"
# currently, sasl code assumes the presence of kerberosV
-RDEPEND="
+RDEPEND=">=sys-apps/util-linux-2.20
hesiod? ( net-dns/hesiod )
ldap? ( >=net-nds/openldap-2.0
sasl? (
dev-libs/cyrus-sasl
dev-libs/libxml2
- virtual/krb5 ) )"
+ virtual/krb5
+ )
+ )"
DEPEND="${RDEPEND}
sys-devel/flex
virtual/yacc"
@@ -53,11 +55,9 @@ PATCHES=(
# Upstream reference: http://thread.gmane.org/gmane.linux.kernel.autofs/5371
"${FILESDIR}"/${PN}-5.0.5-fix-install-deadlink.patch
- # https://bugs.gentoo.org/show_bug.cgi?id=361899
- "${FILESDIR}"/${PN}-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
-
- # https://bugs.gentoo.org/show_bug.cgi?id=381315
- "${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch
+ "${FILESDIR}"/${PN}-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch #361899
+ "${FILESDIR}"/${PN}-5.0.6-revert-ldap.patch #381315
+ "${FILESDIR}"/${PN}-5.0.7-mount-sloppy.patch #453778
)
AUTOTOOLS_IN_SOURCE_BUILD=1
@@ -72,10 +72,6 @@ src_prepare() {
}
src_configure() {
- # work around bug #355975 (mount modifies timestamp of /etc/mtab)
- # with >=sys-apps/util-linux-2.19,
- addpredict "/etc/mtab"
-
# --with-confdir is for bug #361481
# --with-mapdir is for bug #385113
# for systemd support (not enabled yet):
diff --git a/net-fs/autofs/files/autofs-5.0.7-mount-sloppy.patch b/net-fs/autofs/files/autofs-5.0.7-mount-sloppy.patch
new file mode 100644
index 000000000000..670d9bc7c547
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.7-mount-sloppy.patch
@@ -0,0 +1,17 @@
+https://bugs.gentoo.org/453778
+
+we've had a stable util-linux that supports -s for a long time (and the ebuild
+forces a recent version), so disable this test which implicitly tries to modify
+files like /etc/mtab and piss off the sandbox.
+
+--- a/aclocal.m4
++++ b/aclocal.m4
+@@ -65,7 +65,7 @@
+ AC_DEFUN(AF_SLOPPY_MOUNT,
+ [if test -n "$MOUNT" ; then
+ AC_MSG_CHECKING([if mount accepts the -s option])
+- if "$MOUNT" -s > /dev/null 2>&1 ; then
++ if true > /dev/null 2>&1 ; then
+ AC_DEFINE(HAVE_SLOPPY_MOUNT, 1, [define if the mount command supports the -s option])
+ AC_MSG_RESULT(yes)
+ else