summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2004-07-26 17:50:21 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2004-07-26 17:50:21 +0000
commitf4e6dd5971e7c74862925c59a69110b76b774985 (patch)
tree2232a8fcf5dc921a3885c1bb2709c60e0aa128bb /net-fs
parentadded in mailx virtual for bug #58164 (diff)
downloadgentoo-2-f4e6dd5971e7c74862925c59a69110b76b774985.tar.gz
gentoo-2-f4e6dd5971e7c74862925c59a69110b76b774985.tar.bz2
gentoo-2-f4e6dd5971e7c74862925c59a69110b76b774985.zip
Fixed several issues in coda init scripts (see bug #26132)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/coda/ChangeLog9
-rw-r--r--net-fs/coda/coda-6.0.3.ebuild4
-rw-r--r--net-fs/coda/coda-6.0.6.ebuild5
-rw-r--r--net-fs/coda/files/auth213
-rw-r--r--net-fs/coda/files/coda-update28
-rw-r--r--net-fs/coda/files/codasrv26
-rw-r--r--net-fs/coda/files/venus10
-rw-r--r--net-fs/coda/metadata.xml4
8 files changed, 59 insertions, 40 deletions
diff --git a/net-fs/coda/ChangeLog b/net-fs/coda/ChangeLog
index 89c35b107910..d27ebed5325f 100644
--- a/net-fs/coda/ChangeLog
+++ b/net-fs/coda/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/coda
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.7 2004/07/16 23:22:03 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.8 2004/07/26 17:50:21 griffon26 Exp $
+
+ 26 Jul 2004; Maurice van der Pot <griffon26@gentoo.org> metadata.xml,
+ files/auth2, files/coda-update, files/codasrv, files/venus,
+ coda-6.0.3.ebuild, coda-6.0.6.ebuild:
+ Fixed several issues with init scripts that popped up in the comments
+ of bug #26132. Fixed omission in einfo in both ebuilds. Took over
+ maintainance from Daniel Black <dragonheart@gentoo.org>
17 Jul 2004; Daniel Black <dragonheart@gentoo.org> files/auth2,
files/coda-update, files/codasrv, files/venus:
diff --git a/net-fs/coda/coda-6.0.3.ebuild b/net-fs/coda/coda-6.0.3.ebuild
index b92e989bd8f9..10a7b86d4473 100644
--- a/net-fs/coda/coda-6.0.3.ebuild
+++ b/net-fs/coda/coda-6.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.3.ebuild,v 1.4 2004/06/24 22:42:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.3.ebuild,v 1.5 2004/07/26 17:50:21 griffon26 Exp $
inherit eutils
@@ -114,7 +114,7 @@ src_install () {
pkg_postinst () {
einfo
einfo "To enable the coda at boot up, please do:"
- einfo " rc-update venus default"
+ einfo " rc-update add venus default"
einfo
einfo "* To get started, run venus-setup and vice-setup"
einfo
diff --git a/net-fs/coda/coda-6.0.6.ebuild b/net-fs/coda/coda-6.0.6.ebuild
index 2840163ecac5..c1c6d108077c 100644
--- a/net-fs/coda/coda-6.0.6.ebuild
+++ b/net-fs/coda/coda-6.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.6.ebuild,v 1.3 2004/06/24 22:42:31 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.6.ebuild,v 1.4 2004/07/26 17:50:21 griffon26 Exp $
inherit eutils
@@ -114,7 +114,8 @@ src_install () {
pkg_postinst () {
einfo
einfo "To enable the coda at boot up, please do:"
- einfo " rc-update venus default"
+ einfo " rc-update add codasrv default"
+ einfo " rc-update add venus default"
einfo
einfo "* To get started, run venus-setup and vice-setup"
einfo
diff --git a/net-fs/coda/files/auth2 b/net-fs/coda/files/auth2
index 4c9f800835da..6700a09c8c1e 100644
--- a/net-fs/coda/files/auth2
+++ b/net-fs/coda/files/auth2
@@ -1,18 +1,13 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/auth2,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/auth2,v 1.4 2004/07/26 17:50:21 griffon26 Exp $
depend() {
need net
}
checkconfig() {
- if [ ! -e /etc/coda/server.conf ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
- eval `grep "^vicedir=" /etc/coda/server.conf || echo vicedir=/var/lib/vice`
if [ ! -e $vicedir/hostname ] ; then
eerror "Please run vice-setup before starting the service..."
return 1
@@ -27,7 +22,13 @@ we_are_scm() {
fi
}
+getvicedir() {
+ vicedir=`/usr/sbin/codaconfedit server.conf vicedir`
+}
+
start() {
+ getvicedir
+
checkconfig || return 1
ebegin "Starting auth2"
diff --git a/net-fs/coda/files/coda-update b/net-fs/coda/files/coda-update
index c059f96a26cb..9e6276f72b51 100644
--- a/net-fs/coda/files/coda-update
+++ b/net-fs/coda/files/coda-update
@@ -1,12 +1,19 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/coda-update,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/coda-update,v 1.4 2004/07/26 17:50:21 griffon26 Exp $
depend() {
need net auth2
}
+checkconfig() {
+ if [ ! -e $vicedir/hostname ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
+}
+
we_are_scm() {
if [ "`cat $vicedir/hostname`" = "`cat $vicedir/db/scm`" ] ; then
return 0
@@ -15,23 +22,16 @@ we_are_scm() {
fi
}
-checkconfig() {
-
- if [ ! -e /etc/coda/server.conf ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
- eval `grep "^vicedir=" /etc/coda/server.conf || echo vicedir=/var/lib/vice`
- if [ ! -e $vicedir/hostname ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
+getvicedir() {
+ vicedir=`/usr/sbin/codaconfedit server.conf vicedir`
}
start() {
+ getvicedir
+
checkconfig || return 1
- ebegin "Starting coda update servers"
+ ebegin "Starting coda-update"
# Check to see if we are the SCM.
if we_are_scm ; then
@@ -47,6 +47,8 @@ start() {
stop() {
ebegin "Stopping coda-update"
+ getvicedir
+
if we_are_scm ; then
start-stop-daemon --stop --quiet --exec /usr/sbin/rpc2portmap
start-stop-daemon --stop --quiet --exec /usr/sbin/updatesrv
diff --git a/net-fs/coda/files/codasrv b/net-fs/coda/files/codasrv
index 9b759ae707ce..6783add42294 100644
--- a/net-fs/coda/files/codasrv
+++ b/net-fs/coda/files/codasrv
@@ -1,22 +1,17 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/codasrv,v 1.4 2004/07/18 03:52:58 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/codasrv,v 1.5 2004/07/26 17:50:21 griffon26 Exp $
depend() {
need net coda-update auth2
}
checkconfig() {
- if [ ! -e /etc/coda/server.conf ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
- eval `grep "^vicedir=" /etc/coda/server.conf || echo vicedir=/var/lib/vice`
- if [ ! -e $vicedir/hostname ] ; then
- eerror "Please run vice-setup before starting the service..."
- return 1
- fi
+ if [ ! -e $vicedir/hostname ] ; then
+ eerror "Please run vice-setup before starting the service..."
+ return 1
+ fi
}
we_are_scm() {
@@ -27,7 +22,13 @@ we_are_scm() {
fi
}
+getvicedir() {
+ vicedir=`/usr/sbin/codaconfedit server.conf vicedir`
+}
+
start() {
+ getvicedir
+
checkconfig || return 1
ebegin "Starting codasrv"
@@ -37,8 +38,7 @@ start() {
stop() {
ebegin "Stopping codasrv"
- start-stop-daemon --stop --quiet --exec /usr/sbin/codasrv
- /usr/sbin/volutil shutdown
- sleep 30
+ msg=`/usr/sbin/volutil shutdown 2>&1` || echo "$msg"
+ start-stop-daemon --stop --quiet --retry 30/TERM --oknodo --exec /usr/sbin/codasrv
eend $?
}
diff --git a/net-fs/coda/files/venus b/net-fs/coda/files/venus
index 0a6dbf05ee02..ce6bf3f3fc9e 100644
--- a/net-fs/coda/files/venus
+++ b/net-fs/coda/files/venus
@@ -1,10 +1,18 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/venus,v 1.3 2004/07/16 23:22:03 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/venus,v 1.4 2004/07/26 17:50:21 griffon26 Exp $
depend() {
need net
+ after codasrv
+}
+
+checkconfig() {
+ if ! /usr/sbin/codaconfedit venus.conf &>/dev/null; then
+ eerror "Please run venus-setup before starting the service..."
+ return 1
+ fi
}
start() {
diff --git a/net-fs/coda/metadata.xml b/net-fs/coda/metadata.xml
index fd5998d86003..6526113afe87 100644
--- a/net-fs/coda/metadata.xml
+++ b/net-fs/coda/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>net-fs</herd>
<maintainer>
- <email>dragonheart@gentoo.org</email>
- <description>Maintaining until net-fs gets off its feet</description>
+ <email>griffon26@gentoo.org</email>
+ <name>Maurice van der Pot</name>
</maintainer>
<maintainer>
<email>net-fs@gentoo.org</email>