summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-11 20:04:46 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-11 20:04:46 +0000
commitcd1d1b2f2beaa4227662afd62a3d738b92320966 (patch)
treee932b758563976cd646d1c40279d12c53bf7f2cb /net-fs
parentraw-ldflags: fix typo in previous commit #441808#10 (diff)
downloadgentoo-2-cd1d1b2f2beaa4227662afd62a3d738b92320966.tar.gz
gentoo-2-cd1d1b2f2beaa4227662afd62a3d738b92320966.tar.bz2
gentoo-2-cd1d1b2f2beaa4227662afd62a3d738b92320966.zip
Add patches from Andrej Filipcic to fix building with linux-3.6 #437278 by Oliver Freyermuth.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs-kernel/ChangeLog10
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.6.1-r2.ebuild86
2 files changed, 94 insertions, 2 deletions
diff --git a/net-fs/openafs-kernel/ChangeLog b/net-fs/openafs-kernel/ChangeLog
index 81e847a024e9..8c8466d3145c 100644
--- a/net-fs/openafs-kernel/ChangeLog
+++ b/net-fs/openafs-kernel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/openafs-kernel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.139 2012/09/25 00:19:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.140 2012/11/11 20:04:46 vapier Exp $
+
+*openafs-kernel-1.6.1-r2 (11 Nov 2012)
+
+ 11 Nov 2012; Mike Frysinger <vapier@gentoo.org>
+ +openafs-kernel-1.6.1-r2.ebuild:
+ Add patches from Andrej Filipcic to fix building with linux-3.6 #437278 by
+ Oliver Freyermuth.
25 Sep 2012; Mike Frysinger <vapier@gentoo.org>
-openafs-kernel-1.4.14.ebuild, -openafs-kernel-1.6.0.ebuild,
@@ -683,4 +690,3 @@
This set of ebuilds exist to match openafs-1.2.13 and openafs-1.3.85
respectively. All this hard work was done to ease the pain for openafs users
on kernel upgrades, by Stefaan De Roeck <stefaan.deroeck@gmail.com>.
-
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.6.1-r2.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..35e006ce9496
--- /dev/null
+++ b/net-fs/openafs-kernel/openafs-kernel-1.6.1-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.6.1-r2.ebuild,v 1.1 2012/11/11 20:04:46 vapier Exp $
+
+EAPI="4"
+
+inherit eutils autotools multilib linux-mod versionator toolchain-funcs
+
+MY_PV=$(delete_version_separator '_')
+MY_PN=${PN/-kernel}
+MY_P2="${MY_PN}-${PV}"
+MY_P="${MY_PN}-${MY_PV}"
+PVER="3"
+DESCRIPTION="The OpenAFS distributed file system kernel module"
+HOMEPAGE="http://www.openafs.org/"
+# We always d/l the doc tarball as man pages are not USE=doc material
+SRC_URI="http://openafs.org/dl/openafs/${MY_PV}/${MY_P}-src.tar.bz2
+ mirror://gentoo/${MY_P2}-patches-${PVER}.tar.bz2"
+
+LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~x86-linux ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS KEYS"
+ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
+ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
+ERROR_KEYS="OpenAFS needs CONFIG_KEYS option enabled"
+
+QA_TEXTRELS_x86_fbsd="/boot/modules/libafs.ko"
+QA_TEXTRELS_amd64_fbsd="/boot/modules/libafs.ko"
+
+pkg_setup() {
+ if use kernel_linux; then
+ linux-mod_pkg_setup
+ fi
+}
+
+src_prepare() {
+ EPATCH_EXCLUDE="012_all_kbuild.patch" \
+ EPATCH_SUFFIX="patch" \
+ epatch "${WORKDIR}"/gentoo/patches
+
+ # packaging is f-ed up, so we can't run automake (i.e. eautoreconf)
+ sed -i 's/^\(\s*\)a/\1ea/' regen.sh
+ : # this line makes repoman ok with not calling eautoconf etc. directly
+ skipman=1
+ . regen.sh
+}
+
+src_configure() {
+ ARCH="$(tc-arch-kernel)" \
+ econf \
+ --with-linux-kernel-headers=${KV_DIR} \
+ --with-linux-kernel-build=${KV_OUT_DIR}
+}
+
+src_compile() {
+ ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die
+}
+
+src_install() {
+ if use kernel_linux; then
+ local srcdir=$(expr "${S}"/src/libafs/MODLOAD-*)
+ [[ -f ${srcdir}/libafs.${KV_OBJ} ]] || die "Couldn't find compiled kernel module"
+
+ MODULE_NAMES="libafs(fs/openafs:${srcdir})"
+
+ linux-mod_src_install
+ elif use kernel_FreeBSD; then
+ insinto /boot/modules
+ doins "${S}"/src/libafs/MODLOAD/libafs.ko
+ fi
+}
+
+pkg_postinst() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+}
+
+pkg_postrm() {
+ # Update linker.hints file
+ use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
+}