summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2009-01-31 17:34:09 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2009-01-31 17:34:09 +0000
commitc040fc32e2f206d39ca5edb9af6ac8aa155c1197 (patch)
treec0ca5ff04f25c8fcb85021d201d609017f46c663 /net-fs
parenthppa stable with Rej's blessing (diff)
downloadgentoo-2-c040fc32e2f206d39ca5edb9af6ac8aa155c1197.tar.gz
gentoo-2-c040fc32e2f206d39ca5edb9af6ac8aa155c1197.tar.bz2
gentoo-2-c040fc32e2f206d39ca5edb9af6ac8aa155c1197.zip
Add a patch from upstream to support newer linux kernel versions (fixing a.o. bug #255524)
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/openafs-kernel/ChangeLog11
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild58
2 files changed, 67 insertions, 2 deletions
diff --git a/net-fs/openafs-kernel/ChangeLog b/net-fs/openafs-kernel/ChangeLog
index a20be46f2169..4dbd2b20952c 100644
--- a/net-fs/openafs-kernel/ChangeLog
+++ b/net-fs/openafs-kernel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/openafs-kernel
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.115 2008/12/26 11:25:39 klausman Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/ChangeLog,v 1.116 2009/01/31 17:34:09 stefaan Exp $
+
+*openafs-kernel-1.4.8-r1 (31 Jan 2009)
+
+ 31 Jan 2009; Stefaan De Roeck <stefaan@gentoo.org>
+ +openafs-kernel-1.4.8-r1.ebuild:
+ Add a patch from upstream to support newer linux kernel versions (fixing
+ a.o. bug #255524)
26 Dec 2008; Tobias Klausmann <klausman@gentoo.org>
openafs-kernel-1.4.6.ebuild, openafs-kernel-1.4.6_p20080222.ebuild,
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild
new file mode 100644
index 000000000000..3d9ec954d78b
--- /dev/null
+++ b/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild,v 1.1 2009/01/31 17:34:09 stefaan Exp $
+
+inherit eutils linux-mod versionator toolchain-funcs
+
+PATCHVER=0.16
+MY_PN=${PN/-kernel}
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The OpenAFS distributed file system kernel module"
+HOMEPAGE="http://www.openafs.org/"
+SRC_URI="http://openafs.org/dl/${PV}/${MY_P}-src.tar.bz2
+ mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
+
+LICENSE="IBM openafs-krb5 openafs-krb5-a APSL-2 sun-rpc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
+
+CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
+ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
+ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+}
+
+src_unpack() {
+ unpack ${MY_P}-src.tar.bz2
+ unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
+ cd "${S}"
+
+ EPATCH_SUFFIX="patch" \
+ EPATCH_EXCLUDE="012_all_kbuild.patch" \
+ epatch ${PATCHDIR}
+
+ ./regen.sh || die "Failed: regenerating configure script"
+}
+
+src_compile() {
+ ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} \
+ --with-linux-kernel-build=${KV_OUT_DIR} || die "Failed: econf"
+
+ ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
+}
+
+src_install() {
+ MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
+ [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
+ || die "Couldn't find compiled kernel module"
+
+ MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
+
+ linux-mod_src_install
+}