summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-10-28 00:33:09 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-10-28 00:33:09 +0000
commitbfb65acd31688f492e886185cf734375b84cc591 (patch)
tree42b633aacf6039e8252a4b6c3574a2ad18e668ef /net-fs
parentversion bump (diff)
downloadgentoo-2-bfb65acd31688f492e886185cf734375b84cc591.tar.gz
gentoo-2-bfb65acd31688f492e886185cf734375b84cc591.tar.bz2
gentoo-2-bfb65acd31688f492e886185cf734375b84cc591.zip
version bump
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/autofs/ChangeLog7
-rw-r--r--net-fs/autofs/Manifest5
-rw-r--r--net-fs/autofs/autofs-4.0.0.ebuild71
-rw-r--r--net-fs/autofs/files/digest-autofs-4.0.01
-rw-r--r--net-fs/autofs/metadata.xml8
5 files changed, 89 insertions, 3 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index 9f0855d813df..a7fda569634f 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/autofs
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.20 2003/09/24 17:16:28 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.21 2003/10/28 00:33:07 rphillips Exp $
+
+*autofs-4.0.0 (27 Oct 2003)
+
+ 27 Oct 2003; Ryan Phillips <rphillips@gentoo.org> autofs-4.0.0.ebuild:
+ version bump. added as unstable. Thanks to Gregory Shimansky
*autofs-3.1.7-r6 (25 Sep 2003)
diff --git a/net-fs/autofs/Manifest b/net-fs/autofs/Manifest
index 657f94e190ad..52ecbb39d947 100644
--- a/net-fs/autofs/Manifest
+++ b/net-fs/autofs/Manifest
@@ -1,8 +1,9 @@
-MD5 d760e406f632b92ddb4e72a694128e94 autofs-4.0.0.ebuild 1803
+MD5 89fbeabd59dec980326f42c863cf863d autofs-4.0.0.ebuild 1802
MD5 4c3981d85d49586fe99bd5744de29318 autofs-3.1.7-r6.ebuild 1794
MD5 70a328a7cb89310eeb6ec33c609a3107 autofs-3.1.7-r3.ebuild 1313
MD5 57d0455e83cfef78f78092ad5a181c52 autofs-3.1.7-r5.ebuild 1772
-MD5 2894baa3b2030e5234331b55fa68181c ChangeLog 3530
+MD5 2d1177c343ed8d1d1311a8a335ded2c3 ChangeLog 3699
+MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
MD5 2c8659ab995069a50b2ed53da5f4e936 autofs-3.1.7-r4.ebuild 1750
MD5 a132f5883b92e2b509fa66e429f913ab files/autofs.confd 186
MD5 3e9a4415d9928180bd9d1a7a09d4d2e7 files/ldap_config.patch 785
diff --git a/net-fs/autofs/autofs-4.0.0.ebuild b/net-fs/autofs/autofs-4.0.0.ebuild
new file mode 100644
index 000000000000..a3c31fce285e
--- /dev/null
+++ b/net-fs/autofs/autofs-4.0.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-4.0.0.ebuild,v 1.1 2003/10/28 00:33:08 rphillips Exp $
+
+IUSE="ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kernel based automounter"
+HOMEPAGE="http://www.linux-consulting.com/Amd_AutoFS/autofs.html"
+SRC_URI="mirror://kernel/linux/daemons/${PN}/v4/${P}-1.tar.bz2"
+
+DEPEND="ldap? ( >=net-nds/openldap-1.2 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+
+src_unpack() {
+ unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/ldap_config.patch || die "ldap patch died"
+
+# cd ${S}/include
+# epatch ${FILESDIR}/automount.diff || die "automount patch died"
+
+ cd ${S}
+ autoconf
+
+ cd ${S}/daemon
+ sed -i 's/LIBS \= \-ldl/LIBS \= \-ldl \-lnsl \$\{LIBLDAP\}/' Makefile
+}
+
+src_compile() {
+ local myconf
+ use ldap || myconf="--without-openldap"
+
+ ./configure \
+ --host=${HOST} \
+ --prefix=/usr \
+ ${myconf} || die
+ make || die "make failed"
+}
+
+src_install() {
+ into /usr
+ dosbin daemon/automount
+ insinto /usr/lib/autofs
+ insopts -m 755
+ doins modules/*.so
+
+ dodoc COPYING COPYRIGHT NEWS README* TODO
+ cd man
+ doman auto.master.5 autofs.5 autofs.8 automount.8
+
+ cd ../samples
+ dodir /etc/autofs
+ cp ${FILESDIR}/auto.master ${D}/etc/autofs
+ cp ${FILESDIR}/auto.misc ${D}/etc/autofs
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/autofs.rc8 autofs
+ insinto /etc/conf.d ; newins ${FILESDIR}/autofs.confd autofs
+}
+
+pkg_postinst() {
+ einfo "Note: If you plan on using autofs for automounting"
+ einfo "remote NFS mounts without having the NFS daemon running"
+ einfo "please add portmap to your default run-level."
+ echo ""
+ einfo "Also the normal autofs status has been renamed stats"
+ einfo "as there is already a predefined Gentoo status"
+}
diff --git a/net-fs/autofs/files/digest-autofs-4.0.0 b/net-fs/autofs/files/digest-autofs-4.0.0
new file mode 100644
index 000000000000..5edf3308e23f
--- /dev/null
+++ b/net-fs/autofs/files/digest-autofs-4.0.0
@@ -0,0 +1 @@
+MD5 eca614ef301b49aa8105876e8abd91b5 autofs-4.0.0-1.tar.bz2 90036
diff --git a/net-fs/autofs/metadata.xml b/net-fs/autofs/metadata.xml
new file mode 100644
index 000000000000..fc52d7ba53dd
--- /dev/null
+++ b/net-fs/autofs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>rphillips@gentoo.org</email>
+</maintainer>
+</pkgmetadata>