summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-29 13:54:28 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-29 13:54:28 +0000
commit8470335e975f206bfecbe153c08ed8f0369a404e (patch)
tree496529180e6f03e493524bec457b42562a0937d5 /net-fs
parentStable for amd64 wrt bug #487796 (diff)
downloadgentoo-2-8470335e975f206bfecbe153c08ed8f0369a404e.tar.gz
gentoo-2-8470335e975f206bfecbe153c08ed8f0369a404e.tar.bz2
gentoo-2-8470335e975f206bfecbe153c08ed8f0369a404e.zip
Lots of dependency "fixes" (bug #489166, #489748, #489764, #489770). Minor improvements of the init scripts. Removed old (broken) ebuilds
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog12
-rw-r--r--net-fs/samba/files/4.0/samba4.initd-r173
-rw-r--r--net-fs/samba/files/4.1/samba4.initd-r171
-rw-r--r--net-fs/samba/samba-4.0.10-r1.ebuild (renamed from net-fs/samba/samba-4.0.10.ebuild)31
-rw-r--r--net-fs/samba/samba-4.0.9.ebuild161
-rw-r--r--net-fs/samba/samba-4.1.0-r1.ebuild (renamed from net-fs/samba/samba-4.1.0.ebuild)31
-rw-r--r--net-fs/samba/samba-4.1.0_rc4.ebuild153
7 files changed, 122 insertions, 410 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 360bfe459c86..a463395c618d 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.618 2013/10/14 08:00:42 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.619 2013/10/29 13:54:28 polynomial-c Exp $
+
+*samba-4.1.0-r1 (29 Oct 2013)
+*samba-4.0.10-r1 (29 Oct 2013)
+
+ 29 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> -samba-4.0.9.ebuild,
+ -samba-4.0.10.ebuild, +samba-4.0.10-r1.ebuild, -samba-4.1.0_rc4.ebuild,
+ -samba-4.1.0.ebuild, +samba-4.1.0-r1.ebuild, files/4.0/samba4.initd-r1,
+ files/4.1/samba4.initd-r1:
+ Lots of dependency "fixes" (bug #489166, #489748, #489764, #489770). Minor
+ improvements of the init scripts. Removed old (broken) ebuilds.
*samba-4.1.0 (14 Oct 2013)
diff --git a/net-fs/samba/files/4.0/samba4.initd-r1 b/net-fs/samba/files/4.0/samba4.initd-r1
index b1d5cc91782a..434cc5ff8592 100644
--- a/net-fs/samba/files/4.0/samba4.initd-r1
+++ b/net-fs/samba/files/4.0/samba4.initd-r1
@@ -1,59 +1,56 @@
#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/4.0/samba4.initd-r1,v 1.1 2012/11/24 23:59:23 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/4.0/samba4.initd-r1,v 1.2 2013/10/29 13:54:28 polynomial-c Exp $
extra_started_commands="reload"
+piddir="/var/run"
depend() {
- after slapd
- need net
- use cupsd
+ after slapd
+ need net
+ use cupsd
}
DAEMONNAME="${SVCNAME##samba.}"
[ "${DAEMONNAME}" != "samba" ] && daemon_list=${DAEMONNAME}
signal_do() {
- local signal="$1"
- [ -z "${signal}" ] && return 0
-
- local result=0 last_result=0 daemon= cmd_exec=
- for daemon in ${daemon_list} ; do
- eval cmd_exec=\$${daemon}_${signal}
- if [ -n "${cmd_exec}" ]; then
- ebegin "${my_service_name} -> ${signal}: ${daemon}"
- #echo ${cmd} '->' ${!cmd}
- ${cmd_exec} > /dev/null
- last_result=$?
- eend ${last_result}
- fi
- result=$(( ${result} + ${last_result} ))
- done
- return ${result}
-}
-
-mkdir_sambadirs() {
- [ -d /var/run/samba ] || mkdir -p /var/run/samba
+ local signal="$1"
+ [ -z "${signal}" ] && return 0
+
+ local result=0 last_result=0 daemon= cmd_exec=
+ for daemon in ${daemon_list} ; do
+ eval cmd_exec=\$${daemon}_${signal}
+ if [ -n "${cmd_exec}" ]; then
+ ebegin "${my_service_name} -> ${signal}: ${daemon}"
+ #echo ${cmd} '->' ${!cmd}
+ ${cmd_exec} > /dev/null
+ last_result=$?
+ eend ${last_result}
+ fi
+ result=$(( ${result} + ${last_result} ))
+ done
+ return ${result}
}
start() {
- ${my_service_PRE}
- mkdir_sambadirs
- signal_do start && return 0
+ ${my_service_PRE}
+ [ -d "${piddir}" ] || mkdir -p "${piddir}"
+ signal_do start && return 0
- eerror "Error: starting services (see system logs)"
- signal_do stop
- return 1
+ eerror "Error: starting services (see system logs)"
+ signal_do stop
+ return 1
}
stop() {
- ${my_service_PRE}
- if signal_do stop ; then
- ${my_service_POST}
- return 0
- fi
+ ${my_service_PRE}
+ if signal_do stop ; then
+ ${my_service_POST}
+ return 0
+ fi
}
reload() {
- ${my_service_PRE}
- signal_do reload
+ ${my_service_PRE}
+ signal_do reload
}
diff --git a/net-fs/samba/files/4.1/samba4.initd-r1 b/net-fs/samba/files/4.1/samba4.initd-r1
index ebdd3f18f750..0c93a1333784 100644
--- a/net-fs/samba/files/4.1/samba4.initd-r1
+++ b/net-fs/samba/files/4.1/samba4.initd-r1
@@ -1,59 +1,56 @@
#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/4.1/samba4.initd-r1,v 1.1 2013/08/05 04:41:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/files/4.1/samba4.initd-r1,v 1.2 2013/10/29 13:54:28 polynomial-c Exp $
extra_started_commands="reload"
+piddir="/var/run"
depend() {
- after slapd
- need net
- use cupsd
+ after slapd
+ need net
+ use cupsd
}
DAEMONNAME="${SVCNAME##samba.}"
[ "${DAEMONNAME}" != "samba" ] && daemon_list=${DAEMONNAME}
signal_do() {
- local signal="$1"
- [ -z "${signal}" ] && return 0
-
- local result=0 last_result=0 daemon= cmd_exec=
- for daemon in ${daemon_list} ; do
- eval cmd_exec=\$${daemon}_${signal}
- if [ -n "${cmd_exec}" ]; then
- ebegin "${my_service_name} -> ${signal}: ${daemon}"
- #echo ${cmd} '->' ${!cmd}
- ${cmd_exec} > /dev/null
- last_result=$?
- eend ${last_result}
- fi
- result=$(( ${result} + ${last_result} ))
- done
- return ${result}
-}
-
-mkdir_sambadirs() {
- [ -d /var/run/samba ] || mkdir -p /var/run/samba
+ local signal="$1"
+ [ -z "${signal}" ] && return 0
+
+ local result=0 last_result=0 daemon= cmd_exec=
+ for daemon in ${daemon_list} ; do
+ eval cmd_exec=\$${daemon}_${signal}
+ if [ -n "${cmd_exec}" ]; then
+ ebegin "${my_service_name} -> ${signal}: ${daemon}"
+ #echo ${cmd} '->' ${!cmd}
+ ${cmd_exec} > /dev/null
+ last_result=$?
+ eend ${last_result}
+ fi
+ result=$(( ${result} + ${last_result} ))
+ done
+ return ${result}
}
start() {
- ${my_service_PRE}
- mkdir_sambadirs
- signal_do start && return 0
+ ${my_service_PRE}
+ [ -d "${piddir}" ] || mkdir -p "${piddir}"
+ signal_do start && return 0
- eerror "Error: starting services (see system logs)"
- signal_do stop
- return 1
+ eerror "Error: starting services (see system logs)"
+ signal_do stop
+ return 1
}
stop() {
- ${my_service_PRE}
- if signal_do stop ; then
- ${my_service_POST}
- return 0
- fi
+ ${my_service_PRE}
+ if signal_do stop ; then
+ ${my_service_POST}
+ return 0
+ fi
}
reload() {
- ${my_service_PRE}
- signal_do reload
+ ${my_service_PRE}
+ signal_do reload
}
diff --git a/net-fs/samba/samba-4.0.10.ebuild b/net-fs/samba/samba-4.0.10-r1.ebuild
index 4f3b7fb07e69..3e5d15f11fcb 100644
--- a/net-fs/samba/samba-4.0.10.ebuild
+++ b/net-fs/samba/samba-4.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.10.ebuild,v 1.1 2013/10/08 11:20:47 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.10-r1.ebuild,v 1.1 2013/10/29 13:54:28 polynomial-c Exp $
EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
@@ -25,32 +25,41 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addns ads aio avahi client cluster cups gnutls iprint
-ldap pam quota selinux swat syslog test winbind"
+IUSE="acl addns ads aio avahi client cluster cups fam gnutls iprint
+ldap quota selinux swat syslog test winbind"
+# sys-apps/attr is an automagic dependency (see bug #489748)
+# dev-libs/libaio is an automagic dependency (see bug #489764)
+# sys-libs/pam is an automagic dependency (see bug #489770)
RDEPEND="${PYTHON_DEPS}
+ >=app-crypt/heimdal-1.5[-ssl]
dev-libs/iniparser
+ dev-libs/libaio
dev-libs/popt
sys-libs/readline
virtual/libiconv
dev-python/subunit
+ sys-apps/attr
sys-libs/libcap
>=sys-libs/ldb-1.1.16
>=sys-libs/tdb-1.2.11[python]
>=sys-libs/talloc-2.0.8[python]
>=sys-libs/tevent-0.9.18
sys-libs/zlib
- >=app-crypt/heimdal-1.5[-ssl]
+ virtual/pam
+ acl? ( virtual/acl )
addns? ( net-dns/bind-tools[gssapi] )
client? ( net-fs/cifs-utils[ads?] )
cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ fam? ( virtual/fam )
+ gnutls? ( dev-libs/libgcrypt
+ >=net-libs/gnutls-1.4.0 )
ldap? ( net-nds/openldap )
- gnutls? ( >=net-libs/gnutls-1.4.0 )
selinux? ( sec-policy/selinux-samba )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="ads? ( ldap )"
+REQUIRED_USE="ads? ( acl ldap )"
RESTRICT="mirror"
@@ -86,6 +95,7 @@ src_configure() {
--localstatedir=/var \
--with-modulesdir=/usr/$(get_libdir)/samba \
--with-pammodulesdir=/$(get_libdir)/security \
+ --with-piddir=/run/${PN} \
--disable-rpath \
--disable-rpath-install \
--nopyc \
@@ -94,18 +104,19 @@ src_configure() {
--bundled-libraries=NONE \
--builtin-libraries=NONE \
$(use_with addns dnsupdate) \
- $(use_with acl) \
+ $(use_with acl acl-support) \
$(use_with ads) \
$(use_with aio aio-support) \
$(use_enable avahi) \
$(use_with cluster cluster-support) \
$(use_enable cups) \
+ $(use_with fam) \
$(use_enable gnutls) \
$(use_enable iprint) \
$(use_with ldap) \
- $(use_with pam) \
- $(use_with pam pam_smbpass) \
- $(use_with quota) \
+ --with-pam \
+ --with-pam_smbpass \
+ $(use_with quota quotas) \
$(use_with syslog) \
$(use_with swat) \
$(use_with winbind)
diff --git a/net-fs/samba/samba-4.0.9.ebuild b/net-fs/samba/samba-4.0.9.ebuild
deleted file mode 100644
index e9da7e50f769..000000000000
--- a/net-fs/samba/samba-4.0.9.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.0.9.ebuild,v 1.1 2013/09/06 11:58:35 polynomial-c Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-r1 waf-utils multilib linux-info systemd
-
-MY_PV="${PV/_rc/rc}"
-MY_P="${PN}-${MY_PV}"
-
-if [ "${PV}" = "4.9999" ]; then
- EGIT_REPO_URI="git://git.samba.org/samba.git"
- KEYWORDS=""
- inherit git-2
-else
- SRC_URI="mirror://samba/stable/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~hppa ~x86"
-fi
-
-DESCRIPTION="Samba Suite Version 4"
-HOMEPAGE="http://www.samba.org/"
-LICENSE="GPL-3"
-
-SLOT="0"
-
-IUSE="acl addns ads aio avahi client cluster cups gnutls iprint
-ldap pam quota selinux swat syslog test winbind"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/iniparser
- dev-libs/popt
- sys-libs/readline
- virtual/libiconv
- dev-python/subunit
- sys-libs/libcap
- >=sys-libs/ldb-1.1.16
- >=sys-libs/tdb-1.2.11[python]
- >=sys-libs/talloc-2.0.8[python]
- >=sys-libs/tevent-0.9.18
- sys-libs/zlib
- >=app-crypt/heimdal-1.5[-ssl]
- addns? ( net-dns/bind-tools[gssapi] )
- client? ( net-fs/cifs-utils[ads?] )
- cluster? ( >=dev-db/ctdb-1.0.114_p1 )
- ldap? ( net-nds/openldap )
- gnutls? ( >=net-libs/gnutls-1.4.0 )
- selinux? ( sec-policy/selinux-samba )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-REQUIRED_USE="ads? ( ldap )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}/${MY_P}"
-
-CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python_export_best
- if use aio; then
- if ! linux_config_exists || ! linux_chkconfig_present AIO; then
- ewarn "You must enable AIO support in your kernel config, "
- ewarn "to be able to support asynchronous I/O. "
- ewarn "You can find it at"
- ewarn
- ewarn "General Support"
- ewarn " Enable AIO support "
- ewarn
- ewarn "and recompile your kernel..."
- fi
- fi
-}
-
-src_configure() {
- local myconf=''
- use "cluster" && myconf+=" --with-ctdb-dir=/usr"
- use "test" && myconf+=" --enable-selftest"
- myconf="${myconf} \
- --enable-fhs \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-modulesdir=/usr/$(get_libdir)/samba \
- --with-pammodulesdir=/$(get_libdir)/security \
- --disable-rpath \
- --disable-rpath-install \
- --nopyc \
- --nopyo \
- --disable-ntdb \
- --bundled-libraries=NONE \
- --builtin-libraries=NONE \
- $(use_with addns dnsupdate) \
- $(use_with acl) \
- $(use_with ads) \
- $(use_with aio aio-support) \
- $(use_enable avahi) \
- $(use_with cluster cluster-support) \
- $(use_enable cups) \
- $(use_enable gnutls) \
- $(use_enable iprint) \
- $(use_with ldap) \
- $(use_with pam) \
- $(use_with pam pam_smbpass) \
- $(use_with quota) \
- $(use_with syslog) \
- $(use_with swat) \
- $(use_with winbind)
- "
- use "ads" && myconf+=" --with-shared-modules=idmap_ad"
-
- CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
- waf-utils_src_configure ${myconf}
-}
-
-src_install() {
- waf-utils_src_install
-
- # Seems like the build script gets the shebangs correct by itself
- # (4.0.6)
- #python_replicate_script \
- # "${D}/usr/sbin/samba_dnsupdate" \
- # "${D}/usr/sbin/samba_spnupdate" \
- # "${D}/usr/sbin/samba_upgradedns" \
- # "${D}/usr/sbin/samba_kcc" \
- # "${D}/usr/bin/samba-tool"
-
- # Make all .so files executable
- find "${D}" -type f -name "*.so" -exec chmod +x {} +
-
- # Install init script and conf.d file
- newinitd "${CONFDIR}/samba4.initd-r1" samba
- newconfd "${CONFDIR}/samba4.confd" samba
-
- systemd_dotmpfilesd "${FILESDIR}"/samba.conf
- systemd_dounit "${FILESDIR}"/nmbd.service
- systemd_dounit "${FILESDIR}"/smbd.{service,socket}
- systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
- systemd_dounit "${FILESDIR}"/winbindd.service
-}
-
-src_test() {
- "${WAF_BINARY}" test || die "test failed"
-}
-
-pkg_postinst() {
- elog "This is is the first stable release of Samba 4.0"
-
- ewarn "Be aware the this release contains the best of all of Samba's"
- ewarn "technology parts, both a file server (that you can reasonably expect"
- ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
- ewarn "controller work previously known as 'samba4'."
-
- elog "For further information and migration steps make sure to read "
- elog "http://samba.org/samba/history/${P}.html "
- elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
- elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
-}
diff --git a/net-fs/samba/samba-4.1.0.ebuild b/net-fs/samba/samba-4.1.0-r1.ebuild
index 2ad8a7173cd3..77efc3b33891 100644
--- a/net-fs/samba/samba-4.1.0.ebuild
+++ b/net-fs/samba/samba-4.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.0.ebuild,v 1.1 2013/10/14 08:00:42 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.0-r1.ebuild,v 1.1 2013/10/29 13:54:28 polynomial-c Exp $
EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
@@ -19,32 +19,41 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addns ads aio avahi client cluster cups gnutls iprint
-ldap pam quota selinux syslog test winbind"
+IUSE="acl addns ads aio avahi client cluster cups fam gnutls iprint
+ldap quota selinux syslog test winbind"
+# sys-apps/attr is an automagic dependency (see bug #489748)
+# dev-libs/libaio is an automagic dependency (see bug #489764)
+# sys-libs/pam is an automagic dependency (see bug #489770)
RDEPEND="${PYTHON_DEPS}
+ >=app-crypt/heimdal-1.5[-ssl]
dev-libs/iniparser
+ dev-libs/libaio
dev-libs/popt
sys-libs/readline
virtual/libiconv
dev-python/subunit
+ sys-apps/attr
sys-libs/libcap
>=sys-libs/ldb-1.1.16
>=sys-libs/tdb-1.2.11[python]
>=sys-libs/talloc-2.0.8[python]
>=sys-libs/tevent-0.9.18
sys-libs/zlib
- >=app-crypt/heimdal-1.5[-ssl]
+ virtual/pam
+ acl? ( virtual/acl )
addns? ( net-dns/bind-tools[gssapi] )
client? ( net-fs/cifs-utils[ads?] )
cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+ fam? ( virtual/fam )
+ gnutls? ( dev-libs/libgcrypt
+ >=net-libs/gnutls-1.4.0 )
ldap? ( net-nds/openldap )
- gnutls? ( >=net-libs/gnutls-1.4.0 )
selinux? ( sec-policy/selinux-samba )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
-REQUIRED_USE="ads? ( ldap )"
+REQUIRED_USE="ads? ( acl ldap )"
RESTRICT="mirror"
@@ -80,6 +89,7 @@ src_configure() {
--localstatedir=/var \
--with-modulesdir=/usr/$(get_libdir)/samba \
--with-pammodulesdir=/$(get_libdir)/security \
+ --with-piddir=/run/${PN} \
--disable-rpath \
--disable-rpath-install \
--nopyc \
@@ -87,18 +97,19 @@ src_configure() {
--bundled-libraries=ntdb \
--builtin-libraries=ntdb \
$(use_with addns dnsupdate) \
- $(use_with acl) \
+ $(use_with acl acl-support) \
$(use_with ads) \
$(use_with aio aio-support) \
$(use_enable avahi) \
$(use_with cluster cluster-support) \
$(use_enable cups) \
+ $(use_with fam) \
$(use_enable gnutls) \
$(use_enable iprint) \
$(use_with ldap) \
- $(use_with pam) \
- $(use_with pam pam_smbpass) \
- $(use_with quota) \
+ --with-pam \
+ --with-pam_smbpass \
+ $(use_with quota quotas) \
$(use_with syslog) \
$(use_with winbind)
"
diff --git a/net-fs/samba/samba-4.1.0_rc4.ebuild b/net-fs/samba/samba-4.1.0_rc4.ebuild
deleted file mode 100644
index 02d1962bc995..000000000000
--- a/net-fs/samba/samba-4.1.0_rc4.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.0_rc4.ebuild,v 1.1 2013/10/01 08:20:51 polynomial-c Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_{6,7} )
-
-inherit python-r1 waf-utils multilib linux-info systemd
-
-MY_PV="${PV/_rc/rc}"
-MY_P="${PN}-${MY_PV}"
-
-SRC_URI="mirror://samba/rc/${MY_P}.tar.gz"
-KEYWORDS="~amd64 ~hppa ~x86"
-
-DESCRIPTION="Samba Suite Version 4"
-HOMEPAGE="http://www.samba.org/"
-LICENSE="GPL-3"
-
-SLOT="0"
-
-IUSE="acl addns ads aio avahi client cluster cups gnutls iprint
-ldap pam quota selinux syslog test winbind"
-
-RDEPEND="${PYTHON_DEPS}
- dev-libs/iniparser
- dev-libs/popt
- sys-libs/readline
- virtual/libiconv
- dev-python/subunit
- sys-libs/libcap
- >=sys-libs/ldb-1.1.16
- >=sys-libs/tdb-1.2.11[python]
- >=sys-libs/talloc-2.0.8[python]
- >=sys-libs/tevent-0.9.18
- sys-libs/zlib
- >=app-crypt/heimdal-1.5[-ssl]
- addns? ( net-dns/bind-tools[gssapi] )
- client? ( net-fs/cifs-utils[ads?] )
- cluster? ( >=dev-db/ctdb-1.0.114_p1 )
- ldap? ( net-nds/openldap )
- gnutls? ( >=net-libs/gnutls-1.4.0 )
- selinux? ( sec-policy/selinux-samba )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-REQUIRED_USE="ads? ( ldap )"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}/${MY_P}"
-
-CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
-
-WAF_BINARY="${S}/buildtools/bin/waf"
-
-pkg_setup() {
- python_export_best
- if use aio; then
- if ! linux_config_exists || ! linux_chkconfig_present AIO; then
- ewarn "You must enable AIO support in your kernel config, "
- ewarn "to be able to support asynchronous I/O. "
- ewarn "You can find it at"
- ewarn
- ewarn "General Support"
- ewarn " Enable AIO support "
- ewarn
- ewarn "and recompile your kernel..."
- fi
- fi
-}
-
-src_configure() {
- local myconf=''
- use "cluster" && myconf+=" --with-ctdb-dir=/usr"
- use "test" && myconf+=" --enable-selftest"
- myconf="${myconf} \
- --enable-fhs \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-modulesdir=/usr/$(get_libdir)/samba \
- --with-pammodulesdir=/$(get_libdir)/security \
- --disable-rpath \
- --disable-rpath-install \
- --nopyc \
- --nopyo \
- --bundled-libraries=ntdb \
- --builtin-libraries=ntdb \
- $(use_with addns dnsupdate) \
- $(use_with acl) \
- $(use_with ads) \
- $(use_with aio aio-support) \
- $(use_enable avahi) \
- $(use_with cluster cluster-support) \
- $(use_enable cups) \
- $(use_enable gnutls) \
- $(use_enable iprint) \
- $(use_with ldap) \
- $(use_with pam) \
- $(use_with pam pam_smbpass) \
- $(use_with quota) \
- $(use_with syslog) \
- $(use_with winbind)
- "
- use "ads" && myconf+=" --with-shared-modules=idmap_ad"
-
- CPPFLAGS="-I/usr/include/et ${CPPFLAGS}" \
- waf-utils_src_configure ${myconf}
-}
-
-src_install() {
- waf-utils_src_install
-
- # Seems like the build script gets the shebangs correct by itself
- # (4.0.6)
- #python_replicate_script \
- # "${D}/usr/sbin/samba_dnsupdate" \
- # "${D}/usr/sbin/samba_spnupdate" \
- # "${D}/usr/sbin/samba_upgradedns" \
- # "${D}/usr/sbin/samba_kcc" \
- # "${D}/usr/bin/samba-tool"
-
- # Make all .so files executable
- find "${D}" -type f -name "*.so" -exec chmod +x {} +
-
- # Install init script and conf.d file
- newinitd "${CONFDIR}/samba4.initd-r1" samba
- newconfd "${CONFDIR}/samba4.confd" samba
-
- systemd_dotmpfilesd "${FILESDIR}"/samba.conf
- systemd_dounit "${FILESDIR}"/nmbd.service
- systemd_dounit "${FILESDIR}"/smbd.{service,socket}
- systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
- systemd_dounit "${FILESDIR}"/winbindd.service
-}
-
-src_test() {
- "${WAF_BINARY}" test || die "test failed"
-}
-
-pkg_postinst() {
- elog "This is is the first stable release of Samba 4.0"
-
- ewarn "Be aware the this release contains the best of all of Samba's"
- ewarn "technology parts, both a file server (that you can reasonably expect"
- ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
- ewarn "controller work previously known as 'samba4'."
-
- elog "For further information and migration steps make sure to read "
- elog "http://samba.org/samba/history/${P}.html "
- elog "http://samba.org/samba/history/${PN}-4.0.0.html and"
- elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
-}