summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-10 19:14:21 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-10 19:14:21 +0000
commit6f993e61d3a997151881cf7f713829f69156f1da (patch)
treea237b56a5d0be78f9ed91a58d36fc324d7881d91 /net-fs
parentupdate copyright (diff)
downloadgentoo-2-6f993e61d3a997151881cf7f713829f69156f1da.tar.gz
gentoo-2-6f993e61d3a997151881cf7f713829f69156f1da.tar.bz2
gentoo-2-6f993e61d3a997151881cf7f713829f69156f1da.zip
Version bump #136038 by Mario Fetka.
(Portage version: 2.1)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs-utils/ChangeLog7
-rw-r--r--net-fs/nfs-utils/files/digest-nfs-utils-1.0.86
-rw-r--r--net-fs/nfs-utils/nfs-utils-1.0.8.ebuild119
3 files changed, 131 insertions, 1 deletions
diff --git a/net-fs/nfs-utils/ChangeLog b/net-fs/nfs-utils/ChangeLog
index a4a2fae21946..05a86d0bcd8e 100644
--- a/net-fs/nfs-utils/ChangeLog
+++ b/net-fs/nfs-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/nfs-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.73 2006/03/09 00:43:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/ChangeLog,v 1.74 2006/06/10 19:14:21 vapier Exp $
+
+*nfs-utils-1.0.8 (10 Jun 2006)
+
+ 10 Jun 2006; Mike Frysinger <vapier@gentoo.org> +nfs-utils-1.0.8.ebuild:
+ Version bump #136038 by Mario Fetka.
09 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+files/nfs-utils-1.0.7-no-stripping.patch, nfs-utils-1.0.7-r2.ebuild:
diff --git a/net-fs/nfs-utils/files/digest-nfs-utils-1.0.8 b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.8
new file mode 100644
index 000000000000..3b3b84421ec7
--- /dev/null
+++ b/net-fs/nfs-utils/files/digest-nfs-utils-1.0.8
@@ -0,0 +1,6 @@
+MD5 7bbb84a20b521f852cdf9d40286b298e nfs-utils-1.0.8-CITI_NFS4_ALL-2.dif 36171
+RMD160 7b8fc4905326b2affdf20305ec407be69bfdd8f5 nfs-utils-1.0.8-CITI_NFS4_ALL-2.dif 36171
+SHA256 d27507189f7641a1a67dac808288cf9560c067380fe2d7f441211ed9e208ba17 nfs-utils-1.0.8-CITI_NFS4_ALL-2.dif 36171
+MD5 74fc2dd04b40c9d619ca41d3787ef8db nfs-utils-1.0.8.tar.gz 732829
+RMD160 2650814ca04dd4447855e4055243d0c66588e8aa nfs-utils-1.0.8.tar.gz 732829
+SHA256 b7e2304167b2c1bdcd0cad7ee005c7030556897ec8bd8c13fcdcc3365c0cd1a0 nfs-utils-1.0.8.tar.gz 732829
diff --git a/net-fs/nfs-utils/nfs-utils-1.0.8.ebuild b/net-fs/nfs-utils/nfs-utils-1.0.8.ebuild
new file mode 100644
index 000000000000..29de8e6b2d0e
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-1.0.8.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/nfs-utils/nfs-utils-1.0.8.ebuild,v 1.1 2006/06/10 19:14:21 vapier Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://nfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nfs/${P}.tar.gz
+ http://www.citi.umich.edu/projects/nfsv4/linux/nfs-utils-patches/1.0.8-2/nfs-utils-1.0.8-CITI_NFS4_ALL-2.dif"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="nonfsv4 tcpd kerberos"
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ >=net-nds/portmap-5b-r6
+ !nonfsv4? (
+ >=dev-libs/libevent-1.0b
+ >=net-libs/libnfsidmap-0.16
+ )
+ kerberos? ( app-crypt/mit-krb5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.51"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${DISTDIR}"/nfs-utils-1.0.8-CITI_NFS4_ALL-2.dif
+ epatch "${FILESDIR}"/${PN}-1.0.7-man-pages.patch #107991
+
+return 0
+ #epatch "${FILESDIR}"/${P}-gcc4.patch #88421
+ #epatch "${FILESDIR}"/${P}-no-stripping.patch
+
+ # getrpcbynumber_r is not in the SuSv3 spec. disable it for uClibc
+ #epatch "${FILESDIR}"/nfs-utils-1.0.6-uclibc.patch
+
+ # since the usn36 patch is now integrated (at least the parts we care about)
+ # into 1.0.7, we need to re-apply the rquoted patch (04 Feb 2005 agriffis)
+ #epatch "${FILESDIR}"/nfs-utils-0.3.3-rquotad-overflow.patch
+
+ #sed -i 's:@mandir@:$(install_prefix)@mandir@:' config.mk.in
+}
+
+src_compile() {
+# --disable-rquotad
+ econf \
+ --mandir=/usr/share/man \
+ --with-statedir=/var/lib/nfs \
+ --enable-nfsv3 \
+ --enable-secure-statd \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_enable !nonfsv4 nfsv4) \
+ $(use_enable kerberos gss) \
+ || die "Configure failed"
+
+ # parallel make fails for depend target
+# emake -j1 depend || die "failed to make depend"
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+return 0
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ dodir /usr/lib/nfs
+ keepdir /var/lib/nfs/{sm,sm.bak}
+ mv "${D}"/var/lib/nfs/* "${D}"/usr/lib/nfs
+ keepdir /var/lib/nfs
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${D}"/usr/sbin/rpc.{lockd,statd} "${D}"/sbin/
+
+ dodoc ChangeLog README
+ docinto linux-nfs ; dodoc linux-nfs/*
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+ use !nonfsv4 && doins utils/idmapd/idmapd.conf
+ use kerberos && newins support/gssapi/SAMPLE_gssapi_mech.conf
+
+ doinitd "${FILESDIR}"/nfs "${FILESDIR}"/nfsmount
+ newconfd "${FILESDIR}"/nfs.confd nfs
+
+ # uClibc doesn't provide rpcgen like glibc, so lets steal it from nfs-utils
+ if ! use elibc_glibc ; then
+ dobin tools/rpcgen/rpcgen || die "rpcgen"
+ newdoc tools/rpcgen/README README.rpcgen
+ fi
+}
+
+pkg_preinst() {
+ if [[ -s ${ROOT}/etc/exports ]] ; then
+ rm -f "${IMAGE}"/etc/exports
+ fi
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing.
+ # In src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. This fixes
+ # bug 30486
+ local f
+ for f in "${ROOT}"/usr/lib/nfs/*; do
+ [[ -f ${ROOT}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from /usr/lib/nfs to /var/lib/nfs"
+ cp -pPR ${f} "${ROOT}"/var/lib/nfs/
+ done
+}