summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2008-04-10 10:22:14 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2008-04-10 10:22:14 +0000
commitc3c8a5d3b47a864b5900316e77d9faa7e8e02ed1 (patch)
treefa1d89beff4572fef558e75c304ad1c6099a5f3c /net-fs/openafs
parentYet another version bump (diff)
downloadgentoo-2-c3c8a5d3b47a864b5900316e77d9faa7e8e02ed1.tar.gz
gentoo-2-c3c8a5d3b47a864b5900316e77d9faa7e8e02ed1.tar.bz2
gentoo-2-c3c8a5d3b47a864b5900316e77d9faa7e8e02ed1.zip
Yet another version bump
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/ChangeLog8
-rw-r--r--net-fs/openafs/openafs-1.4.7_pre3.ebuild151
2 files changed, 158 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index b19068dcb317..878695e18d5b 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/openafs
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.144 2008/04/05 09:27:58 stefaan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.145 2008/04/10 10:22:14 stefaan Exp $
+
+*openafs-1.4.7_pre3 (10 Apr 2008)
+
+ 10 Apr 2008; Stefaan De Roeck <stefaan@gentoo.org>
+ +openafs-1.4.7_pre3.ebuild:
+ Yet another version bump
04 Apr 2008; Stefaan De Roeck <stefaan@gentoo.org>
-files/openafs-pinstall-execve-1.2.10.patch, -files/CellServDB,
diff --git a/net-fs/openafs/openafs-1.4.7_pre3.ebuild b/net-fs/openafs/openafs-1.4.7_pre3.ebuild
new file mode 100644
index 000000000000..459b47760671
--- /dev/null
+++ b/net-fs/openafs/openafs-1.4.7_pre3.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.4.7_pre3.ebuild,v 1.1 2008/04/10 10:22:14 stefaan Exp $
+
+inherit flag-o-matic eutils toolchain-funcs versionator pam
+
+PATCHVER=0.14
+MY_PV=${PV/_pre/pre}
+MY_P=${PN}-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="The OpenAFS distributed file system"
+HOMEPAGE="http://www.openafs.org/"
+SRC_URI="http://openafs.org/dl/candidate/${MY_PV}/${MY_P}-src.tar.bz2
+ doc? ( http://openafs.org/dl/candidate/${MY_PV}/${MY_P}-doc.tar.bz2 )
+ mirror://gentoo/${PN}-gentoo-${PATCHVER}.tar.bz2"
+
+LICENSE="IBM openafs-krb5 openafs-krb5-a APSL-2 sun-rpc"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug kerberos pam doc"
+
+RDEPEND="~net-fs/openafs-kernel-${PV}
+ pam? ( sys-libs/pam )
+ kerberos? ( virtual/krb5 )"
+
+PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
+CONFDIR=${WORKDIR}/gentoo/configs
+SCRIPTDIR=${WORKDIR}/gentoo/scripts
+
+src_unpack() {
+ unpack ${A}; cd "${S}"
+
+ # Apply patches to apply chosen compiler settings, fix the hardcoded paths
+ # to be more FHS friendly, and the fix the incorrect typecasts for va_arg
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+
+ # enable UCONTEXT on alpha
+ epatch "${FILESDIR}"/openafs-alpha-ucontext.patch
+ # don't use mapfiles to strip symbols (bug #202489)
+ epatch "${FILESDIR}"/openafs-1.4.5-shared-libs.patch
+
+ # disable XCFLAGS override
+ sed -i 's/^[ \t]*XCFLAGS.*/:/' src/cf/osconf.m4
+ # disable compiler choice override
+ sed -i 's/^[ \t]\+\(CC\|CCOBJ\|MT_CC\)="[^ ]*\(.*\)"/\1="${CC}\2"/' src/cf/osconf.m4
+
+ ./regen.sh || die "Failed: regenerating configure script"
+}
+
+src_compile() {
+ # cannot use "use_with" macro, as --without-krb5-config crashes the econf
+ local myconf=""
+ if use kerberos; then
+ myconf="--with-krb5-conf=$(type -p krb5-config)"
+ fi
+
+ # fix linux version at 2.6
+ AFS_SYSKVERS=26 \
+ XCFLAGS="${CFLAGS}" \
+ econf \
+ $(use_enable pam) \
+ $(use_enable debug) \
+ --enable-largefile-fileserver \
+ --enable-supergroups \
+ --disable-kernel-module \
+ ${myconf} || die econf
+
+ emake -j1 all_nolibafs || die "Build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install_nolibafs || die "Installing failed"
+
+ # pam_afs and pam_afs.krb have been installed in irregular locations, fix
+ if use pam; then
+ dopammod "${D}"/usr/$(get_libdir)/pam_afs*
+ rm -f "${D}"/usr/$(get_libdir)/pam_afs*
+ fi
+
+ # compile_et collides with com_err. Remove it from this package.
+ rm "${D}"/usr/bin/compile_et
+
+ # avoid collision with mit_krb5's version of kpasswd
+ (cd "${D}"/usr/bin; mv kpasswd kpasswd_afs)
+ use doc && (cd "${D}"/usr/share/man/man1; mv kpasswd.1 kpasswd_afs.1)
+
+ # minimal documentation
+ dodoc ${CONFDIR}/README ${CONFDIR}/CellServDB
+
+ # documentation package
+ if use doc; then
+ use pam && doman src/pam/pam_afs.5
+
+ cp -pPR doc/* "${D}"/usr/share/doc/${PF}
+ fi
+
+ # Gentoo related scripts
+ newconfd ${CONFDIR}/openafs-client openafs-client
+ newconfd ${CONFDIR}/openafs-server openafs-server
+ newinitd ${SCRIPTDIR}/openafs-client openafs-client
+ newinitd ${SCRIPTDIR}/openafs-server openafs-server
+
+ # used directories: client
+ keepdir /etc/openafs
+ keepdir /var/cache/openafs
+
+ # used directories: server
+ keepdir /etc/openafs/server
+ diropts -m0700
+ keepdir /var/lib/openafs
+ keepdir /var/lib/openafs/db
+ diropts -m0755
+ keepdir /var/lib/openafs/logs
+
+ # link logfiles to /var/log
+ dosym ../lib/openafs/logs /var/log/openafs
+}
+
+pkg_preinst() {
+ ## Somewhat intelligently install default configuration files
+ ## (when they are not present)
+ # CellServDB
+ if [ ! -e "${ROOT}"etc/openafs/CellServDB ] \
+ || grep "GCO Public CellServDB" "${ROOT}"etc/openafs/CellServDB &> /dev/null
+ then
+ cp ${CONFDIR}/CellServDB "${D}"etc/openafs
+ fi
+ # cacheinfo: use a default location cache, 200 megabyte in size
+ # (should be safe for about any root partition, the user can increase
+ # the size as required)
+ if [ ! -e "${ROOT}"etc/openafs/cacheinfo ]; then
+ echo "/afs:/var/cache/openafs:200000" > "${D}"etc/openafs/cacheinfo
+ fi
+ # ThisCell: default to "openafs.org"
+ if [ ! -e "${ROOT}"etc/openafs/ThisCell ]; then
+ echo "openafs.org" > "${D}"etc/openafs/ThisCell
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "This installation should work out of the box (at least the"
+ elog "client part doing global afs-cell browsing, unless you had"
+ elog "a previous and different configuration). If you want to"
+ elog "set up your own cell or modify the standard config,"
+ elog "please have a look at the Gentoo OpenAFS documentation"
+ elog "(warning: it is not yet up to date wrt the new file locations)"
+ elog
+ elog "The documentation can be found at:"
+ elog " http://www.gentoo.org/doc/en/openafs.xml"
+}