summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-21 22:57:17 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-21 22:57:17 +0000
commit82cfda69f2b8bb8955d0fdc52194ccb26cce028a (patch)
treeac81af505e004ff190c7d4c8caedd2e3eab122c4 /net-fs/openafs-kernel
parentVersion bump. (diff)
downloadgentoo-2-82cfda69f2b8bb8955d0fdc52194ccb26cce028a.tar.gz
gentoo-2-82cfda69f2b8bb8955d0fdc52194ccb26cce028a.tar.bz2
gentoo-2-82cfda69f2b8bb8955d0fdc52194ccb26cce028a.zip
old
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/openafs-kernel')
-rw-r--r--net-fs/openafs-kernel/files/STABLE14-linux-flush-compare-2008040217
-rw-r--r--net-fs/openafs-kernel/files/STABLE14-linux-flush-unlock-2008040220
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.6.ebuild55
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.6_p20080222.ebuild60
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.7.ebuild56
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild58
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.8.ebuild58
-rw-r--r--net-fs/openafs-kernel/openafs-kernel-1.4.8_pre3.ebuild59
8 files changed, 0 insertions, 383 deletions
diff --git a/net-fs/openafs-kernel/files/STABLE14-linux-flush-compare-20080402 b/net-fs/openafs-kernel/files/STABLE14-linux-flush-compare-20080402
deleted file mode 100644
index faeb752a63b1..000000000000
--- a/net-fs/openafs-kernel/files/STABLE14-linux-flush-compare-20080402
+++ /dev/null
@@ -1,17 +0,0 @@
-===================================================================
-RCS file: /cvs/openafs/src/afs/LINUX/osi_vnodeops.c,v
-retrieving revision 1.81.2.62
-retrieving revision 1.81.2.63
-diff -u -r1.81.2.62 -r1.81.2.63
---- openafs/src/afs/LINUX/osi_vnodeops.c 2008/04/02 13:11:42 1.81.2.62
-+++ openafs/src/afs/LINUX/osi_vnodeops.c 2008/04/02 18:27:13 1.81.2.63
-@@ -570,7 +570,7 @@
-
- AFS_GLOCK();
-
-- if (fp->f_flags | O_RDONLY) { /* readers dont flush */
-+ if ((fp->f_flags & O_ACCMODE) == O_RDONLY) { /* readers dont flush */
- AFS_GUNLOCK();
- return 0;
- }
-
diff --git a/net-fs/openafs-kernel/files/STABLE14-linux-flush-unlock-20080402 b/net-fs/openafs-kernel/files/STABLE14-linux-flush-unlock-20080402
deleted file mode 100644
index 1261810ee099..000000000000
--- a/net-fs/openafs-kernel/files/STABLE14-linux-flush-unlock-20080402
+++ /dev/null
@@ -1,20 +0,0 @@
-===================================================================
-RCS file: /cvs/openafs/src/afs/LINUX/osi_vnodeops.c,v
-retrieving revision 1.81.2.61
-retrieving revision 1.81.2.62
-diff -u -r1.81.2.61 -r1.81.2.62
---- openafs/src/afs/LINUX/osi_vnodeops.c 2008/03/26 04:17:32 1.81.2.61
-+++ openafs/src/afs/LINUX/osi_vnodeops.c 2008/04/02 13:11:42 1.81.2.62
-@@ -570,8 +570,10 @@
-
- AFS_GLOCK();
-
-- if (fp->f_flags | O_RDONLY) /* readers dont flush */
-+ if (fp->f_flags | O_RDONLY) { /* readers dont flush */
-+ AFS_GUNLOCK();
- return 0;
-+ }
-
- credp = crref();
- vcp = VTOAFS(FILE_INODE(fp));
-
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.6.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.6.ebuild
deleted file mode 100644
index c4745b2196fb..000000000000
--- a/net-fs/openafs-kernel/openafs-kernel-1.4.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.6.ebuild,v 1.7 2010/02/06 10:51:10 ulm Exp $
-
-inherit eutils linux-mod versionator toolchain-funcs
-
-PATCHVER=0.14
-MY_PN=${PN/-kernel}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The OpenAFS distributed file system kernel module"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${PV}/${MY_P}-src.tar.bz2
- mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
-IUSE=""
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-
-CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
-ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
-ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
-
-pkg_setup() {
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-src.tar.bz2
- unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- cd "${S}"
-
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} || die "Failed: econf"
-
- ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
-}
-
-src_install() {
- MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
- [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
- || die "Couldn't find compiled kernel module"
-
- MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
-
- linux-mod_src_install
-}
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.6_p20080222.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.6_p20080222.ebuild
deleted file mode 100644
index ba53bf5cc30c..000000000000
--- a/net-fs/openafs-kernel/openafs-kernel-1.4.6_p20080222.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.6_p20080222.ebuild,v 1.6 2010/02/06 10:51:10 ulm Exp $
-
-inherit eutils linux-mod versionator toolchain-funcs
-
-PATCHVER=0.14
-MY_PN=${PN/-kernel}
-MY_PV_DATE=${PV#*_p}
-MY_PV=${PV%_p*}
-MY_P=${MY_PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The OpenAFS distributed file system kernel module"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${MY_PV}/${MY_P}-src.tar.bz2
- mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- mirror://gentoo/${MY_PN}-${MY_PV}-cvs${MY_PV_DATE}.patch.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
-IUSE=""
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-
-CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
-ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
-ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
-
-pkg_setup() {
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-src.tar.bz2
- unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- cd "${S}"
-
- epatch "${DISTDIR}"/${MY_P}-cvs${MY_PV_DATE}.patch.bz2
-
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} || die "Failed: econf"
-
- ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
-}
-
-src_install() {
- MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
- [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
- || die "Couldn't find compiled kernel module"
-
- MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
-
- linux-mod_src_install
-}
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.7.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.7.ebuild
deleted file mode 100644
index 507b0edc740d..000000000000
--- a/net-fs/openafs-kernel/openafs-kernel-1.4.7.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.7.ebuild,v 1.4 2010/02/06 10:51:10 ulm Exp $
-
-inherit eutils linux-mod versionator toolchain-funcs
-
-PATCHVER=0.14
-MY_PN=${PN/-kernel}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The OpenAFS distributed file system kernel module"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${PV}/${MY_P}-src.tar.bz2
- mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-
-CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
-ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
-ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
-
-pkg_setup() {
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-src.tar.bz2
- unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- cd "${S}"
-
- EPATCH_EXCLUDE="006_all_ppc64.patch" \
- EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_OUT_DIR} || die "Failed: econf"
-
- ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
-}
-
-src_install() {
- MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
- [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
- || die "Couldn't find compiled kernel module"
-
- MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
-
- linux-mod_src_install
-}
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild
deleted file mode 100644
index 24d284d96f7e..000000000000
--- a/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.8-r1.ebuild,v 1.2 2010/02/06 10:51:10 ulm Exp $
-
-inherit eutils linux-mod versionator toolchain-funcs
-
-PATCHVER=0.16
-MY_PN=${PN/-kernel}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The OpenAFS distributed file system kernel module"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${PV}/${MY_P}-src.tar.bz2
- mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-
-CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
-ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
-ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
-
-pkg_setup() {
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-src.tar.bz2
- unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- cd "${S}"
-
- EPATCH_SUFFIX="patch" \
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- epatch ${PATCHDIR}
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} \
- --with-linux-kernel-build=${KV_OUT_DIR} || die "Failed: econf"
-
- ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
-}
-
-src_install() {
- MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
- [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
- || die "Couldn't find compiled kernel module"
-
- MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
-
- linux-mod_src_install
-}
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.8.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.8.ebuild
deleted file mode 100644
index 5b8087751606..000000000000
--- a/net-fs/openafs-kernel/openafs-kernel-1.4.8.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.8.ebuild,v 1.5 2010/02/06 10:51:10 ulm Exp $
-
-inherit eutils linux-mod versionator toolchain-funcs
-
-PATCHVER=0.15
-MY_PN=${PN/-kernel}
-MY_P=${MY_PN}-${PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The OpenAFS distributed file system kernel module"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/${PV}/${MY_P}-src.tar.bz2
- mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
-IUSE=""
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-
-CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
-ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
-ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
-
-pkg_setup() {
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-src.tar.bz2
- unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- cd "${S}"
-
- EPATCH_SUFFIX="patch" \
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- epatch ${PATCHDIR}
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} \
- --with-linux-kernel-build=${KV_OUT_DIR} || die "Failed: econf"
-
- ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
-}
-
-src_install() {
- MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
- [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
- || die "Couldn't find compiled kernel module"
-
- MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
-
- linux-mod_src_install
-}
diff --git a/net-fs/openafs-kernel/openafs-kernel-1.4.8_pre3.ebuild b/net-fs/openafs-kernel/openafs-kernel-1.4.8_pre3.ebuild
deleted file mode 100644
index 852dfb26218d..000000000000
--- a/net-fs/openafs-kernel/openafs-kernel-1.4.8_pre3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs-kernel/openafs-kernel-1.4.8_pre3.ebuild,v 1.3 2010/02/06 10:51:10 ulm Exp $
-
-inherit eutils linux-mod versionator toolchain-funcs
-
-PATCHVER=0.15
-MY_PN=${PN/-kernel}
-MY_PV=${PV/_pre/pre}
-MY_P=${MY_PN}-${MY_PV}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="The OpenAFS distributed file system kernel module"
-HOMEPAGE="http://www.openafs.org/"
-SRC_URI="http://openafs.org/dl/candidate/${MY_PV}/${MY_P}-src.tar.bz2
- mirror://gentoo/${MY_PN}-gentoo-${PATCHVER}.tar.bz2"
-
-LICENSE="IBM BSD openafs-krb5-a APSL-2 sun-rpc"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-PATCHDIR=${WORKDIR}/gentoo/patches/$(get_version_component_range 1-2)
-
-CONFIG_CHECK="!DEBUG_RODATA ~!AFS_FS"
-ERROR_DEBUG_RODATA="OpenAFS is incompatible with linux' CONFIG_DEBUG_RODATA option"
-ERROR_AFS_FS="OpenAFS conflicts with the in-kernel AFS-support. Make sure not to load both at the same time!"
-
-pkg_setup() {
- linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${MY_P}-src.tar.bz2
- unpack ${MY_PN}-gentoo-${PATCHVER}.tar.bz2
- cd "${S}"
-
- EPATCH_SUFFIX="patch" \
- EPATCH_EXCLUDE="012_all_kbuild.patch" \
- epatch ${PATCHDIR}
-
- ./regen.sh || die "Failed: regenerating configure script"
-}
-
-src_compile() {
- ARCH="$(tc-arch-kernel)" econf --with-linux-kernel-headers=${KV_DIR} \
- --with-linux-kernel-build=${KV_OUT_DIR} || die "Failed: econf"
-
- ARCH="$(tc-arch-kernel)" emake -j1 only_libafs || die "Failed: emake"
-}
-
-src_install() {
- MOD_SRCDIR=$(expr ${S}/src/libafs/MODLOAD-*)
- [ -f ${MOD_SRCDIR}/libafs.${KV_OBJ} ] \
- || die "Couldn't find compiled kernel module"
-
- MODULE_NAMES='libafs(fs/openafs:$MOD_SRCDIR)'
-
- linux-mod_src_install
-}