summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-07-02 10:07:02 +0000
committerPeter Volkov <pva@gentoo.org>2010-07-02 10:07:02 +0000
commitf63192922861c3503d87c540224d19c9b6ffedda (patch)
treef0c6878ec88a33f717c1d45e80c9e0ee6e3a07ff /net-firewall
parentUSE=expat was quite useless, expat is mandatory in polkit. Don't create user ... (diff)
downloadgentoo-2-f63192922861c3503d87c540224d19c9b6ffedda.tar.gz
gentoo-2-f63192922861c3503d87c540224d19c9b6ffedda.tar.bz2
gentoo-2-f63192922861c3503d87c540224d19c9b6ffedda.zip
Avoid maintainer mode, make build verbose, fix ED->D typo. Drop old.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/xtables-addons/ChangeLog6
-rw-r--r--net-firewall/xtables-addons/xtables-addons-1.26.ebuild137
-rw-r--r--net-firewall/xtables-addons/xtables-addons-1.27.ebuild10
3 files changed, 10 insertions, 143 deletions
diff --git a/net-firewall/xtables-addons/ChangeLog b/net-firewall/xtables-addons/ChangeLog
index 310232d92216..eaa85088430c 100644
--- a/net-firewall/xtables-addons/ChangeLog
+++ b/net-firewall/xtables-addons/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/xtables-addons
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/ChangeLog,v 1.3 2010/06/01 09:01:35 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/ChangeLog,v 1.4 2010/07/02 10:07:02 pva Exp $
+
+ 02 Jul 2010; Peter Volkov <pva@gentoo.org> -xtables-addons-1.26.ebuild,
+ xtables-addons-1.27.ebuild:
+ Avoid maintainer mode, make build verbose, fix ED->D typo. Drop old.
*xtables-addons-1.27 (01 Jun 2010)
diff --git a/net-firewall/xtables-addons/xtables-addons-1.26.ebuild b/net-firewall/xtables-addons/xtables-addons-1.26.ebuild
deleted file mode 100644
index 324962a30723..000000000000
--- a/net-firewall/xtables-addons/xtables-addons-1.26.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/xtables-addons-1.26.ebuild,v 1.1 2010/05/08 06:52:48 pva Exp $
-
-EAPI="2"
-
-inherit eutils linux-mod
-
-DESCRIPTION="extensions not yet accepted in the main kernel/iptables (patch-o-matic(-ng) successor)"
-HOMEPAGE="http://xtables-addons.sourceforge.net/"
-SRC_URI="mirror://sourceforge/xtables-addons/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="modules"
-
-MODULES="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark echo dhcpmac delude chaos account"
-
-for mod in ${MODULES}; do
- IUSE="${IUSE} xtables_addons_${mod}"
-done
-
-RDEPEND="virtual/modutils
- >=net-firewall/iptables-1.4.3
- >virtual/linux-sources-2.6.22
- xtables_addons_ipset? ( !net-firewall/ipset )"
-
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use modules; then
- get_version
- check_modules_supported
- # CONFIG_IP_NF_CONNTRACK{,_MARK} doesn't exist in >virtual/linux-sources-2.6.22
- CONFIG_CHECK="NF_CONNTRACK NF_CONNTRACK_MARK"
- linux-mod_pkg_setup
-
- if ! linux_chkconfig_present IPV6; then
- SKIP_IPV6_MODULES="ip6table_rawpost"
- fi
- fi
-}
-
-# Helper for maintainer: cheks if all possible MODULES are listed.
-XA_qa_check() {
- local all_modules
- all_modules=$(sed -n '/^build_/{s/build_\(.*\)=.*/\L\1/;G;s/\n/ /;s/ $//;h}; ${x;p}' "${S}/mconfig")
- if [[ ${all_modules} != ${MODULES} ]]; then
- ewarn "QA: Modules in mconfig differ from \$MODULES in ebuild."
- ewarn "Please, update MODULES in ebuild."
- ewarn "'${all_modules}'"
- fi
-}
-
-# Is there any use flag set?
-XA_has_something_to_build() {
- local mod
- for mod in ${MODULES}; do
- use xtables_addons_${mod} && return
- done
-
- eerror "All modules are disabled. What do you want me to build?"
- eerror "Please, set XTABLES_ADDONS to any combination of"
- eerror "${MODULES}"
- die "All modules are disabled."
-}
-
-# Parse Kbuid files and generates list of sources
-XA_get_module_name() {
- [[ $# != 1 ]] && die "XA_get_sources_for_mod: needs exactly one argument."
- local mod objdir build_mod sources_list
- mod=${1}
- objdir=${S}/extensions
- build_mod=$(sed -n "s/\(build_${mod}\)=.*/\1/Ip" "${S}/mconfig")
- sources_list=$(sed -n "/^obj-[$][{]${build_mod}[}]/\
- {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
- "${objdir}/Kbuild")
-
- if [[ -d ${S}/extensions/${sources_list} ]]; then
- objdir=${S}/extensions/${sources_list}
- sources_list=$(sed -n "/^obj-m/\
- {s:obj-[^+]\+ [+]=[[:space:]]*::;s:[.]o::g;p}" \
- "${objdir}/Kbuild")
- fi
- for mod_src in ${sources_list}; do
- has ${mod_src} ${SKIP_IPV6_MODULES} || \
- echo " ${mod_src}(xtables_addons:${S}/extensions:${objdir})"
- done
-}
-
-src_prepare() {
- XA_qa_check
- XA_has_something_to_build
-
- local mod module_name
- if use modules; then
- MODULE_NAMES="compat_xtables(xtables_addons:${S}/extensions:)"
- fi
- for mod in ${MODULES}; do
- if use xtables_addons_${mod}; then
- sed "s/\(build_${mod}=\).*/\1m/I" -i mconfig || die
- if use modules; then
- for module_name in $(XA_get_module_name ${mod}); do
- MODULE_NAMES+=" ${module_name}"
- done
- fi
- else
- sed "s/\(build_${mod}=\).*/\1n/I" -i mconfig || die
- fi
- done
-
- sed -e 's/depmod -a/true/' -i Makefile.{in,am} || die
- sed -e '/^all-local:/{s: modules::}' \
- -e '/^install-exec-local:/{s: modules_install::}' \
- -i extensions/Makefile.{in,am} || die
-}
-
-src_configure() {
- unset ARCH # .. or it'll look for /arch/amd64/Makefile in linux sources
- export KBUILD_EXTMOD=${S} # Avoid build in /usr/src/linux #250407
- econf --prefix=/ \
- --libexecdir=/lib/ \
- --with-kbuild="${KV_DIR}"
-}
-
-src_compile() {
- emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
- use modules && BUILD_TARGETS="modules" linux-mod_src_compile
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- use modules && linux-mod_src_install
- dodoc README doc/* || die
- find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+'
-}
diff --git a/net-firewall/xtables-addons/xtables-addons-1.27.ebuild b/net-firewall/xtables-addons/xtables-addons-1.27.ebuild
index c135f078450a..23dd77f3a8dd 100644
--- a/net-firewall/xtables-addons/xtables-addons-1.27.ebuild
+++ b/net-firewall/xtables-addons/xtables-addons-1.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/xtables-addons-1.27.ebuild,v 1.1 2010/06/01 09:01:35 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/xtables-addons/xtables-addons-1.27.ebuild,v 1.2 2010/07/02 10:07:02 pva Exp $
EAPI="3"
@@ -110,10 +110,10 @@ src_prepare() {
fi
done
- sed -e 's/depmod -a/true/' -i Makefile.{in,am} || die
+ sed -e 's/depmod -a/true/' -i Makefile.in || die
sed -e '/^all-local:/{s: modules::}' \
-e '/^install-exec-local:/{s: modules_install::}' \
- -i extensions/Makefile.{in,am} || die
+ -i extensions/Makefile.in || die
}
src_configure() {
@@ -125,12 +125,12 @@ src_configure() {
}
src_compile() {
- emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" || die
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" V=1 || die
use modules && BUILD_TARGETS="modules" linux-mod_src_compile
}
src_install() {
- emake DESTDIR="${ED}" install || die
+ emake DESTDIR="${D}" install || die
use modules && linux-mod_src_install
dodoc README doc/* || die
find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+'