summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-24 11:25:46 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-24 11:25:46 +0000
commitc139946eea82cc0447c72d23a957688cb7fa0193 (patch)
tree290d7e90fdb5e46eae8a81518b5c31616c381b4c /net-firewall
parentFixing dependency on dev-libs/glib. Bug #203207 (diff)
downloadgentoo-2-c139946eea82cc0447c72d23a957688cb7fa0193.tar.gz
gentoo-2-c139946eea82cc0447c72d23a957688cb7fa0193.tar.bz2
gentoo-2-c139946eea82cc0447c72d23a957688cb7fa0193.zip
Version bump #203161 by Nebojsa Trpkovic.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/files/digest-iptables-1.4.09
-rw-r--r--net-firewall/iptables/iptables-1.4.0.ebuild201
3 files changed, 216 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 9ff2f3266898..9522ed30630d 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.153 2007/12/24 09:43:38 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.154 2007/12/24 11:25:46 vapier Exp $
+
+*iptables-1.4.0 (24 Dec 2007)
+
+ 24 Dec 2007; Mike Frysinger <vapier@gentoo.org> +iptables-1.4.0.ebuild:
+ Version bump #203161 by Nebojsa Trpkovic.
*iptables-1.3.8-r3 (24 Dec 2007)
diff --git a/net-firewall/iptables/files/digest-iptables-1.4.0 b/net-firewall/iptables/files/digest-iptables-1.4.0
new file mode 100644
index 000000000000..d850a23b6863
--- /dev/null
+++ b/net-firewall/iptables/files/digest-iptables-1.4.0
@@ -0,0 +1,9 @@
+MD5 133a27ce2aa95581e91d364827f68293 iptables-1.3.6-imq.diff 5723
+RMD160 7158923558f9ad82973cda9dbec2c10b86e13e9c iptables-1.3.6-imq.diff 5723
+SHA256 f507319d01dd1810b497e0700a67d8f9668dd1363b1f8e1b09097cf2bbc26ab7 iptables-1.3.6-imq.diff 5723
+MD5 90cfa8a554a29b0b859a625e701af2a7 iptables-1.4.0.tar.bz2 181610
+RMD160 6f6a29cbe0e55261607acc1183e04482c444286e iptables-1.4.0.tar.bz2 181610
+SHA256 fd9a978035e6a8f73344f986c84a222dc4ac3706b901e0c1ecae9647db5e5d52 iptables-1.4.0.tar.bz2 181610
+MD5 e153d23a3879f33f4a96ed6b706609e3 netfilter-layer7-v2.17.tar.gz 160408
+RMD160 9823d7b411e18160dc8501a6a5d2129f75e727e1 netfilter-layer7-v2.17.tar.gz 160408
+SHA256 2e2893757a3b22f2786ead2045efae1d6a52942a89d0159c39ba907531b60c01 netfilter-layer7-v2.17.tar.gz 160408
diff --git a/net-firewall/iptables/iptables-1.4.0.ebuild b/net-firewall/iptables/iptables-1.4.0.ebuild
new file mode 100644
index 000000000000..e944fe82066f
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.0.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.0.ebuild,v 1.1 2007/12/24 11:25:46 vapier Exp $
+
+inherit eutils toolchain-funcs linux-info
+
+L7_PV=2.17
+L7_P=netfilter-layer7-v${L7_PV}
+IMQ_PATCH=iptables-1.3.6-imq.diff
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/ http://www.linuximq.net/ http://l7-filter.sf.net/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2
+ imq? ( http://www.linuximq.net/patchs/${IMQ_PATCH} )
+ l7filter? ( mirror://sourceforge/l7-filter/${L7_P}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="extensions imq ipv6 l7filter static"
+
+DEPEND="virtual/os-headers
+ l7filter? ( virtual/linux-sources )
+ imq? ( virtual/linux-sources )"
+RDEPEND=""
+
+pkg_setup() {
+ if use l7filter || use imq || use extensions ; then
+ ewarn "WARNING: 3rd party extensions has been enabled."
+ ewarn "This means that iptables will use your currently installed"
+ ewarn "kernel in ${KERNEL_DIR} as headers for iptables."
+ ewarn
+ if use extensions ; then
+ ewarn "You may have to patch your kernel to allow iptables to build."
+ ewarn "Please check http://ftp.netfilter.org/pub/patch-o-matic-ng/snapshot/ for patches"
+ ewarn "for your kernel."
+ ewarn
+ fi
+ linux-info_pkg_setup
+ fi
+
+ if kernel_is ge 2 6 20
+ then
+ L7FILE=${KERNEL_DIR}/net/netfilter/xt_layer7.c
+ else
+ L7FILE=${KERNEL_DIR}/net/ipv4/netfilter/ipt_layer7.c
+ fi
+ if use l7filter && \
+ [ ! -f "${L7FILE}" ]; then
+ die "For layer 7 support emerge net-misc/l7-filter-${L7_PV} before this"
+ fi
+ if use imq && \
+ [ ! -f "${KERNEL_DIR}/net/ipv4/netfilter/ipt_IMQ.c" ]; then
+ die "For IMQ support add a patch from http://www.linuximq.net/patches.html to your kernel"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ if use l7filter
+ then
+ unpack ${L7_P}.tar.gz
+ fi
+ cd "${S}"
+
+ # this provide's grsec's stealth match
+ EPATCH_OPTS="-p0" \
+ epatch "${FILESDIR}"/1.3.1-files/grsecurity-1.2.8-iptables.patch-1.3.1
+ sed -i \
+ -e "s/PF_EXT_SLIB:=/PF_EXT_SLIB:=stealth /g" \
+ extensions/Makefile || die "failed to enable stealth extension"
+
+ local check base=${PORTAGE_CONFIGROOT}/etc/portage/patches
+ for check in {${CATEGORY}/${PF},${CATEGORY}/${P},${CATEGORY}/${PN}}; do
+ EPATCH_SOURCE=${base}/${CTARGET}/${check}
+ [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${CHOST}/${check}
+ [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${base}/${check}
+ if [[ -d ${EPATCH_SOURCE} ]] ; then
+ EPATCH_SUFFIX="patch"
+ EPATCH_FORCE="yes" \
+ EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
+ epatch
+ break
+ fi
+ done
+
+ if use imq ; then
+ EPATCH_OPTS="-p1" epatch "${DISTDIR}"/${IMQ_PATCH}
+ for OA in extensions/.IMQ-test extensions/.IMQ-test6 ; do
+ mv ${OA} ${OA}.orig
+ tr '\015' '\012' < ${OA}.orig > ${OA}
+ rm ${OA}.orig
+ done
+ chmod +x extensions/.IMQ-test*
+ fi
+ if use l7filter ; then
+ #yes choosing 2.6.20 was deliberate - upstream mistake possibly
+ if kernel_is ge 2 6 20
+ then
+ L7_PATCH=iptables-1.3-for-kernel-2.6.20forward-layer7-${L7_PV}.patch
+ else
+ L7_PATCH=iptables-1.3-for-kernel-pre2.6.20-layer7-${L7_PV}.patch
+ fi
+ EPATCH_OPTS="-p1" epatch "${WORKDIR}"/${L7_P}/${L7_PATCH}
+ chmod +x extensions/.layer7-test*
+ fi
+
+ if ! use extensions ; then
+ cat <<-EOF > "${S}"/include/linux/compiler.h
+ #define __user
+ EOF
+ fi
+}
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf=""
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/$(get_libdir)"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ # iptables and libraries are now installed to /sbin and /lib, so that
+ # systems with remote network-mounted /usr filesystems can get their
+ # network interfaces up and running correctly without /usr.
+ use ipv6 || myconf="${myconf} DO_IPV6=0"
+ use static && myconf="${myconf} NO_SHARED_LIBS=0"
+ export myconf
+ if ! use l7filter && ! use imq && ! use extensions ; then
+ export KERNEL_DIR=$(
+ # ugh -- iptables has scripts which check for the existence of
+ # files so we need to give it the right path to our toolchains
+ # include dir where the linux headers are.
+ # FYI IPTABLES: YOU FAIL
+ echo '#include <linux/limits.h>' | $(tc-getCPP) - | grep -o '/[^"]*linux/limits.h' | sed s:/include/linux/limits.h::
+ )
+ export KBUILD_OUTPUT=${KERNEL_DIR}
+ diemsg="failure"
+ else
+ diemsg="failure - with l7filter and/or imq patch and/or other miscellanious patches added"
+ fi
+ export diemsg
+}
+
+src_compile() {
+ src_defs
+ emake \
+ COPT_FLAGS="${CFLAGS}" ${myconf} \
+ CC="$(tc-getCC)" \
+ || die "${diemsg}"
+}
+
+src_install() {
+ src_defs
+ emake ${myconf} \
+ DESTDIR="${D}" \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ install install-devel || die "${diemsg}"
+
+ dodir /usr/$(get_libdir)
+ mv -f "${D}"/$(get_libdir)/*.a "${D}"/usr/$(get_libdir)
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables
+
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables
+ fi
+}
+
+pkg_postinst() {
+ elog "This package now includes an initscript which loads and saves"
+ elog "rules stored in /var/lib/iptables/rules-save"
+ use ipv6 && elog "and /var/lib/ip6tables/rules-save"
+ elog "This location can be changed in /etc/conf.d/iptables"
+ elog
+ elog "If you are using the iptables initsscript you should save your"
+ elog "rules using the new iptables version before rebooting."
+ elog
+ elog "If you are upgrading to a >=2.4.21 kernel you may need to rebuild"
+ elog "iptables."
+ elog
+ ewarn "!!! ipforwarding is not a part of the iptables initscripts."
+ ewarn
+ ewarn "To enable ipforwarding at bootup:"
+ ewarn "/etc/sysctl.conf and set net.ipv4.ip_forward = 1"
+ if use ipv6 ; then
+ ewarn "and/or"
+ ewarn " net.ipv6.ip_forward = 1"
+ ewarn "for ipv6."
+ fi
+ if has_version '=net-firewall/iptables-1.2*' ; then
+ ewarn
+ ewarn "When upgrading from iptables-1.2.x, you may be unable to remove"
+ ewarn "rules added with iptables-1.2.x. This is a known issue, please see:"
+ ewarn "http://bugs.gentoo.org/92535"
+ fi
+}