summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-10-12 14:13:35 +0000
committerPeter Volkov <pva@gentoo.org>2011-10-12 14:13:35 +0000
commit70d02874e3cb56e45e86007cb2b9104e6ab88f55 (patch)
treefbe04a69403347adf80aeeeb34d02a331eed2455 /net-firewall
parentold (diff)
downloadgentoo-2-70d02874e3cb56e45e86007cb2b9104e6ab88f55.tar.gz
gentoo-2-70d02874e3cb56e45e86007cb2b9104e6ab88f55.tar.bz2
gentoo-2-70d02874e3cb56e45e86007cb2b9104e6ab88f55.zip
On second thought drop USE=ipv6: userspace should work is the same independently of USE=ipv6 and kernel side will depend on kernel configuration.
(Portage version: 2.1.10.25/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipset/ChangeLog7
-rw-r--r--net-firewall/ipset/ipset-6.9.1-r2.ebuild10
2 files changed, 10 insertions, 7 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 7fed3705e64e..17fbf7ade8cb 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.55 2011/10/12 13:26:16 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.56 2011/10/12 14:13:35 pva Exp $
+
+ 12 Oct 2011; Peter Volkov <pva@gentoo.org> ipset-6.9.1-r2.ebuild:
+ On second thought drop USE=ipv6: userspace should work is the same
+ independently of USE=ipv6 and kernel side will depend on kernel
+ configuration.
*ipset-6.9.1-r2 (12 Oct 2011)
diff --git a/net-firewall/ipset/ipset-6.9.1-r2.ebuild b/net-firewall/ipset/ipset-6.9.1-r2.ebuild
index 0b82ecf471b6..6d89ad5ea9cb 100644
--- a/net-firewall/ipset/ipset-6.9.1-r2.ebuild
+++ b/net-firewall/ipset/ipset-6.9.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.9.1-r2.ebuild,v 1.1 2011/10/12 13:26:16 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-6.9.1-r2.ebuild,v 1.2 2011/10/12 14:13:35 pva Exp $
EAPI="4"
inherit autotools linux-info linux-mod
@@ -15,7 +15,7 @@ SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="ipv6 modules"
+IUSE="modules"
RDEPEND=">=net-firewall/iptables-1.4.4
net-libs/libmnl"
@@ -44,9 +44,7 @@ check_header_patch() {
pkg_setup() {
get_version
CONFIG_CHECK="NETFILTER"
- use ipv6 && CONFIG_CHECK+=" IP6_NF_IPTABLES"
ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
- ERROR_IP6_NF_IPTABLES="ipset requires IP6_NF_IPTABLES support in your kernel."
build_modules=0
if use modules; then
@@ -65,11 +63,11 @@ pkg_setup() {
fi
else
eerror "Nonmodular kernel detected, but USE=modules. Either build"
- eerror "modular kernel or disable USE=modules"
+ eerror "modular kernel (without IP_SET) or disable USE=modules"
die "Nonmodular kernel detected, will not build kernel modules"
fi
fi
- linux-mod_pkg_setup
+ [[ ${build_modules} -eq 1 ]] && linux-mod_pkg_setup
}
src_prepare() {