summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-03-08 14:26:49 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-03-08 14:26:49 +0000
commit6a65b7fe6ef08270616c6e7613ee2d3517f92967 (patch)
tree0ebbe932bc3100e5e6dea3e3e87aa8482b448d4f /net-firewall
parentRemove old versions. (diff)
downloadgentoo-2-6a65b7fe6ef08270616c6e7613ee2d3517f92967.tar.gz
gentoo-2-6a65b7fe6ef08270616c6e7613ee2d3517f92967.tar.bz2
gentoo-2-6a65b7fe6ef08270616c6e7613ee2d3517f92967.zip
Migrate to EAPI 2.
(Portage version: 2.2_rc20/cvs/Linux 2.6.29-rc6 i686)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-common/ChangeLog7
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild15
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild12
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild15
4 files changed, 22 insertions, 27 deletions
diff --git a/net-firewall/shorewall-common/ChangeLog b/net-firewall/shorewall-common/ChangeLog
index a39d79e98531..665d4d056617 100644
--- a/net-firewall/shorewall-common/ChangeLog
+++ b/net-firewall/shorewall-common/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-common
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.23 2009/02/28 18:46:12 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.24 2009/03/08 14:26:49 betelgeuse Exp $
+
+ 08 Mar 2009; Petteri Räty <betelgeuse@gentoo.org>
+ shorewall-common-4.0.15.ebuild, shorewall-common-4.2.4.ebuild,
+ shorewall-common-4.2.6.ebuild:
+ Migrate to EAPI 2.
28 Feb 2009; Peter Volkov <pva@gentoo.org>
-shorewall-common-4.0.12.ebuild, -shorewall-common-4.0.13.ebuild,
diff --git a/net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild b/net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild
index cde51d79bdb3..df8b8af738fe 100644
--- a/net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild
+++ b/net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild,v 1.2 2009/02/28 18:46:12 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.15.ebuild,v 1.3 2009/03/08 14:26:49 betelgeuse Exp $
+
+EAPI="2"
inherit eutils versionator
@@ -24,16 +26,10 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
DEPEND=">=net-firewall/iptables-1.2.4
- sys-apps/iproute2
+ sys-apps/iproute2[-minimal]
!<net-firewall/shorewall-4.0"
RDEPEND="${DEPEND}"
-pkg_setup() {
- if built_with_use sys-apps/iproute2 minimal; then
- die "Shorewall requires sys-apps/iproute2 to be built without the \"minimal\" USE flag."
- fi
-}
-
src_compile() {
einfo "Nothing to compile."
}
@@ -45,7 +41,8 @@ src_install() {
PREFIX="${D}" ./install.sh || die "install.sh failed"
newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
- dodoc changelog.txt releasenotes.txt
+ dodoc changelog.txt releasenotes.txt || die
+
if use doc; then
cd "${WORKDIR}/${MY_P_DOCS}"
# install documentation
diff --git a/net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild b/net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild
index baab68758055..e35e2b926458 100644
--- a/net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild
+++ b/net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild,v 1.1 2009/01/22 08:17:45 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.2.4.ebuild,v 1.2 2009/03/08 14:26:49 betelgeuse Exp $
+
+EAPI="2"
inherit eutils versionator
@@ -24,16 +26,10 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
DEPEND=">=net-firewall/iptables-1.2.4
- sys-apps/iproute2
+ sys-apps/iproute2[-minimal]
!<net-firewall/shorewall-4.0"
RDEPEND="${DEPEND}"
-pkg_setup() {
- if built_with_use sys-apps/iproute2 minimal; then
- die "Shorewall requires sys-apps/iproute2 to be built without the \"minimal\" USE flag."
- fi
-}
-
src_compile() {
einfo "Nothing to compile."
}
diff --git a/net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild b/net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild
index 561e24ce7634..51d373278392 100644
--- a/net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild
+++ b/net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild,v 1.1 2009/02/22 13:38:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.2.6.ebuild,v 1.2 2009/03/08 14:26:49 betelgeuse Exp $
+
+EAPI="2"
inherit eutils versionator
@@ -24,16 +26,10 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
DEPEND=">=net-firewall/iptables-1.2.4
- sys-apps/iproute2
+ sys-apps/iproute2[-minimal]
!<net-firewall/shorewall-4.0"
RDEPEND="${DEPEND}"
-pkg_setup() {
- if built_with_use sys-apps/iproute2 minimal; then
- die "Shorewall requires sys-apps/iproute2 to be built without the \"minimal\" USE flag."
- fi
-}
-
src_compile() {
einfo "Nothing to compile."
}
@@ -45,7 +41,8 @@ src_install() {
PREFIX="${D}" ./install.sh || die "install.sh failed"
newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
- dodoc changelog.txt releasenotes.txt
+ dodoc changelog.txt releasenotes.txt || die
+
if use doc; then
cd "${WORKDIR}/${MY_P_DOCS}"
# install documentation