summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-10-01 11:08:01 +0000
committerThilo Bangert <bangert@gentoo.org>2008-10-01 11:08:01 +0000
commit314966233519881eff4aae7c0518da2bf952d50f (patch)
tree8f0558b4e9b570060a61d9ee5cf02053b64cdf73 /net-firewall
parentversion bump by Armando Di Cianno - bug #210734 (diff)
downloadgentoo-2-314966233519881eff4aae7c0518da2bf952d50f.tar.gz
gentoo-2-314966233519881eff4aae7c0518da2bf952d50f.tar.bz2
gentoo-2-314966233519881eff4aae7c0518da2bf952d50f.zip
version bump - thanks Pinky - bug #184180
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipkungfu/ChangeLog8
-rw-r--r--net-firewall/ipkungfu/files/ipkungfu_noiseless.patch24
-rw-r--r--net-firewall/ipkungfu/ipkungfu-0.6.1.ebuild49
3 files changed, 80 insertions, 1 deletions
diff --git a/net-firewall/ipkungfu/ChangeLog b/net-firewall/ipkungfu/ChangeLog
index 348d97d846f2..e4eac136081b 100644
--- a/net-firewall/ipkungfu/ChangeLog
+++ b/net-firewall/ipkungfu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipkungfu
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipkungfu/ChangeLog,v 1.15 2008/04/21 17:51:03 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipkungfu/ChangeLog,v 1.16 2008/10/01 11:07:54 bangert Exp $
+
+*ipkungfu-0.6.1 (01 Oct 2008)
+
+ 01 Oct 2008; Thilo Bangert <bangert@gentoo.org>
+ +files/ipkungfu_noiseless.patch, +ipkungfu-0.6.1.ebuild:
+ version bump - thanks Pinky - bug #184180
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/net-firewall/ipkungfu/files/ipkungfu_noiseless.patch b/net-firewall/ipkungfu/files/ipkungfu_noiseless.patch
new file mode 100644
index 000000000000..eed657f2dada
--- /dev/null
+++ b/net-firewall/ipkungfu/files/ipkungfu_noiseless.patch
@@ -0,0 +1,24 @@
+diff -ru ipkungfu-0.6.1.orig/ipkungfu.in ipkungfu-0.6.1/ipkungfu.in
+--- ipkungfu-0.6.1.orig/ipkungfu.in 2007-01-22 04:47:04.000000000 +0100
++++ ipkungfu-0.6.1/ipkungfu.in 2007-07-04 12:49:23.000000000 +0200
+@@ -753,11 +753,15 @@
+ fi
+
+ function delTestChain {
+-# {{{ Flush and delete test chains
+- $IPTABLES -t filter -F SYSTEST
+- $IPTABLES -t filter -X SYSTEST
+- $IPTABLES -t mangle -F SYSTEST
+- $IPTABLES -t mangle -X SYSTEST
++# {{{ Flush and delete test chains, if exist
++ if $IPTABLES -t filter -L SYSTEST > /dev/null 2>&1 ; then
++ $IPTABLES -t filter -F SYSTEST
++ $IPTABLES -t filter -X SYSTEST
++ fi
++ if $IPTABLES -t mangle -L SYSTEST > /dev/null 2>&1 ; then
++ $IPTABLES -t mangle -F SYSTEST
++ $IPTABLES -t mangle -X SYSTEST
++ fi
+ # }}}
+ }
+
diff --git a/net-firewall/ipkungfu/ipkungfu-0.6.1.ebuild b/net-firewall/ipkungfu/ipkungfu-0.6.1.ebuild
new file mode 100644
index 000000000000..3c45ecb3c176
--- /dev/null
+++ b/net-firewall/ipkungfu/ipkungfu-0.6.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipkungfu/ipkungfu-0.6.1.ebuild,v 1.1 2008/10/01 11:07:54 bangert Exp $
+
+inherit eutils
+
+DESCRIPTION="A nice iptables firewall script"
+HOMEPAGE="http://www.linuxkungfu.org/"
+SRC_URI="http://www.linuxkungfu.org/ipkungfu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ net-firewall/iptables"
+RDEPEND="${DEPEND}
+ virtual/logger"
+
+src_compile() {
+ epatch "${FILESDIR}/ipkungfu_noiseless.patch" || die "Could not apply ipkungfu_noiseless.patch patch"
+ econf || die "Could not run econf"
+ emake || die "Couldn't run make"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ # Install configuration files
+ make DESTDIR="${D}" install-config || die
+
+ # Install Gentoo init script
+ newinitd "${FILESDIR}"/ipkungfu.init ipkungfu
+}
+
+pkg_postinst() {
+ # Remove the cache dir so ipkungfu won't fail when running for
+ # the first time, case 0.6.0 was installed before.
+ rm -rf /etc/ipkungfu/cache
+
+ einfo "Be sure to, before running ipkungfu, edit the config files in:"
+ einfo "/etc/ipkungfu/"
+ echo
+ einfo "Also, be sure to run ipkungfu prior to rebooting,"
+ einfo "especially if you you're updating from <0.6.0 to >=0.6.0."
+ einfo "There are some significant configuration changes on this"
+ einfo "release covered by the ipkungfu script."
+}