summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-01-27 19:21:30 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-01-27 19:21:30 +0000
commit1a069e1bbd3a176ace7e406372592ce744f255a6 (patch)
tree4025d0614b92efce0dd7f91de66dc3a5dac5414b /net-firewall/shorewall-shell
parentalpha/ia64/sparc stable (diff)
downloadgentoo-2-1a069e1bbd3a176ace7e406372592ce744f255a6.tar.gz
gentoo-2-1a069e1bbd3a176ace7e406372592ce744f255a6.tar.bz2
gentoo-2-1a069e1bbd3a176ace7e406372592ce744f255a6.zip
Version bump, thanks to Vieri for the notification in bug #196695
(Portage version: 2.1.4)
Diffstat (limited to 'net-firewall/shorewall-shell')
-rw-r--r--net-firewall/shorewall-shell/ChangeLog10
-rw-r--r--net-firewall/shorewall-shell/files/digest-shorewall-shell-4.0.83
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.8.ebuild52
3 files changed, 63 insertions, 2 deletions
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index 1241e9c97dea..d942c123f3bc 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-shell
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.7 2007/09/14 11:44:04 fmccor Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.8 2008/01/27 19:21:29 jokey Exp $
+
+*shorewall-shell-4.0.8 (27 Jan 2008)
+
+ 27 Jan 2008; Markus Ullmann <jokey@gentoo.org>
+ +shorewall-shell-4.0.8.ebuild:
+ Version bump, thanks to Vieri for the notification in bug #196695
14 Sep 2007; Ferris McCormick <fmccor@gentoo.org>
shorewall-shell-4.0.3.ebuild:
diff --git a/net-firewall/shorewall-shell/files/digest-shorewall-shell-4.0.8 b/net-firewall/shorewall-shell/files/digest-shorewall-shell-4.0.8
new file mode 100644
index 000000000000..6fb8c51ca385
--- /dev/null
+++ b/net-firewall/shorewall-shell/files/digest-shorewall-shell-4.0.8
@@ -0,0 +1,3 @@
+MD5 13b11729d0f2ec008a8a7d6a1550e777 shorewall-shell-4.0.8.tar.bz2 78096
+RMD160 573918e314768657fdf8a02ed2a4de501e5e5e67 shorewall-shell-4.0.8.tar.bz2 78096
+SHA256 6445a622029057333aedcadfd41719fbf623e920ae9295a7c6a8ed45b3fe1beb shorewall-shell-4.0.8.tar.bz2 78096
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.8.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.8.ebuild
new file mode 100644
index 000000000000..5aaa89ebb89b
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.8.ebuild,v 1.1 2008/01/27 19:21:29 jokey Exp $
+
+# Choose between experimental, stable and beta:
+#MY_P_TREE="development/4.0" # experimental and beta
+MY_P_TREE="4.0" # stable
+#MY_P_BETA="-Beta7" # only beta
+MY_P_BETA="" # stable or experimental
+
+MY_P="shorewall-${PV}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="~net-firewall/shorewall-common-${PV}"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ einfo "In order to use the shell compiler you need to add"
+ einfo "SHOREWALL_COMPILER=shell"
+ einfo "to shorewall.conf"
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/shorewall/${MY_P_TREE}/${MY_P}${MY_P_BETA}/known_problems.txt"
+ einfo
+}