summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-05-03 08:54:38 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-05-03 08:54:38 +0000
commit4c10f161e8ab06f1665ac2765407f060fbf1b0d0 (patch)
tree91715ed71bb6ae8825282e1b658bba30c664da92 /net-firewall/ipset
parentVersion bumped. This closes bug #91110. (diff)
downloadgentoo-2-4c10f161e8ab06f1665ac2765407f060fbf1b0d0.tar.gz
gentoo-2-4c10f161e8ab06f1665ac2765407f060fbf1b0d0.tar.bz2
gentoo-2-4c10f161e8ab06f1665ac2765407f060fbf1b0d0.zip
Convert to use linux-info eclass.
(Portage version: 2.0.51.21)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog8
-rw-r--r--net-firewall/ipset/Manifest14
-rw-r--r--net-firewall/ipset/files/digest-ipset-2.1.0.20050119-r11
-rw-r--r--net-firewall/ipset/ipset-2.1.0.20050119-r1.ebuild61
4 files changed, 72 insertions, 12 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index 34409f38fa13..eed054051abb 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.2 2005/04/26 16:30:23 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.3 2005/05/03 08:54:38 robbat2 Exp $
+
+*ipset-2.1.0.20050119-r1 (03 May 2005)
+
+ 03 May 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +ipset-2.1.0.20050119-r1.ebuild:
+ Convert to use linux-info eclass.
26 Apr 2005; Andrej Kacian <ticho@gentoo.org> ipset-2.1.0.20050119.ebuild:
Added ~amd64 keyword.
diff --git a/net-firewall/ipset/Manifest b/net-firewall/ipset/Manifest
index e1bc47575ee3..5962f19d9f51 100644
--- a/net-firewall/ipset/Manifest
+++ b/net-firewall/ipset/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 a91e5d48b48bd8a6aa1f82db05c49047 ChangeLog 515
MD5 55c086ca5c64b48d64de4fd2cf96adf9 ipset-2.1.0.20050119.ebuild 1709
+MD5 9447056947e88797000b6746358b0fd1 ipset-2.1.0.20050119-r1.ebuild 1605
+MD5 a91e5d48b48bd8a6aa1f82db05c49047 ChangeLog 515
MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
+MD5 eeb0a192ff8d4aa8efabfbae1e3ccf7c files/digest-ipset-2.1.0.20050119-r1 72
MD5 eeb0a192ff8d4aa8efabfbae1e3ccf7c files/digest-ipset-2.1.0.20050119 72
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCbmy4QlM6RnzZP+IRAgFYAJ9f3qt1gf0HqFNNxjeslJwGJlsjhgCgwn05
-0Wf47qPDQPMrew7gzqO+LFA=
-=NfRB
------END PGP SIGNATURE-----
diff --git a/net-firewall/ipset/files/digest-ipset-2.1.0.20050119-r1 b/net-firewall/ipset/files/digest-ipset-2.1.0.20050119-r1
new file mode 100644
index 000000000000..68db10cd589a
--- /dev/null
+++ b/net-firewall/ipset/files/digest-ipset-2.1.0.20050119-r1
@@ -0,0 +1 @@
+MD5 9f1b9c36d37eb8371c83b5610362d16d ipset-2.1.0-20050119.tar.bz2 23821
diff --git a/net-firewall/ipset/ipset-2.1.0.20050119-r1.ebuild b/net-firewall/ipset/ipset-2.1.0.20050119-r1.ebuild
new file mode 100644
index 000000000000..a4cf54d9efc4
--- /dev/null
+++ b/net-firewall/ipset/ipset-2.1.0.20050119-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.1.0.20050119-r1.ebuild,v 1.1 2005/05/03 08:54:38 robbat2 Exp $
+
+inherit eutils flag-o-matic versionator linux-info
+
+MY_PV="$(replace_version_separator 3 '-' )"
+MY_P="${PN}-${MY_PV}"
+DESCRIPTION="IPset tool for iptables, successor to ippool."
+HOMEPAGE="http://people.netfilter.org/kadlec/ipset/"
+SRC_URI="${HOMEPAGE}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=net-firewall/iptables-1.3*"
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+S="${WORKDIR}/${PN}"
+CONFIG_CHECK="IP_NF_SET"
+
+pkg_setup() {
+ ewarn "If your kernel sources do not contain the IPset functionality,"
+ ewarn "this package may fail to compile."
+ linux-info_pkg_setup
+}
+
+src_defs() {
+ # these are used in both of src_compile and src_install
+ myconf="${myconf} PREFIX="
+ myconf="${myconf} LIBDIR=/lib"
+ myconf="${myconf} BINDIR=/sbin"
+ myconf="${myconf} MANDIR=/usr/share/man"
+ myconf="${myconf} INCDIR=/usr/include"
+ export myconf
+}
+
+src_compile() {
+ src_defs
+
+ # for some reason, it doesn't behave right if this is skipped
+ replace-flags -O0 -O2
+ if [ -z `get-flag O` ]; then
+ append-flags -O2
+ fi
+
+ # see iptables ebuild, as this code links against it
+ filter-flags "-fstack-protector"
+
+ # now build it
+ emake COPT_FLAGS="${CFLAGS}" ${myconf} \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ || die "failed to build"
+}
+
+src_install() {
+ src_defs
+ emake DESTDIR="${D}" ${myconf} \
+ KERNEL_DIR="${KERNEL_DIR}" \
+ install || die "failed to package"
+}