summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2007-08-29 21:26:55 +0000
committerPatrick McLean <chutzpah@gentoo.org>2007-08-29 21:26:55 +0000
commite3aed1690bd9450dad63c7140e3dbbe54b64b3fe (patch)
treee184d4dd77034ba446e9dc834cb8cc46723a92b0 /net-dns
parent(QA) Remove the mysql check wrt bug #156213. (diff)
downloadgentoo-2-e3aed1690bd9450dad63c7140e3dbbe54b64b3fe.tar.gz
gentoo-2-e3aed1690bd9450dad63c7140e3dbbe54b64b3fe.tar.bz2
gentoo-2-e3aed1690bd9450dad63c7140e3dbbe54b64b3fe.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/dnsmasq/ChangeLog9
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.40.ebuild63
-rw-r--r--net-dns/dnsmasq/files/digest-dnsmasq-2.403
3 files changed, 73 insertions, 2 deletions
diff --git a/net-dns/dnsmasq/ChangeLog b/net-dns/dnsmasq/ChangeLog
index 34476a49af41..88d03045c105 100644
--- a/net-dns/dnsmasq/ChangeLog
+++ b/net-dns/dnsmasq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dnsmasq
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.133 2007/08/04 11:25:19 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/ChangeLog,v 1.134 2007/08/29 21:26:55 chutzpah Exp $
+
+*dnsmasq-2.40 (29 Aug 2007)
+
+ 29 Aug 2007; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.40.ebuild:
+ Version bump.
04 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org> dnsmasq-2.39.ebuild:
ppc stable, bug #184881
@@ -34,7 +39,7 @@
*dnsmasq-2.39 (09 May 2007)
- 09 May 2007; Patrick McLean <chutz@gentoo.org> +dnsmasq-2.39.ebuild:
+ 09 May 2007; Patrick McLean <chutzpah@gentoo.org> +dnsmasq-2.39.ebuild:
Version bump (bug #177608).
22 Apr 2007; Raúl Porcel <armin76@gentoo.org> dnsmasq-2.38-r1.ebuild:
diff --git a/net-dns/dnsmasq/dnsmasq-2.40.ebuild b/net-dns/dnsmasq/dnsmasq-2.40.ebuild
new file mode 100644
index 000000000000..1f43328be565
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.40.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.40.ebuild,v 1.1 2007/08/29 21:26:55 chutzpah Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="dbus isc resolvconf tftp"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dbus? ( sys-apps/dbus )
+ resolvconf? ( net-dns/resolvconf-gentoo )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-fbsd-config.patch"
+}
+
+src_compile() {
+ use tftp || append-flags -DNO_TFTP
+ use dbus && sed -i '$ a #define HAVE_DBUS' src/config.h
+ use isc && sed -i '$ a #define HAVE_ISC_READER' src/config.h
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+
+ if use resolvconf ; then
+ exeinto /etc/resolvconf/update.d
+ newexe ${FILESDIR}/resolvconf.dnsmasq dnsmasq
+ fi
+}
diff --git a/net-dns/dnsmasq/files/digest-dnsmasq-2.40 b/net-dns/dnsmasq/files/digest-dnsmasq-2.40
new file mode 100644
index 000000000000..7dff16b243f4
--- /dev/null
+++ b/net-dns/dnsmasq/files/digest-dnsmasq-2.40
@@ -0,0 +1,3 @@
+MD5 91b6063ae81146b9d70b4381b2f3e44f dnsmasq-2.40.tar.gz 307051
+RMD160 f86ee3c5e398b3a8eac103c6598f8f3db60d6955 dnsmasq-2.40.tar.gz 307051
+SHA256 16517856930074fa4bba739f40ca1dd4a11b80a0623a12f2ae7be701083564e0 dnsmasq-2.40.tar.gz 307051