summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-08-11 09:03:50 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-08-11 09:03:50 +0000
commit208b3d02ccd9a9acab47b40069e682d0ba1c66f0 (patch)
tree5b8eb59fc9b7d8218e048249e311bdbf12c5fcc5 /net-dns
parentChange udev rules numbering from 99 to 80. (diff)
downloadgentoo-2-208b3d02ccd9a9acab47b40069e682d0ba1c66f0.tar.gz
gentoo-2-208b3d02ccd9a9acab47b40069e682d0ba1c66f0.tar.bz2
gentoo-2-208b3d02ccd9a9acab47b40069e682d0ba1c66f0.zip
Version bump to 1.0. They now use GPL-3 for the tools, examples etc and the library is still under LGPL-2.1.
(Portage version: 2.1.3)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/libidn/ChangeLog8
-rw-r--r--net-dns/libidn/files/digest-libidn-1.03
-rw-r--r--net-dns/libidn/libidn-1.0.ebuild57
3 files changed, 67 insertions, 1 deletions
diff --git a/net-dns/libidn/ChangeLog b/net-dns/libidn/ChangeLog
index c7aba6857705..c23eba8dbbd2 100644
--- a/net-dns/libidn/ChangeLog
+++ b/net-dns/libidn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/libidn
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.60 2007/05/28 17:17:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.61 2007/08/11 09:03:50 betelgeuse Exp $
+
+*libidn-1.0 (11 Aug 2007)
+
+ 11 Aug 2007; Petteri Räty <betelgeuse@gentoo.org> +libidn-1.0.ebuild:
+ Version bump to 1.0. They now use GPL-3 for the tools, examples etc and the
+ library is still under LGPL-2.1.
28 May 2007; Raúl Porcel <armin76@gentoo.org> libidn-0.6.5-r1.ebuild:
alpha stable wrt #175845
diff --git a/net-dns/libidn/files/digest-libidn-1.0 b/net-dns/libidn/files/digest-libidn-1.0
new file mode 100644
index 000000000000..a3faed85ec31
--- /dev/null
+++ b/net-dns/libidn/files/digest-libidn-1.0
@@ -0,0 +1,3 @@
+MD5 8a6a15dc061c0e17a97cb6b77d850e86 libidn-1.0.tar.gz 2373729
+RMD160 e1ebd229cf05c6c65ac5feb6793de956eb635bbb libidn-1.0.tar.gz 2373729
+SHA256 160642c11121af0b99306fb66ec7a9a8bbc740f384e9829a78ca1f061c6fc312 libidn-1.0.tar.gz 2373729
diff --git a/net-dns/libidn/libidn-1.0.ebuild b/net-dns/libidn/libidn-1.0.ebuild
new file mode 100644
index 000000000000..fa82b96225da
--- /dev/null
+++ b/net-dns/libidn/libidn-1.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/libidn-1.0.ebuild,v 1.1 2007/08/11 09:03:50 betelgeuse Exp $
+
+inherit java-pkg-opt-2 mono autotools
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="http://www.gnu.org/software/libidn/"
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/libidn/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="java doc emacs mono nls"
+
+DEPEND="java? ( >=virtual/jdk-1.4
+ dev-java/gjdoc
+ mono? ( >=dev-lang/mono-0.95 )
+ )"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ mono? ( >=dev-lang/mono-0.95 )"
+
+src_compile() {
+ local myconf=" --disable-csharp"
+
+ use mono && myconf="--enable-csharp=mono"
+
+ econf \
+ $(use_enable nls) \
+ $(use_enable java) \
+ ${myconf} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO || die
+
+ if ! use emacs; then
+ rm -r ${D}/usr/share/emacs || die
+ fi
+
+ if use doc; then
+ dohtml -r doc/reference/html/* || die
+ fi
+
+ if use java; then
+ java-pkg_newjar ${D}/usr/share/java/${P}.jar || die
+ rm -rf ${D}/usr/share/java || die
+
+ if use doc; then
+ java-pkg_dojavadoc doc/java
+ fi
+ fi
+}