summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2004-01-19 07:52:20 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2004-01-19 07:52:20 +0000
commite4422aee940d6210c9dc14d26048e92546ec8d10 (patch)
treef6aa083d4497bd6822c0785c41a5023cf613b38d /net-dns/pdns/pdns-2.9.15.ebuild
parentVersion bump. Fixes bug #37989 (diff)
downloadgentoo-2-e4422aee940d6210c9dc14d26048e92546ec8d10.tar.gz
gentoo-2-e4422aee940d6210c9dc14d26048e92546ec8d10.tar.bz2
gentoo-2-e4422aee940d6210c9dc14d26048e92546ec8d10.zip
Version bump. Fixes bug #37989
Diffstat (limited to 'net-dns/pdns/pdns-2.9.15.ebuild')
-rw-r--r--net-dns/pdns/pdns-2.9.15.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-dns/pdns/pdns-2.9.15.ebuild b/net-dns/pdns/pdns-2.9.15.ebuild
new file mode 100644
index 000000000000..0b3639d46c6f
--- /dev/null
+++ b/net-dns/pdns/pdns-2.9.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns/pdns-2.9.15.ebuild,v 1.1 2004/01/19 07:52:12 jhhudso Exp $
+
+DESCRIPTION="The PowerDNS Daemon."
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.gz"
+HOMEPAGE="http://www.powerdns.com/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="mysql postgres static ldap"
+
+DEPEND="virtual/glibc
+ mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-cpp/libpqpp-4.0-r1 )
+ ldap? ( >=net-nds/openldap-2.0.27-r4 )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf=""
+ local modules=""
+
+ use static && myconf="$myconf --enable-static-binaries"
+ use postgres && myconf="$myconf --with-pgsql-includes=/usr/include"
+
+ use mysql && modules="gmysql $modules"
+ use postgres && modules="gpgsql $modules"
+ use ldap && modules="ldap $modules"
+
+ econf --with-modules="$modules" \
+ $myconf || die "Configuration failed"
+
+ emake || die "Make failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ChangeLog HACKING INSTALL README TODO WARNING pdns/COPYING
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/pdns
+
+ mv ${D}/etc/pdns.conf-dist ${D}/etc/pdns.conf
+}