summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-02-12 08:14:18 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-02-12 08:14:18 +0000
commitbc2149f239c6af9b656f600b4d2a77304197acb1 (patch)
tree8bdd5732cd09ca38fd67def012920f23aa10daeb /net-dialup
parentversion bump + kernel 2.6.24 patches (solving bug #207891). (diff)
downloadgentoo-2-bc2149f239c6af9b656f600b4d2a77304197acb1.tar.gz
gentoo-2-bc2149f239c6af9b656f600b4d2a77304197acb1.tar.bz2
gentoo-2-bc2149f239c6af9b656f600b4d2a77304197acb1.zip
version bump (solving bug #207891).
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/misdnuser/ChangeLog10
-rw-r--r--net-dialup/misdnuser/misdnuser-1.1.7.2.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/net-dialup/misdnuser/ChangeLog b/net-dialup/misdnuser/ChangeLog
index 40b67bab6196..2b050090cb64 100644
--- a/net-dialup/misdnuser/ChangeLog
+++ b/net-dialup/misdnuser/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/misdnuser
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdnuser/ChangeLog,v 1.13 2007/11/12 19:16:27 genstef Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdnuser/ChangeLog,v 1.14 2008/02/12 08:14:18 sbriesen Exp $
+
+*misdnuser-1.1.7.2 (12 Feb 2008)
+
+ 12 Feb 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +misdnuser-1.1.7.2.ebuild:
+ version bump (solving bug #207891).
*misdnuser-1.1.7 (12 Nov 2007)
diff --git a/net-dialup/misdnuser/misdnuser-1.1.7.2.ebuild b/net-dialup/misdnuser/misdnuser-1.1.7.2.ebuild
new file mode 100644
index 000000000000..45526eca1f14
--- /dev/null
+++ b/net-dialup/misdnuser/misdnuser-1.1.7.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdnuser/misdnuser-1.1.7.2.ebuild,v 1.1 2008/02/12 08:14:18 sbriesen Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="mISDNuser-${PV//./_}"
+
+DESCRIPTION="mISDN (modular ISDN) kernel link library and includes"
+HOMEPAGE="http://www.mISDN.org"
+SRC_URI="http://www.misdn.org/downloads/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-dialup/misdn-1.1.7.2
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}/misdnuser-as-needed.patch"
+ sed -i -e "s:^\(ifeq\):#\1:g" -e "s:^\(endif\):#\1:g" \
+ -e "s/\(CFLAGS\):/\1+/g" Makefile
+}
+
+src_compile() {
+ emake -j1 CC="$(tc-getCC)" MISDNDIR="/usr"
+}
+
+src_install() {
+ emake INSTALL_PREFIX="${D}" install || die "emake install failed"
+ dodoc CHANGES doc/*
+}