summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-12-28 22:58:26 +0000
committerAlin Năstac <mrness@gentoo.org>2004-12-28 22:58:26 +0000
commit97134d337442f9f75e750c1ad301557adba73b30 (patch)
tree15e62f0f0008aabafb35a14d93363697b17d0787 /net-dialup/penggy/penggy-0.2.1.ebuild
parentMoved dev-libs/ogdi to sci-libs/ogdi (diff)
downloadgentoo-2-97134d337442f9f75e750c1ad301557adba73b30.tar.gz
gentoo-2-97134d337442f9f75e750c1ad301557adba73b30.tar.bz2
gentoo-2-97134d337442f9f75e750c1ad301557adba73b30.zip
clean up ebuild (#75876)
Diffstat (limited to 'net-dialup/penggy/penggy-0.2.1.ebuild')
-rw-r--r--net-dialup/penggy/penggy-0.2.1.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/net-dialup/penggy/penggy-0.2.1.ebuild b/net-dialup/penggy/penggy-0.2.1.ebuild
index 7cb0a1c9c258..f0bfa3e52ea0 100644
--- a/net-dialup/penggy/penggy-0.2.1.ebuild
+++ b/net-dialup/penggy/penggy-0.2.1.ebuild
@@ -1,30 +1,23 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/penggy/penggy-0.2.1.ebuild,v 1.3 2004/06/24 22:30:28 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/penggy/penggy-0.2.1.ebuild,v 1.4 2004/12/28 22:58:26 mrness Exp $
DESCRIPTION="Provide access to Internet using the AOL/Compuserve network."
-HOMEPAGE="http://www.peng.apinc.org/"
+HOMEPAGE="http://www.peng.apinc.org/eng/"
SRC_URI="ftp://ftp.penggy.org/birdy57/penggy/sources/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND=">=dev-util/guile-1.4.0"
+RDEPEND=">=dev-util/guile-1.4.0"
src_compile() {
- # Without localstatedir=/var, it would use /usr/var/run/ .
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sysconfdir=/etc || die "./configure failed"
- emake || die
+ econf || die "configure failed"
+ emake || die "make failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
exeinto /etc/init.d
newexe ${FILESDIR}/rc_net.aol net.aol
}
@@ -36,7 +29,5 @@ pkg_postinst() {
einfo "You now need to configure it by editing penggy.cfg, aol-secrets, and phonetab in /etc/penggy."
einfo "Also you will need to have tuntap, built into your kernel or compiled as a module."
einfo
- einfo "IMPORTANT: Penggy is neither endorsed by or affiliated with"
- einfo "AOL."
- einfo
+ ewarn "IMPORTANT: Penggy is neither endorsed by or affiliated with AOL."
}