summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-06-20 10:36:58 +0000
committerAlin Năstac <mrness@gentoo.org>2009-06-20 10:36:58 +0000
commita35e5e780817b8919db2d4525acaa51079e973ef (patch)
tree8de64c7012252f966452ef28b141a4633b45e9cf /net-dialup/minicom
parentDrop old (diff)
downloadgentoo-2-a35e5e780817b8919db2d4525acaa51079e973ef.tar.gz
gentoo-2-a35e5e780817b8919db2d4525acaa51079e973ef.tar.bz2
gentoo-2-a35e5e780817b8919db2d4525acaa51079e973ef.zip
Update getline-rename.patch (#270452). Migrate to EAPI 2.
(Portage version: 2.1.6.13/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-dialup/minicom')
-rw-r--r--net-dialup/minicom/ChangeLog9
-rw-r--r--net-dialup/minicom/files/minicom-2.3-getline-rename.patch32
-rw-r--r--net-dialup/minicom/minicom-2.3-r2.ebuild (renamed from net-dialup/minicom/minicom-2.3-r1.ebuild)10
3 files changed, 29 insertions, 22 deletions
diff --git a/net-dialup/minicom/ChangeLog b/net-dialup/minicom/ChangeLog
index 730918d478ac..a1f334536328 100644
--- a/net-dialup/minicom/ChangeLog
+++ b/net-dialup/minicom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/minicom
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.68 2009/05/19 21:58:44 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/ChangeLog,v 1.69 2009/06/20 10:36:57 mrness Exp $
+
+*minicom-2.3-r2 (20 Jun 2009)
+
+ 20 Jun 2009; Alin Năstac <mrness@gentoo.org>
+ files/minicom-2.3-getline-rename.patch, -minicom-2.3-r1.ebuild,
+ +minicom-2.3-r2.ebuild:
+ Update getline-rename.patch (#270452). Migrate to EAPI 2.
19 May 2009; Markus Ullmann <jokey@gentoo.org> minicom-2.3-r1.ebuild,
+files/minicom-2.3-getline-rename.patch:
diff --git a/net-dialup/minicom/files/minicom-2.3-getline-rename.patch b/net-dialup/minicom/files/minicom-2.3-getline-rename.patch
index 5ea6c7622a9a..83196604df5c 100644
--- a/net-dialup/minicom/files/minicom-2.3-getline-rename.patch
+++ b/net-dialup/minicom/files/minicom-2.3-getline-rename.patch
@@ -1,11 +1,11 @@
--- minicom-2.3.orig/src/minicom.c 2008-02-02 23:49:53.000000000 +0100
-+++ minicom-2.3/src/minicom.c 2009-05-19 22:09:13.121029740 +0200
++++ minicom-2.3/src/minicom.c 2009-06-08 09:42:32.151729441 +0200
@@ -167,7 +167,7 @@
#endif /*SIGTSTP*/
/* Get a line from either window or scroll back buffer. */
-static ELM *getline(WIN *w, int no)
-+static ELM *_getline(WIN *w, int no)
++static ELM *minic_getline(WIN *w, int no)
{
int i;
static ELM outofrange[MAXCOLS] = {{0,0,0}};
@@ -14,7 +14,7 @@
w->direct = 0;
for (f = 0; f < w->ys; f++)
- mc_wdrawelm(w, f, getline(w, y++));
-+ mc_wdrawelm(w, f, _getline(w, y++));
++ mc_wdrawelm(w, f, minic_getline(w, y++));
if (r)
mc_wredraw(w, 1);
w->direct = 1;
@@ -23,7 +23,7 @@
w->direct = 0;
for (f = 0; f < w->ys; f++) {
- tmp_e = getline(w, y++);
-+ tmp_e = _getline(w, y++);
++ tmp_e = minic_getline(w, y++);
/* First we "accumulate" the line into a variable */
mc_wdrawelm_var(w, tmp_e, tmp_line);
@@ -32,7 +32,7 @@
for (next_line = hit_line; next_line <= all_lines; next_line++) {
/* we do 'something' here... :-) */
- tmp_e = getline(w_hist, next_line);
-+ tmp_e = _getline(w_hist, next_line);
++ tmp_e = minic_getline(w_hist, next_line);
/*
* First we "accumulate" the line into a variable.
@@ -41,10 +41,10 @@
{
if (y+citey >= start && y+citey <= end)
- mc_wdrawelm_inverse(w, y, getline(w, y+citey));
-+ mc_wdrawelm_inverse(w, y, _getline(w, y+citey));
++ mc_wdrawelm_inverse(w, y, minic_getline(w, y+citey));
else
- mc_wdrawelm(w, y, getline(w, y+citey));
-+ mc_wdrawelm(w, y, _getline(w, y+citey));
++ mc_wdrawelm(w, y, minic_getline(w, y+citey));
}
static void drawcite_whole(WIN *w, int y, int start, int end)
@@ -53,7 +53,7 @@
vt_send('>');
vt_send(' ');
- tmp_e = getline(w, y);
-+ tmp_e = _getline(w, y);
++ tmp_e = minic_getline(w, y);
mc_wdrawelm_var(w, tmp_e, tmp_line);
tmp_line[w->xs] = 0;
for (x = w->xs-1; x >= 0; x--) {
@@ -62,7 +62,7 @@
inverse = (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
} else {
- tmp_e = getline(b_us, y);
-+ tmp_e = _getline(b_us, y);
++ tmp_e = minic_getline(b_us, y);
if (wcslen(look_for) > 1) {
/* quick scan for pattern match */
mc_wdrawelm_var(b_us, tmp_e, tmp_line);
@@ -71,10 +71,10 @@
if (inverse)
- mc_wdrawelm_inverse(b_us, 0, getline(b_us, y));
-+ mc_wdrawelm_inverse(b_us, 0, _getline(b_us, y));
++ mc_wdrawelm_inverse(b_us, 0, minic_getline(b_us, y));
else
- mc_wdrawelm(b_us, 0, getline(b_us, y));
-+ mc_wdrawelm(b_us, 0, _getline(b_us, y));
++ mc_wdrawelm(b_us, 0, minic_getline(b_us, y));
if (citemode)
mc_wlocate(b_us, 0, cite_y);
mc_wflush();
@@ -83,7 +83,7 @@
inverse = (y+cite_y >= cite_ystart && y+cite_y <= cite_yend);
} else {
- tmp_e = getline(b_us, y + b_us->ys - 1);
-+ tmp_e = _getline(b_us, y + b_us->ys - 1);
++ tmp_e = minic_getline(b_us, y + b_us->ys - 1);
if (wcslen(look_for) > 1) {
/* quick scan for pattern match */
mc_wdrawelm_var(b_us, tmp_e, tmp_line);
@@ -92,11 +92,11 @@
if (inverse)
mc_wdrawelm_inverse(b_us, b_us->ys - 1,
- getline(b_us, y + b_us->ys - 1));
-+ _getline(b_us, y + b_us->ys - 1));
++ minic_getline(b_us, y + b_us->ys - 1));
else
mc_wdrawelm(b_us, b_us->ys - 1,
- getline(b_us, y + b_us->ys - 1));
-+ _getline(b_us, y + b_us->ys - 1));
++ minic_getline(b_us, y + b_us->ys - 1));
if (citemode)
mc_wlocate(b_us, 0, cite_y);
mc_wflush();
@@ -105,7 +105,7 @@
mc_wprintf(b_st, hline);
mc_wredraw(b_st, 1);
- mc_wdrawelm_inverse(b_us, cite_y, getline(b_us, cite_ystart));
-+ mc_wdrawelm_inverse(b_us, cite_y, _getline(b_us, cite_ystart));
++ mc_wdrawelm_inverse(b_us, cite_y, minic_getline(b_us, cite_ystart));
mc_wlocate(b_us, 0, cite_y);
break;
- case K_ESC:
+ case K_ESC: \ No newline at end of file
diff --git a/net-dialup/minicom/minicom-2.3-r1.ebuild b/net-dialup/minicom/minicom-2.3-r2.ebuild
index a6e1f15ed11a..3e4cd5bb2e46 100644
--- a/net-dialup/minicom/minicom-2.3-r1.ebuild
+++ b/net-dialup/minicom/minicom-2.3-r2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.3-r1.ebuild,v 1.7 2009/05/19 21:58:44 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/minicom/minicom-2.3-r2.ebuild,v 1.1 2009/06/20 10:36:57 mrness Exp $
+
+EAPI="2"
inherit eutils
@@ -26,19 +28,17 @@ RDEPEND="${COMMON_DEPEND}
MY_AVAILABLE_LINGUAS=" cs da de es fi fr hu ja nb pl pt_BR ro ru rw sv vi zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
-src_unpack() {
- unpack ${A}
+src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo-runscript.patch
#glibc name conflict
epatch "${FILESDIR}"/${P}-getline-rename.patch
}
-src_compile() {
+src_configure() {
econf --sysconfdir=/etc/${PN} \
$(use_enable nls) \
|| die "econf failed"
- emake || die "emake failed"
}
src_install() {