summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-20 13:31:41 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-20 13:31:41 +0000
commitfc3e289d4ee71d6cea6385eb8b2153c335fa0c1c (patch)
tree81e1c09e6e5d373958bdc55d1be339c70b8b5f7f /net-dialup/fritzcapi
parentChange firmware directory in order to be compatible with other ebuilds. (Mani... (diff)
downloadgentoo-2-fc3e289d4ee71d6cea6385eb8b2153c335fa0c1c.tar.gz
gentoo-2-fc3e289d4ee71d6cea6385eb8b2153c335fa0c1c.tar.bz2
gentoo-2-fc3e289d4ee71d6cea6385eb8b2153c335fa0c1c.zip
initial import from #71821
Diffstat (limited to 'net-dialup/fritzcapi')
-rw-r--r--net-dialup/fritzcapi/ChangeLog10
-rw-r--r--net-dialup/fritzcapi/Manifest2
-rw-r--r--net-dialup/fritzcapi/files/digest-fritzcapi-2.6.26.71
-rw-r--r--net-dialup/fritzcapi/fritzcapi-2.6.26.7.ebuild51
-rw-r--r--net-dialup/fritzcapi/metadata.xml6
5 files changed, 70 insertions, 0 deletions
diff --git a/net-dialup/fritzcapi/ChangeLog b/net-dialup/fritzcapi/ChangeLog
new file mode 100644
index 000000000000..ed1f5b5ff10b
--- /dev/null
+++ b/net-dialup/fritzcapi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-dialup/fritzcapi
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fritzcapi/ChangeLog,v 1.1 2004/11/20 13:31:41 mrness Exp $
+
+*fritzcapi-2.6.26.7 (20 Nov 2004)
+
+ 20 Nov 2004; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+ +fritzcapi-2.6.26.7.ebuild:
+ Initial import, thanks to Stefan Schweizer <genstef@gentoo.org>. Closing #71821
+
diff --git a/net-dialup/fritzcapi/Manifest b/net-dialup/fritzcapi/Manifest
new file mode 100644
index 000000000000..551d77e356ef
--- /dev/null
+++ b/net-dialup/fritzcapi/Manifest
@@ -0,0 +1,2 @@
+MD5 286431677a23678edfe312da8a8f2489 fritzcapi-2.6.26.7.ebuild 1352
+MD5 accf9b4a9f56c30c485802543f4e44d5 files/digest-fritzcapi-2.6.26.7 76
diff --git a/net-dialup/fritzcapi/files/digest-fritzcapi-2.6.26.7 b/net-dialup/fritzcapi/files/digest-fritzcapi-2.6.26.7
new file mode 100644
index 000000000000..364f6b2de00c
--- /dev/null
+++ b/net-dialup/fritzcapi/files/digest-fritzcapi-2.6.26.7
@@ -0,0 +1 @@
+MD5 da1774a7774e22afc7bff26d2978118e km_fritzcapi-2.6-26.7.i586.rpm 1904272
diff --git a/net-dialup/fritzcapi/fritzcapi-2.6.26.7.ebuild b/net-dialup/fritzcapi/fritzcapi-2.6.26.7.ebuild
new file mode 100644
index 000000000000..139aa7ac7fe9
--- /dev/null
+++ b/net-dialup/fritzcapi/fritzcapi-2.6.26.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fritzcapi/fritzcapi-2.6.26.7.ebuild,v 1.1 2004/11/20 13:31:41 mrness Exp $
+
+inherit kernel-mod rpm
+
+S="${WORKDIR}/usr/src/kernel-modules/fritzcapi"
+
+DESCRIPTION="SuSE's 2.6 AVM kernel modules for fcclassic, fcpci, fcpcmcia, fcpnp, fcusb, fcusb2, fxusb_CZ and fxusb"
+HOMEPAGE="http://www.avm.de/"
+SRC_URI="ftp://ftp.suse.com/pub/suse/i386/update/9.1/rpm/i586/km_${P/2.6./2.6-}.i586.rpm"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=">=net-dialup/capi4k-utils-20040810"
+DEPEND="${RDEPEND}
+ app-arch/rpm2targz
+ virtual/linux-sources"
+
+pkg_setup() {
+ if ! kernel-mod_is_2_6_kernel; then
+ die "This package works only with 2.6 kernel!"
+ fi
+ if ! kernel-mod_configoption_present ISDN_CAPI_CAPI20; then
+ die "For using the driver you need a kernel with enabled CAPI support."
+ fi
+ kernel-mod_check_modules_supported
+}
+
+src_unpack() {
+ rpm_src_unpack ${A} || die "Could not unpack RPM package."
+}
+
+src_compile() {
+ unset ARCH
+ emake KERNEL_SOURCE="${ROOT}/usr/src/linux" modules || die "emake modules failed"
+}
+
+src_install() {
+ insinto /lib/modules/${KV_VERSION_FULL}/extra
+ doins fritz.*/src/*.ko
+}
+
+pkg_postinst() {
+ einfo "Checking kernel module dependencies"
+ test -r "${ROOT}/usr/src/linux/System.map" && \
+ depmod -ae -F "${ROOT}/usr/src/linux/System.map" -b "${ROOT}" -r ${KV}
+}
diff --git a/net-dialup/fritzcapi/metadata.xml b/net-dialup/fritzcapi/metadata.xml
new file mode 100644
index 000000000000..ab51a4a5059d
--- /dev/null
+++ b/net-dialup/fritzcapi/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>SuSE's 2.6 AVM kernel modules for fcclassic, fcpci, fcpcmcia, fcpnp, fcusb, fcusb2, fxusb_CZ and fxusb</longdescription>
+</pkgmetadata>