summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:35:03 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-30 01:35:03 +0000
commitd51fd9d240ce5628cba26a563f448ee1127d4dff (patch)
treec1dd2047be4d2219d7ab539ab28d6630ce01f4c9 /net-dialup/fcdslusba
parentfixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks... (diff)
downloadgentoo-2-d51fd9d240ce5628cba26a563f448ee1127d4dff.tar.gz
gentoo-2-d51fd9d240ce5628cba26a563f448ee1127d4dff.tar.bz2
gentoo-2-d51fd9d240ce5628cba26a563f448ee1127d4dff.zip
fixing string.h problem (see bug #202385) + patches for kernel 2.6.24 (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
(Portage version: 2.1.4)
Diffstat (limited to 'net-dialup/fcdslusba')
-rw-r--r--net-dialup/fcdslusba/ChangeLog9
-rw-r--r--net-dialup/fcdslusba/fcdslusba-0.1-r1.ebuild55
-rw-r--r--net-dialup/fcdslusba/files/digest-fcdslusba-0.1-r13
-rw-r--r--net-dialup/fcdslusba/files/fcdslusba_kernel-2.6.24.diff66
4 files changed, 132 insertions, 1 deletions
diff --git a/net-dialup/fcdslusba/ChangeLog b/net-dialup/fcdslusba/ChangeLog
index c72887338a6e..7a9f63db874b 100644
--- a/net-dialup/fcdslusba/ChangeLog
+++ b/net-dialup/fcdslusba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/fcdslusba
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdslusba/ChangeLog,v 1.1 2008/01/06 01:50:23 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdslusba/ChangeLog,v 1.2 2008/01/30 01:35:02 sbriesen Exp $
+
+*fcdslusba-0.1-r1 (30 Jan 2008)
+
+ 30 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/fcdslusba_kernel-2.6.24.diff, +fcdslusba-0.1-r1.ebuild:
+ fixing string.h problem (see bug #202385) + patches for kernel 2.6.24
+ (thanks to Arnd Feldmueller <arnd.feldmueller@web.de>).
*fcdslusba-0.1 (06 Jan 2008)
diff --git a/net-dialup/fcdslusba/fcdslusba-0.1-r1.ebuild b/net-dialup/fcdslusba/fcdslusba-0.1-r1.ebuild
new file mode 100644
index 000000000000..36ea105eb2cd
--- /dev/null
+++ b/net-dialup/fcdslusba/fcdslusba-0.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcdslusba/fcdslusba-0.1-r1.ebuild,v 1.1 2008/01/30 01:35:02 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card DSL USB ANALOG"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[012345]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ epatch "${FILESDIR}/${PN}_kernel-2.6.24.diff"
+ convert_to_m src/Makefile
+
+ for i in lib/*-lib.o; do
+ einfo "Localize symbols in ${i##*/} ..."
+ objcopy -L memcmp -L memcpy -L memmove -L memset -L strcat \
+ -L strcmp -L strcpy -L strlen -L strncmp -L strncpy "${i}"
+ done
+}
+
+src_install() {
+ linux-mod_src_install
+ insinto /lib/firmware/isdn
+ doins *.frm
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcdslusba/files/digest-fcdslusba-0.1-r1 b/net-dialup/fcdslusba/files/digest-fcdslusba-0.1-r1
new file mode 100644
index 000000000000..b53ebf1b83d6
--- /dev/null
+++ b/net-dialup/fcdslusba/files/digest-fcdslusba-0.1-r1
@@ -0,0 +1,3 @@
+MD5 dc1e7becb9f57691eb06e4066f75e9ba fcdslusba-0.1-0.src.rpm 1284862
+RMD160 6d55e8fcdc5c647d5acc112d9b4e777a98a706dc fcdslusba-0.1-0.src.rpm 1284862
+SHA256 b42b744d437beb122aa71eaa8ed2624ad2aaa5765837612cdc853899c308097a fcdslusba-0.1-0.src.rpm 1284862
diff --git a/net-dialup/fcdslusba/files/fcdslusba_kernel-2.6.24.diff b/net-dialup/fcdslusba/files/fcdslusba_kernel-2.6.24.diff
new file mode 100644
index 000000000000..e5bf525c8946
--- /dev/null
+++ b/net-dialup/fcdslusba/files/fcdslusba_kernel-2.6.24.diff
@@ -0,0 +1,66 @@
+--- src/driver.c.orig 2008-01-30 01:40:21.000000000 +0100
++++ src/driver.c 2008-01-30 01:43:00.000000000 +0100
+@@ -131,12 +131,20 @@
+ static DECLARE_TASKLET(rx_tasklet, rx_task, 0);
+ static DECLARE_WAIT_QUEUE_HEAD(wait);
+ static DECLARE_WAIT_QUEUE_HEAD(capi_wait);
++static DECLARE_COMPLETION(hotplug); /* New DECLARE, <arnd.feldmueller@web.de> */
++static DECLARE_COMPLETION(config); /* New DECLARE, <arnd.feldmueller@web.de> */
++static DECLARE_COMPLETION(notify); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(hotplug);
+ static DECLARE_MUTEX_LOCKED(config);
+ static DECLARE_MUTEX_LOCKED(notify);
++#endif
+
+ static DECLARE_WAIT_QUEUE_HEAD(dbg_wait);
++static DECLARE_COMPLETION(thread_sync); /* New DECLARE, <arnd.feldmueller@web.de> */
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ static DECLARE_MUTEX_LOCKED(thread_sync);
++#endif
+
+ #define SCHED_WAKEUP_CAPI { atomic_set (&thread_capi_flag, 1); wake_up_interruptible (&capi_wait); }
+ #define SCHED_WAKEUP { atomic_set (&got_kicked, 1); wake_up_interruptible (&wait); }
+@@ -434,7 +442,7 @@
+ close_func = func;
+ close_data = data;
+
+- INIT_WORK (&closing_work, closing_worker);
++ INIT_WORK (&closing_work, (work_func_t)closing_worker);
+ schedule_work (&closing_work);
+ LOG("Worker scheduled.\n");
+ } /* start_closing_worker */
+@@ -1180,7 +1188,10 @@
+ }
+ }
+ LOG("Scheduler thread stopped.\n");
++ complete(&thread_sync); /* Complete Thread Sync here <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ up (&thread_sync);
++ #endif
+ return 0;
+ } /* scheduler */
+
+@@ -1214,7 +1225,10 @@
+ SCHED_WAKEUP;
+ }
+ LOG("Thread signalled, waiting for termination...\n");
++ wait_for_completion(&thread_sync); /* Wait for complete Thread Sync <arnd.feldmueller@web.de> */
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ down (&thread_sync);
++ #endif
+ LOG("Thread[%d] terminated.\n", thread_pid);
+ }
+ thread_pid = -1;
+--- src/common.h.orig 2005-07-07 00:00:00.000000000 +0200
++++ src/common.h 2008-01-30 01:40:21.000000000 +0100
+@@ -51,7 +51,9 @@
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/
+ typedef long intptr_t;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ typedef unsigned long uintptr_t;
++#endif
+
+ /*---------------------------------------------------------------------------*\
+ \*---------------------------------------------------------------------------*/