summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-09-22 13:51:45 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-09-22 13:51:45 +0000
commit695cf112755388faea64524e490966839d805167 (patch)
tree26dc4b62f5b51d1f33241c03947b0354226fa181 /net-dialup/capisuite
parentFixlocalpod addition (diff)
downloadgentoo-2-695cf112755388faea64524e490966839d805167.tar.gz
gentoo-2-695cf112755388faea64524e490966839d805167.tar.bz2
gentoo-2-695cf112755388faea64524e490966839d805167.zip
fixed deprecation syntax errors in incoming.py and as a precaution also idle.py, solving bug #130234 and #147854.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-dialup/capisuite')
-rw-r--r--net-dialup/capisuite/ChangeLog9
-rw-r--r--net-dialup/capisuite/capisuite-0.4.5-r4.ebuild89
-rw-r--r--net-dialup/capisuite/files/capisuite-0.4.5-syntax.patch133
-rw-r--r--net-dialup/capisuite/files/digest-capisuite-0.4.5-r43
4 files changed, 233 insertions, 1 deletions
diff --git a/net-dialup/capisuite/ChangeLog b/net-dialup/capisuite/ChangeLog
index 5568665612da..1e2098f5242e 100644
--- a/net-dialup/capisuite/ChangeLog
+++ b/net-dialup/capisuite/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/capisuite
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.28 2006/09/22 13:41:51 sbriesen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/ChangeLog,v 1.29 2006/09/22 13:51:45 sbriesen Exp $
+
+*capisuite-0.4.5-r4 (22 Sep 2006)
+
+ 22 Sep 2006; Stefan Briesenick <sbriesen@gentoo.org>
+ +files/capisuite-0.4.5-syntax.patch, +capisuite-0.4.5-r4.ebuild:
+ fixed deprecation syntax errors in incoming.py and as a precaution also
+ idle.py, solving bug #130234 and #147854.
22 Sep 2006; Stefan Briesenick <sbriesen@gentoo.org>
-files/capisuite-0.4.5-capiv3.patch, -files/capisuite-0.4.5-gentoo.patch,
diff --git a/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild b/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild
new file mode 100644
index 000000000000..00896d53ecce
--- /dev/null
+++ b/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capisuite/capisuite-0.4.5-r4.ebuild,v 1.1 2006/09/22 13:51:45 sbriesen Exp $
+
+inherit eutils flag-o-matic multilib python
+
+DESCRIPTION="ISDN telecommunication suite providing fax and voice services"
+HOMEPAGE="http://www.capisuite.de"
+SRC_URI="http://www.capisuite.de/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="virtual/python
+ sys-devel/automake
+ >=sys-devel/autoconf-2.50
+ media-sound/sox
+ >=media-libs/tiff-3.7.1
+ media-gfx/jpeg2ps
+ media-gfx/sfftobmp
+ virtual/ghostscript
+ net-dialup/capi4k-utils"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # taken from capisuite-0.4.5-5.src.rpm (SuSE-9.3)
+ epatch "${FILESDIR}/${P}-capi4linux_v3.diff"
+
+ # patched scripts/cs_helpers.pyin for bug #96540
+ epatch "${FILESDIR}/${P}-date-header.patch"
+
+ # patched src/backend/connection.cpp for bug #69522
+ epatch "${FILESDIR}/${PN}-fax-compatibility.patch"
+
+ # patched scripts/{incoming,idle}.py for bug #147854
+ epatch "${FILESDIR}/${P}-syntax.patch"
+}
+
+src_compile() {
+ strip-flags # see bug #90901
+ ebegin "Updating autotools-generated files"
+ aclocal -I . || die "aclocal failed"
+ automake -a || die "automake failed"
+ autoheader || die "autoheader failed"
+ WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+ eend $?
+
+ econf --localstatedir=/var \
+ --with-docdir="/usr/share/doc/${PF}" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed."
+
+ rm -f "${D}"/usr/{lib,share}/capisuite/README
+ rmdir -p --ignore-fail-on-non-empty "${D}/var/log"
+ rm -f "${D}/usr/share/doc/${PF}"/{COPYING,manual.pdf}
+ keepdir /var/spool/capisuite/{done,failed,sendq,users}
+
+ dodir /etc/init.d
+ newinitd "${FILESDIR}/capisuite.initd" capisuite
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/capisuite.logrotated" capisuite
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ exeinto /etc/cron.daily
+ doexe capisuite.cron
+
+ insinto /etc/capisuite
+ doins cronjob.conf
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_compile ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/cs_helpers.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}usr/$(get_libdir)/python*/site-packages
+}
diff --git a/net-dialup/capisuite/files/capisuite-0.4.5-syntax.patch b/net-dialup/capisuite/files/capisuite-0.4.5-syntax.patch
new file mode 100644
index 000000000000..0a0725f9b6b3
--- /dev/null
+++ b/net-dialup/capisuite/files/capisuite-0.4.5-syntax.patch
@@ -0,0 +1,133 @@
+--- scripts/incoming.py.orig 2004-11-28 14:35:23.000000000 +0100
++++ scripts/incoming.py 2006-09-22 15:17:28.000000000 +0200
+@@ -1,3 +1,4 @@
++# -*- coding: UTF-8 -*-
+ # incoming.py - standard incoming script for capisuite
+ # ----------------------------------------------------
+ # copyright : (C) 2002 by Gernot Hillier
+@@ -48,7 +49,7 @@
+ if config.has_option(u,'fax_numbers'):
+ numbers=config.get(u,'fax_numbers')
+ if (call_to in numbers.split(',') or numbers=="*"):
+- if (service in (capisuite.SERVICE_FAXG3,capisuite.SERVICE_VOICE)):
++ if (service in (capisuite.SERVICE_FAXG3,capisuite.SERVICE_VOICE)):
+ curr_user=u
+ curr_service=capisuite.SERVICE_FAXG3
+ break
+@@ -133,8 +134,8 @@
+
+ if (os.access(filename,os.R_OK)):
+ cs_helpers.writeDescription(filename,
+- "call_from=\""+call_from+"\"\ncall_to=\""+call_to+"\"\ntime=\""
+- +time.ctime()+"\"\ncause=\"0x%x/0x%x\"\n" % (cause,causeB3))
++ "call_from=\""+call_from+"\"\ncall_to=\""+call_to+"\"\ntime=\""
++ +time.ctime()+"\"\ncause=\"0x%x/0x%x\"\n" % (cause,causeB3))
+ userdata=pwd.getpwnam(curr_user)
+ os.chmod(filename,0600)
+ os.chown(filename,userdata[2],userdata[3])
+@@ -153,8 +154,8 @@
+ action="saveonly"
+ if (action=="mailandsave"):
+ cs_helpers.sendMIMEMail(fromaddress, mailaddress, "Fax received from "+call_from+" to "+call_to, faxFormat,
+- "You got a fax from "+call_from+" to "+call_to+"\nDate: "+time.ctime()+"\n\n"
+- +"See attached file.\nThe original file was saved to file://"+filename+"\n\n", filename)
++ "You got a fax from "+call_from+" to "+call_to+"\nDate: "+time.ctime()+"\n\n"
++ +"See attached file.\nThe original file was saved to file://"+filename+"\n\n", filename)
+
+ # @brief called by callIncoming when an incoming voice call is received
+ #
+@@ -234,8 +235,8 @@
+
+ if (os.access(filename,os.R_OK)):
+ cs_helpers.writeDescription(filename,
+- "call_from=\""+call_from+"\"\ncall_to=\""+call_to+"\"\ntime=\""
+- +time.ctime()+"\"\ncause=\"0x%x/0x%x\"\n" % (cause,causeB3))
++ "call_from=\""+call_from+"\"\ncall_to=\""+call_to+"\"\ntime=\""
++ +time.ctime()+"\"\ncause=\"0x%x/0x%x\"\n" % (cause,causeB3))
+ userdata=pwd.getpwnam(curr_user)
+ os.chmod(filename,0600)
+ os.chown(filename,userdata[2],userdata[3])
+@@ -250,8 +251,8 @@
+ mailaddress=curr_user
+ if (action=="mailandsave"):
+ cs_helpers.sendMIMEMail(fromaddress, mailaddress, "Voice call received from "+call_from+" to "+call_to, "la",
+- "You got a voice call from "+call_from+" to "+call_to+"\nDate: "+time.ctime()+"\n\n"
+- +"See attached file.\nThe original file was saved to file://"+filename+"\n\n", filename)
++ "You got a voice call from "+call_from+" to "+call_to+"\nDate: "+time.ctime()+"\n\n"
++ +"See attached file.\nThe original file was saved to file://"+filename+"\n\n", filename)
+
+
+ # @brief remote inquiry function (uses german wave snippets!)
+@@ -418,7 +419,7 @@
+ #
+ # Revision 1.9 2003/06/27 07:51:09 gernot
+ # - replaced german umlaut in filename "nachricht-gelscht.la", can cause
+-# problems on Redhat, thx to Herbert Hübner for reporting
++# problems on Redhat, thx to Herbert Hübner for reporting
+ #
+ # Revision 1.8 2003/06/16 10:21:05 gernot
+ # - define filename in any case (thx to Axel Schneck for reporting and
+--- scripts/idle.py.orig 2004-11-28 14:35:16.000000000 +0100
++++ scripts/idle.py 2006-09-22 15:33:50.000000000 +0200
+@@ -1,3 +1,4 @@
++# -*- coding: UTF-8 -*-
+ # idle.py - default script for capisuite
+ # ---------------------------------------------
+ # copyright : (C) 2002 by Gernot Hillier
+@@ -105,13 +106,13 @@
+ movejob(job_fax,sendq,done,user)
+ capisuite.log("job "+job_fax+": finished successfully",1)
+ mailtext="Your fax job to "+addressee+" ("+dialstring+") was sent successfully.\n\n" \
+- +"Subject: "+subject+"\nFilename: "+job_fax \
+- +"\nNeeded tries: "+str(tries) \
+- +("\nLast result: 0x%x/0x%x" % (result,resultB3)) \
+- +"\n\nIt was moved to file://"+done+user+"-"+job_fax
++ +"Subject: "+subject+"\nFilename: "+job_fax \
++ +"\nNeeded tries: "+str(tries) \
++ +("\nLast result: 0x%x/0x%x" % (result,resultB3)) \
++ +"\n\nIt was moved to file://"+done+user+"-"+job_fax
+ cs_helpers.sendSimpleMail(fromaddress,mailaddress,
+- "Fax to "+addressee+" ("+dialstring+") sent successfully.",
+- mailtext)
++ "Fax to "+addressee+" ("+dialstring+") sent successfully.",
++ mailtext)
+ else:
+ max_tries=int(cs_helpers.getOption(config,"","send_tries","10"))
+ delays=cs_helpers.getOption(config,"","send_delays","60,60,60,300,300,3600,3600,18000,36000").split(",")
+@@ -123,19 +124,19 @@
+ starttime=time.time()+next_delay
+ capisuite.log("job "+job_fax+": delayed for "+str(next_delay)+" seconds",2)
+ cs_helpers.writeDescription(sendq+job_fax,"dialstring=\""+dialstring+"\"\n"
+- +"starttime=\""+time.ctime(starttime)+"\"\ntries=\""+str(tries)+"\"\n"
+- +"user=\""+user+"\"\naddressee=\""+addressee+"\"\nsubject=\""+subject+"\"\n")
++ +"starttime=\""+time.ctime(starttime)+"\"\ntries=\""+str(tries)+"\"\n"
++ +"user=\""+user+"\"\naddressee=\""+addressee+"\"\nsubject=\""+subject+"\"\n")
+ if (tries>=max_tries):
+ movejob(job_fax,sendq,failed,user)
+ capisuite.log("job "+job_fax+": failed finally",1)
+ mailtext="I'm sorry, but your fax job to "+addressee+" ("+dialstring \
+- +") failed finally.\n\nSubject: "+subject \
+- +"\nFilename: "+job_fax+"\nTries: "+str(tries) \
+- +"\nLast result: 0x%x/0x%x" % (result,resultB3) \
+- +"\n\nIt was moved to file://"+failed+user+"-"+job_fax
++ +") failed finally.\n\nSubject: "+subject \
++ +"\nFilename: "+job_fax+"\nTries: "+str(tries) \
++ +"\nLast result: 0x%x/0x%x" % (result,resultB3) \
++ +"\n\nIt was moved to file://"+failed+user+"-"+job_fax
+ cs_helpers.sendSimpleMail(fromaddress,mailaddress,
+- "Fax to "+addressee+" ("+dialstring+") FAILED.",
+- mailtext)
++ "Fax to "+addressee+" ("+dialstring+") FAILED.",
++ mailtext)
+
+ fcntl.lockf(lockfile,fcntl.LOCK_UN)
+ lockfile.close()
+@@ -149,7 +150,7 @@
+ if (stationID==None):
+ capisuite.error("Warning: fax_stationID for user "+user+" not set")
+ stationID=""
+- headline=cs_helpers.getOption(config,user,"fax_headline","")
++ headline=cs_helpers.getOption(config,user,"fax_headline","")
+ (call,result)=capisuite.call_faxG3(capi,controller,outgoing_nr,dialstring,timeout,stationID,headline)
+ if (result!=0):
+ return(result,0)
diff --git a/net-dialup/capisuite/files/digest-capisuite-0.4.5-r4 b/net-dialup/capisuite/files/digest-capisuite-0.4.5-r4
new file mode 100644
index 000000000000..38c12bea5c04
--- /dev/null
+++ b/net-dialup/capisuite/files/digest-capisuite-0.4.5-r4
@@ -0,0 +1,3 @@
+MD5 2197c8650be74db8904c7e54ff43ab7b capisuite-0.4.5.tar.gz 1184603
+RMD160 f28b9cb42a6cfa6d790ec76e74a33a0b7a799762 capisuite-0.4.5.tar.gz 1184603
+SHA256 3e94e42eae6477a222c608c2cd040568fd9fcfa4e8eb0b06a538175d44cbae96 capisuite-0.4.5.tar.gz 1184603