summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-25 13:33:18 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-25 13:33:18 +0000
commitd9b2d3e8eb272434ce2630d930d749b70e55f1e8 (patch)
tree1930f43ff35d74e18659513e2284007a89f12a1c /net-analyzer
parentFixed write error when using top with pipes (#485952) (diff)
downloadgentoo-2-d9b2d3e8eb272434ce2630d930d749b70e55f1e8.tar.gz
gentoo-2-d9b2d3e8eb272434ce2630d930d749b70e55f1e8.tar.bz2
gentoo-2-d9b2d3e8eb272434ce2630d930d749b70e55f1e8.zip
Fix linking against installed libraries (bug #489104 by Kalin KOZHUHAROV).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog8
-rw-r--r--net-analyzer/wireshark/files/wireshark-1.11.0-oldlibs.patch20
-rw-r--r--net-analyzer/wireshark/wireshark-1.11.0-r1.ebuild (renamed from net-analyzer/wireshark/wireshark-1.11.0.ebuild)5
3 files changed, 30 insertions, 3 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index afe543770452..372f869ba078 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/wireshark
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.550 2013/10/24 15:07:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.551 2013/10/25 13:33:18 jer Exp $
+
+*wireshark-1.11.0-r1 (25 Oct 2013)
+
+ 25 Oct 2013; Jeroen Roovers <jer@gentoo.org> -wireshark-1.11.0.ebuild,
+ +wireshark-1.11.0-r1.ebuild, +files/wireshark-1.11.0-oldlibs.patch:
+ Fix linking against installed libraries (bug #489104 by Kalin KOZHUHAROV).
24 Oct 2013; Jeroen Roovers <jer@gentoo.org> wireshark-1.8.10.ebuild,
wireshark-1.10.2.ebuild, wireshark-1.11.0.ebuild:
diff --git a/net-analyzer/wireshark/files/wireshark-1.11.0-oldlibs.patch b/net-analyzer/wireshark/files/wireshark-1.11.0-oldlibs.patch
new file mode 100644
index 000000000000..24b5c7ddc9bc
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-1.11.0-oldlibs.patch
@@ -0,0 +1,20 @@
+--- a/epan/Makefile.am
++++ b/epan/Makefile.am
+@@ -137,6 +137,7 @@
+ # Add the object files for missing routines, if any.
+ #
+ libwireshark_la_LIBADD = \
++ ${top_builddir}/wiretap/libwiretap.la ${top_builddir}/wsutil/libwsutil.la \
+ libwireshark_generated.la \
+ libwireshark_asmopt.la crypt/libairpdcap.la \
+ ftypes/libftypes.la dfilter/libdfilter.la dissectors/libdissectors.la \
+@@ -144,8 +145,7 @@
+ wmem/libwmem.la $(wslua_lib) $(wspython_lib) @SOCKET_LIBS@ @NSL_LIBS@ \
+ @C_ARES_LIBS@ @ADNS_LIBS@ @LIBGCRYPT_LIBS@ @LIBGNUTLS_LIBS@ \
+ @KRB5_LIBS@ @SSL_LIBS@ @LIBSMI_LDFLAGS@ @GEOIP_LIBS@ \
+- ${top_builddir}/wiretap/libwiretap.la @GLIB_LIBS@ \
+- ${top_builddir}/wsutil/libwsutil.la -lm
++ @GLIB_LIBS@ -lm
+
+ libwireshark_la_DEPENDENCIES = \
+ libwireshark_generated.la \
diff --git a/net-analyzer/wireshark/wireshark-1.11.0.ebuild b/net-analyzer/wireshark/wireshark-1.11.0-r1.ebuild
index 51bbdba66a68..0056b1786bd6 100644
--- a/net-analyzer/wireshark/wireshark-1.11.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.11.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.11.0.ebuild,v 1.2 2013/10/24 15:07:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.11.0-r1.ebuild,v 1.1 2013/10/25 13:33:18 jer Exp $
EAPI=5
inherit autotools eutils fcaps user
@@ -85,7 +85,8 @@ pkg_setup() {
src_prepare() {
epatch \
- "${FILESDIR}"/${PN}-1.6.13-ldflags.patch
+ "${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
+ "${FILESDIR}"/${P}-oldlibs.patch
epatch_user