summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-07-25 08:28:14 +0000
committerJeroen Roovers <jer@gentoo.org>2015-07-25 08:28:14 +0000
commita9bb0e6c280232d99a87f1281ee869caf5eba29f (patch)
tree0c1642e91c1c71da1a6279a2c9aa68545c13f240 /net-analyzer
parentVersion bump. (diff)
downloadgentoo-2-a9bb0e6c280232d99a87f1281ee869caf5eba29f.tar.gz
gentoo-2-a9bb0e6c280232d99a87f1281ee869caf5eba29f.tar.bz2
gentoo-2-a9bb0e6c280232d99a87f1281ee869caf5eba29f.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/cacti-0.8.8f.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 4fd2ce89dad9..8916d1fa75a9 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.214 2015/07/24 04:18:58 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.215 2015/07/25 08:28:14 jer Exp $
+
+*cacti-0.8.8f (25 Jul 2015)
+
+ 25 Jul 2015; Jeroen Roovers <jer@gentoo.org> +cacti-0.8.8f.ebuild:
+ Version bump.
24 Jul 2015; Jeroen Roovers <jer@gentoo.org> -cacti-0.8.8d.ebuild:
Old.
diff --git a/net-analyzer/cacti/cacti-0.8.8f.ebuild b/net-analyzer/cacti/cacti-0.8.8f.ebuild
new file mode 100644
index 000000000000..39cfb4add0ce
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.8f.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.8f.ebuild,v 1.1 2015/07/25 08:28:14 jer Exp $
+
+EAPI=5
+
+inherit depend.php eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.cacti.net/"
+SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ virtual/mysql
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_prepare() {
+ sed -i -e \
+ 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"adodb/adodb.inc.php":' \
+ "${S}"/include/global.php || die
+
+ rm -rf lib/adodb || die # don't use bundled adodb
+}
+
+src_compile() { :; }
+
+src_install() {
+ webapp_src_preinst
+
+ rm LICENSE README || die
+ dodoc docs/{CHANGELOG,CONTRIB,README,txt/manual.txt}
+ use doc && dohtml -r docs/html/
+ rm -rf docs
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}