summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-26 04:20:02 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-26 04:20:02 +0000
commit9f864141ff348bf2db544468af454233f38f549e (patch)
tree8fcd07f2cea29606c6da5834cc04f31e3ba57a6b /net-analyzer
parentinstall fix #27261 (diff)
downloadgentoo-2-9f864141ff348bf2db544468af454233f38f549e.tar.gz
gentoo-2-9f864141ff348bf2db544468af454233f38f549e.tar.bz2
gentoo-2-9f864141ff348bf2db544468af454233f38f549e.zip
link order patch #27267
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/dsniff/ChangeLog5
-rw-r--r--net-analyzer/dsniff/dsniff-2.3-r1.ebuild3
-rw-r--r--net-analyzer/dsniff/files/2.3-makefile.patch29
3 files changed, 35 insertions, 2 deletions
diff --git a/net-analyzer/dsniff/ChangeLog b/net-analyzer/dsniff/ChangeLog
index 41d3bf58336d..e7a22424e9f6 100644
--- a/net-analyzer/dsniff/ChangeLog
+++ b/net-analyzer/dsniff/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for net-analyzer/dsniff
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.5 2003/08/21 05:10:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/ChangeLog,v 1.6 2003/08/26 04:20:02 vapier Exp $
*dsniff-2.3-r1 (21 Aug 2003)
+ 26 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add patch to fix linking order #27267.
+
21 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
Patch to compile against SLOT-ed libnet-1.0.x #17772.
diff --git a/net-analyzer/dsniff/dsniff-2.3-r1.ebuild b/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
index f8f6985c935b..32fcfb4e93a1 100644
--- a/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
+++ b/net-analyzer/dsniff/dsniff-2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r1.ebuild,v 1.1 2003/08/21 05:10:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/dsniff/dsniff-2.3-r1.ebuild,v 1.2 2003/08/26 04:20:02 vapier Exp $
inherit eutils
@@ -48,6 +48,7 @@ src_unpack() {
sed -i "s:lib':':" configure || die "sed configure"
sed -i 's:-DDSNIFF_LIBDIR=\\\"$(libdir)/\\\"::' Makefile.in || die "sed makefile"
sed -i 's:/usr/local/lib:/etc/dsniff:' pathnames.h || die "sed pathnames"
+ epatch ${FILESDIR}/${PV}-makefile.patch
}
src_compile() {
diff --git a/net-analyzer/dsniff/files/2.3-makefile.patch b/net-analyzer/dsniff/files/2.3-makefile.patch
new file mode 100644
index 000000000000..83beecee6d35
--- /dev/null
+++ b/net-analyzer/dsniff/files/2.3-makefile.patch
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2003-08-25 18:07:17.000000000 +1200
++++ Makefile.in 2003-08-25 18:29:13.000000000 +1200
+@@ -94,7 +94,7 @@
+ $(RANLIB) $@
+
+ dsniff: $(HDRS) $(SRCS) $(OBJS)
+- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(DBLIB) $(SSLLIB)
++ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(DBLIB) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(SSLLIB)
+
+ arpspoof: arpspoof.o arp.o
+ $(CC) $(LDFLAGS) -o $@ arpspoof.o arp.o $(LIBS) $(PCAPLIB) $(LNETLIB)
+@@ -115,7 +115,7 @@
+ $(CC) $(LDFLAGS) -o $@ msgsnarf.o buf.o pcaputil.o $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB)
+
+ sshmitm: sshmitm.o buf.o hex.o record.o ssh.o sshcrypto.o
+- $(CC) $(LDFLAGS) -o $@ sshmitm.o buf.o hex.o record.o ssh.o sshcrypto.o $(LIBS) $(LNETLIB) $(DBLIB) $(SSLLIB)
++ $(CC) $(LDFLAGS) -o $@ sshmitm.o buf.o hex.o record.o ssh.o sshcrypto.o $(LIBS) $(DBLIB) $(LNETLIB) $(SSLLIB)
+
+ tcpkill: tcpkill.o pcaputil.o
+ $(CC) $(LDFLAGS) -o $@ tcpkill.o pcaputil.o $(LIBS) $(PCAPLIB) $(LNETLIB)
+@@ -130,7 +130,7 @@
+ $(CC) $(LDFLAGS) -o $@ urlsnarf.o base64.o buf.o pcaputil.o $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB)
+
+ webmitm: webmitm.o base64.o buf.o decode_http.o record.o
+- $(CC) $(LDFLAGS) -o $@ webmitm.o base64.o buf.o decode_http.o record.o $(LIBS) $(LNETLIB) $(DBLIB) $(SSLLIB)
++ $(CC) $(LDFLAGS) -o $@ webmitm.o base64.o buf.o decode_http.o record.o $(LIBS) $(DBLIB) $(LNETLIB) $(SSLLIB)
+
+ webspy: webspy.o base64.o buf.o remote.o
+ $(CC) $(LDFLAGS) -o $@ webspy.o base64.o buf.o remote.o $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(X11LIB)