summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-25 11:50:32 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-25 11:50:32 +0000
commit99ca5d7f67f70bb1313d7e6f666f4358a7450f82 (patch)
tree5e63d80aceea9720bdf13521f0bd8e6d4fae3d83 /net-analyzer
parentclean even more, whole -r1 was a mistake back in 2008 (diff)
downloadgentoo-2-99ca5d7f67f70bb1313d7e6f666f4358a7450f82.tar.gz
gentoo-2-99ca5d7f67f70bb1313d7e6f666f4358a7450f82.tar.bz2
gentoo-2-99ca5d7f67f70bb1313d7e6f666f4358a7450f82.zip
Fix building with make >= 3.82 wrt #337912 by Diego E. Pettenò.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/traceroute/ChangeLog6
-rw-r--r--net-analyzer/traceroute/files/traceroute-2.0.15-make-382.patch12
-rw-r--r--net-analyzer/traceroute/traceroute-2.0.15.ebuild9
3 files changed, 24 insertions, 3 deletions
diff --git a/net-analyzer/traceroute/ChangeLog b/net-analyzer/traceroute/ChangeLog
index 2e6f55186ca1..cce232cc75a1 100644
--- a/net-analyzer/traceroute/ChangeLog
+++ b/net-analyzer/traceroute/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/traceroute
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceroute/ChangeLog,v 1.75 2010/07/15 17:19:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceroute/ChangeLog,v 1.76 2010/09/25 11:50:32 ssuominen Exp $
+
+ 25 Sep 2010; Samuli Suominen <ssuominen@gentoo.org>
+ traceroute-2.0.15.ebuild, +files/traceroute-2.0.15-make-382.patch:
+ Fix building with make >= 3.82 wrt #337912 by Diego E. Pettenò.
*traceroute-2.0.15 (15 Jul 2010)
diff --git a/net-analyzer/traceroute/files/traceroute-2.0.15-make-382.patch b/net-analyzer/traceroute/files/traceroute-2.0.15-make-382.patch
new file mode 100644
index 000000000000..f9a5752064e4
--- /dev/null
+++ b/net-analyzer/traceroute/files/traceroute-2.0.15-make-382.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/337912
+
+--- default.rules
++++ default.rules
+@@ -188,6 +188,6 @@
+ @mkdir -p $(DESTDIR)$(mandir)/man$(patsubst .%,%,$(suffix $(1)))
+ cp -f $(1) $(DESTDIR)$(mandir)/man$(patsubst .%,%,$(suffix $(1)))
+
+-endef
+ $(foreach man,$(install_manuals),$(call inst_man,$(man)))
++endef
+ endif
diff --git a/net-analyzer/traceroute/traceroute-2.0.15.ebuild b/net-analyzer/traceroute/traceroute-2.0.15.ebuild
index f877e6c61a5b..78e9ed40516a 100644
--- a/net-analyzer/traceroute/traceroute-2.0.15.ebuild
+++ b/net-analyzer/traceroute/traceroute-2.0.15.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceroute/traceroute-2.0.15.ebuild,v 1.1 2010/07/15 17:19:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceroute/traceroute-2.0.15.ebuild,v 1.2 2010/09/25 11:50:32 ssuominen Exp $
-inherit flag-o-matic toolchain-funcs
+EAPI=2
+inherit eutils flag-o-matic toolchain-funcs
DESCRIPTION="Utility to trace the route of IP packets"
HOMEPAGE="http://traceroute.sourceforge.net/"
@@ -13,6 +14,10 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="static"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make-382.patch
+}
+
src_compile() {
use static && append-ldflags -static
tc-export CC AR RANLIB