summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
commit7bccea6a9acc26c9c0c2c800b7a84094890c9a29 (patch)
tree9b5b36d6b92c1bda2bf2c7bda81abc01c26df605 /net-analyzer
parent*** empty log message *** (diff)
downloadgentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.gz
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.bz2
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.zip
*** empty log message ***
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/nmap-2.54_beta24.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/nmap/nmap-2.54_beta24.ebuild b/net-analyzer/nmap/nmap-2.54_beta24.ebuild
new file mode 100644
index 000000000000..37e484ce0907
--- /dev/null
+++ b/net-analyzer/nmap/nmap-2.54_beta24.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Heade
+
+P=nmap-2.54BETA24
+A=${P}.tgz
+S=${WORKDIR}/${P}
+DESCRIPTION="Portscanner"
+SRC_URI="http://www.insecure.org/nmap/dist/"${A}
+HOMEPAGE="http://www.insecure.org/nmap/"
+
+DEPEND="virtual/glibc
+ gtk? ( >=x11-libs/gtk+-1.2.8 )"
+
+src_compile() {
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --enable-ipv6
+ if [ "`use gtk`" ] ; then
+ try make
+ else
+ try make nmap
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+
+ dodoc CHANGELOG COPYING HACKING README*
+ cd docs
+ dodoc *.txt
+ docinto html
+ dodoc *.html
+}
+
+
+