summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-09-11 15:23:43 +0000
committerJon Hood <squinky86@gentoo.org>2004-09-11 15:23:43 +0000
commit70b39d8d471caa7f61357bc4f5e6cf6e8243913d (patch)
tree8ba3cd01397ce0baee952c3c2ea9f049950ebec1 /net-analyzer
parentClosing #63514 (diff)
downloadgentoo-2-70b39d8d471caa7f61357bc4f5e6cf6e8243913d.tar.gz
gentoo-2-70b39d8d471caa7f61357bc4f5e6cf6e8243913d.tar.bz2
gentoo-2-70b39d8d471caa7f61357bc4f5e6cf6e8243913d.zip
fix dependencies, #63498
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/snmptt/ChangeLog5
-rw-r--r--net-analyzer/snmptt/snmptt-0.9.ebuild17
2 files changed, 18 insertions, 4 deletions
diff --git a/net-analyzer/snmptt/ChangeLog b/net-analyzer/snmptt/ChangeLog
index c26c49020e4d..98ba9e85853d 100644
--- a/net-analyzer/snmptt/ChangeLog
+++ b/net-analyzer/snmptt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/snmptt
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/ChangeLog,v 1.3 2004/08/16 10:53:08 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/ChangeLog,v 1.4 2004/09/11 15:23:43 squinky86 Exp $
+
+ 11 Sep 2004; Jon Hood <squinky86@gentoo.org> snmptt-0.9.ebuild:
+ Fix dependencies irt #63498. Thanks Lazar Obradovic <laza@yu.net>.
16 Aug 2004; Eldad Zack <eldad@gentoo.org> snmptt-0.9.ebuild:
x86 stable
diff --git a/net-analyzer/snmptt/snmptt-0.9.ebuild b/net-analyzer/snmptt/snmptt-0.9.ebuild
index 0c0fba211418..ef9f097267db 100644
--- a/net-analyzer/snmptt/snmptt-0.9.ebuild
+++ b/net-analyzer/snmptt/snmptt-0.9.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/snmptt-0.9.ebuild,v 1.3 2004/08/16 10:53:08 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snmptt/snmptt-0.9.ebuild,v 1.4 2004/09/11 15:23:43 squinky86 Exp $
MY_P=${P/-/_}
DESCRIPTION="SNMP Trap Translator"
-RESTRICT="nomirror"
SRC_URI="mirror://sourceforge/snmptt/${MY_P}.tgz"
HOMEPAGE="http://www.snmptt.org/"
@@ -13,10 +12,16 @@ LICENSE="GPL-2"
KEYWORDS="x86 ~ppc"
SLOT="0"
-IUSE=""
+IUSE="mysql postgres"
S="${WORKDIR}/${MY_P}"
+RDEPEND=">=dev-lang/perl-5.6.1
+ dev-perl/Config-IniFiles
+ >=net-analyzer/net-snmp-5.1
+ mysql? ( dev-perl/DBD-mysql )
+ postgres? ( dev-perl/DBD-Pg )"
+
src_compile() {
echo "traphandler default /usr/sbin/snmptt" >examples/snmptrapd.conf.sample
}
@@ -34,3 +39,9 @@ src_install() {
dohtml docs/faqs.html docs/index.html docs/layout1.css docs/snmptt.html docs/snmpttconvert.html docs/snmpttconvertmib.html
}
+
+pkg_postinst() {
+ if ( use mysql || use postgres ); then
+ einfo "Read the html documentation to configure your database."
+ fi
+}