summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 02:00:45 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 02:00:45 +0000
commit708a671334b240be67f0097b3e3404c0a5715297 (patch)
tree8056304225e9b5514431fcb1532f03cabc4f72ff /net-analyzer
parentChanged econf||die to econf (diff)
downloadgentoo-2-708a671334b240be67f0097b3e3404c0a5715297.tar.gz
gentoo-2-708a671334b240be67f0097b3e3404c0a5715297.tar.bz2
gentoo-2-708a671334b240be67f0097b3e3404c0a5715297.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/p0f/p0f-1.8.2.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/net-analyzer/p0f/p0f-1.8.2.ebuild b/net-analyzer/p0f/p0f-1.8.2.ebuild
index 8bc6c421eda5..b38c568ddc2e 100644
--- a/net-analyzer/p0f/p0f-1.8.2.ebuild
+++ b/net-analyzer/p0f/p0f-1.8.2.ebuild
@@ -1,17 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.8 2002/10/04 21:09:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.9 2002/11/30 02:00:45 vapier Exp $
-S=${WORKDIR}/${P}
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
SRC_URI="http://www.stearns.org/p0f/p0f-1.8.2.tgz"
HOMEPAGE="http://www.stearns.org/p0f/"
-DEPEND="net-libs/libpcap"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="x86 sparc sparc64"
+DEPEND="net-libs/libpcap"
+
src_compile() {
patch < ${FILESDIR}/${P}-makefile.patch
cp ${FILESDIR}/${P}.rc p0f.rc
@@ -19,15 +19,11 @@ src_compile() {
}
src_install () {
- mkdir -p ${D}/usr/bin
- mkdir -p ${D}/usr/sbin
- mkdir -p ${D}/usr/share/doc
- mkdir -p ${D}/usr/share/man/man1
- mkdir -p ${D}/etc/init.d
- make DESTDIR=${D} install
+ dodir /usr/bin /usr/sbin /usr/share/doc /usr/share/man/man1 /etc/init.d
+ make DESTDIR=${D} install || die
}
-pkg_postinst () {
+pkg_postinst() {
einfo "You can start the p0f monitoring program on boot time by running"
einfo "rc-update add p0f default"
}