summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-05-24 05:48:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-05-24 05:48:24 +0000
commit31df25e91aabbffc597e0e8df633f5b8212a1756 (patch)
tree19ccbd3b8520ab6a3f0f9dbd2f43cfeb3ad6655d /net-analyzer
parentAdded a menu entry. Bug #159762 (diff)
downloadgentoo-2-31df25e91aabbffc597e0e8df633f5b8212a1756.tar.gz
gentoo-2-31df25e91aabbffc597e0e8df633f5b8212a1756.tar.bz2
gentoo-2-31df25e91aabbffc597e0e8df633f5b8212a1756.zip
Bug #179321, previous DESTDIR patching missed a single case for the munin-node.conf file.
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/munin/ChangeLog9
-rw-r--r--net-analyzer/munin/files/digest-munin-1.3.3-r23
-rw-r--r--net-analyzer/munin/files/munin-1.3.3-Makefile.patch2
-rw-r--r--net-analyzer/munin/munin-1.3.3-r2.ebuild119
4 files changed, 131 insertions, 2 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 1980ed96f810..18863107a81e 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.9 2007/05/13 06:09:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.10 2007/05/24 05:48:24 robbat2 Exp $
+
+*munin-1.3.3-r2 (22 May 2007)
+
+ 22 May 2007; Robin H. Johnson <robbat2@gentoo.org>
+ files/munin-1.3.3-Makefile.patch, +munin-1.3.3-r2.ebuild:
+ Bug #179321, previous DESTDIR patching missed a single case for the
+ munin-node.conf file.
13 May 2007; Robin H. Johnson <robbat2@gentoo.org> munin-1.3.3.ebuild:
Forgot IUSE=doc.
diff --git a/net-analyzer/munin/files/digest-munin-1.3.3-r2 b/net-analyzer/munin/files/digest-munin-1.3.3-r2
new file mode 100644
index 000000000000..505377a42102
--- /dev/null
+++ b/net-analyzer/munin/files/digest-munin-1.3.3-r2
@@ -0,0 +1,3 @@
+MD5 1e0f72f2092764b72d453f3faf298689 munin_1.3.3.tar.gz 386976
+RMD160 6fbae6ddd237332c6d28d3827a4b163259d054ea munin_1.3.3.tar.gz 386976
+SHA256 8f9bec688084cb37b573a70ecf3617d0ce7389f42f22c48b3fa4c53a68a9d7f8 munin_1.3.3.tar.gz 386976
diff --git a/net-analyzer/munin/files/munin-1.3.3-Makefile.patch b/net-analyzer/munin/files/munin-1.3.3-Makefile.patch
index e845c27887b3..80564482a32c 100644
--- a/net-analyzer/munin/files/munin-1.3.3-Makefile.patch
+++ b/net-analyzer/munin/files/munin-1.3.3-Makefile.patch
@@ -177,7 +177,7 @@
+
+ $(INSTALL) -m 0755 build/node/munin-node $(DESTDIR)$(SBINDIR)/
+ $(INSTALL) -m 0755 build/node/munin-node-configure $(DESTDIR)$(SBINDIR)/
-+ test -f "$(CONFDIR)/munin-node.conf" || $(INSTALL) -m 0644 build/node/munin-node.conf $(DESTDIR)$(CONFDIR)/
++ test -f "$(DESTDIR)$(CONFDIR)/munin-node.conf" || $(INSTALL) -m 0644 build/node/munin-node.conf $(DESTDIR)$(CONFDIR)/
+ $(INSTALL) -m 0755 build/node/munin-run $(DESTDIR)$(SBINDIR)/
uninstall-node-non-snmp: build
diff --git a/net-analyzer/munin/munin-1.3.3-r2.ebuild b/net-analyzer/munin/munin-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..100e3fc26e91
--- /dev/null
+++ b/net-analyzer/munin/munin-1.3.3-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-1.3.3-r2.ebuild,v 1.1 2007/05/24 05:48:24 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Munin Server Monitoring Tool"
+HOMEPAGE="http://munin.sourceforge.net"
+SRC_URI="mirror://sourceforge/munin/${PN}_${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc minimal munin-irc munin-dhcp munin-surfboard munin-apache munin-squid ssl"
+
+# Upstream's listing of required modules is NOT correct!
+DEPEND_COM="dev-lang/perl
+ dev-perl/net-server
+ sys-process/procps
+ ssl? ( dev-perl/Net-SSLeay )
+ dev-perl/Net-SNMP
+ dev-perl/DateManip
+ virtual/perl-Time-HiRes
+ virtual/perl-Digest-MD5
+ virtual/perl-Getopt-Long
+ virtual/perl-Storable
+ virtual/perl-Text-Balanced
+ !minimal? ( dev-perl/HTML-Template
+ net-analyzer/rrdtool )
+ munin-irc? ( dev-perl/Net-IRC )
+ munin-dhcp? ( dev-perl/Net-Netmask dev-perl/libwww-perl )
+ munin-surfboard? ( dev-perl/libwww-perl )
+ munin-apache? ( dev-perl/libwww-perl )
+ munin-squid? ( virtual/perl-MIME-Base64 )"
+ # Sybase isn't supported in Gentoo
+ #munin-sybase? ( dev-perl/DBD-Sybase )
+
+# Keep this seperate, as previous versions have had other deps here
+DEPEND="${DEPEND_COM}"
+RDEPEND="${DEPEND_COM}
+ !minimal? ( virtual/cron )"
+
+pkg_setup() {
+ enewgroup munin
+ enewuser munin 177 -1 /var/lib/munin munin
+}
+
+src_unpack() {
+ if use !minimal; then
+ if ! built_with_use net-analyzer/rrdtool perl ; then
+ die 'Sorry, munin needs net-analyzer/rrdtool built with USE=perl.'
+ fi
+ fi
+ unpack ${A}
+ # upstream needs a lot of DESTDIR loving
+ # and Gentoo location support
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.3.3-Makefile.patch
+ # Fix noise in the plugins
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-1.3.2-plugin-cleanup.patch
+}
+
+src_compile() {
+ emake build build-man || die "build/build-man failed"
+ if use doc; then
+ emake build-doc || die "build-doc failed"
+ fi
+
+ #Ensure TLS is disabled if built without SSL
+ if ! use ssl; then
+ echo "tls disabled" >> ${S}/build/node/munin-node.conf \
+ || die "Fixing munin-node.conf Failed!"
+ echo "tls disabled" >> ${S}/build/server/munin.conf \
+ || die "Fixing munin.conf Failed!"
+ fi
+
+}
+
+src_install() {
+ local dirs
+ dirs="/var/log/munin/ /var/lib/munin/"
+ dirs="${dirs} /var/lib/munin/plugin-state/"
+ dirs="${dirs} /var/run/munin/plugin-state/"
+ dirs="${dirs} /etc/munin/plugin-conf.d/"
+ dirs="${dirs} /etc/munin/plugins/"
+ keepdir ${dirs}
+
+ emake DESTDIR="${D}" install-main install-man install-node install-node-plugins || die "install failed"
+ fowners munin:munin ${dirs}
+
+ emake DESTDIR="${D}" install-man || die "install manpages failed"
+
+ insinto /etc/munin/plugin-conf.d/
+ newins ${FILESDIR}/${PN}-1.3.2-plugins.conf munin-node
+
+ # make sure we've got everything in the correct directory
+ insinto /var/lib/munin
+ newins ${FILESDIR}/${P}-crontab crontab
+ newinitd ${FILESDIR}/munin-node_init.d_1.3.3-r1 munin-node
+ newconfd ${FILESDIR}/munin-node_conf.d_1.3.3-r1 munin-node
+ dodoc README ChangeLog INSTALL logo.eps logo.svg build/resources/apache*
+}
+
+pkg_config() {
+ einfo "Press enter to install the default crontab for the munin master"
+ einfo "installation from /var/lib/munin/crontab"
+ einfo "If you have a large site, you may wish to customize it."
+ read
+ crontab -u munin /var/lib/munin/crontab
+}
+
+pkg_postinst() {
+ elog "Please follow the munin documentation to set up the plugins you"
+ elog "need, afterwards start munin-node via /etc/init.d/munin-node."
+ elog "To have munin's cronjob automatically configured for you if this is"
+ elog "your munin master installation, please:"
+ elog "emerge --config net-analyzer/munin"
+ elog ""
+ elog "Please note that the crontab has undergone some modifications"
+ elog "since 1.3.2, and you should update to it!"
+}