summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-31 16:18:21 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-31 16:18:21 +0000
commit31a5886bed42273c254973dbc5a035a30ef05ca4 (patch)
tree9bb2c94d4199db9ebf590d58f9c22e8f66981f68 /net-analyzer
parentComplete removal of psyco support, thanks ssuominen for heads up (diff)
downloadgentoo-2-31a5886bed42273c254973dbc5a035a30ef05ca4.tar.gz
gentoo-2-31a5886bed42273c254973dbc5a035a30ef05ca4.tar.bz2
gentoo-2-31a5886bed42273c254973dbc5a035a30ef05ca4.zip
Version BUmp
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/linkchecker/ChangeLog7
-rw-r--r--net-analyzer/linkchecker/linkchecker-7.6.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/net-analyzer/linkchecker/ChangeLog b/net-analyzer/linkchecker/ChangeLog
index 7e050eae517c..dd2f04491205 100644
--- a/net-analyzer/linkchecker/ChangeLog
+++ b/net-analyzer/linkchecker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/linkchecker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.66 2012/03/02 08:36:12 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/ChangeLog,v 1.67 2012/03/31 16:18:21 jlec Exp $
+
+*linkchecker-7.6 (31 Mar 2012)
+
+ 31 Mar 2012; Justin Lecher <jlec@gentoo.org> +linkchecker-7.6.ebuild:
+ Version BUmp
02 Mar 2012; Justin Lecher <jlec@gentoo.org> ChangeLog:
Dropped old broken, #386671
diff --git a/net-analyzer/linkchecker/linkchecker-7.6.ebuild b/net-analyzer/linkchecker/linkchecker-7.6.ebuild
new file mode 100644
index 000000000000..19601fdb6b68
--- /dev/null
+++ b/net-analyzer/linkchecker/linkchecker-7.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/linkchecker/linkchecker-7.6.ebuild,v 1.1 2012/03/31 16:18:21 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.7"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 2.6 3.*"
+PYTHON_MODNAME="linkcheck"
+
+inherit bash-completion-r1 distutils eutils
+
+MY_P="${P/linkchecker/LinkChecker}"
+
+DESCRIPTION="Check websites for broken links"
+HOMEPAGE="http://linkchecker.sourceforge.net/ http://pypi.python.org/pypi/linkchecker/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris"
+IUSE="bash-completion bookmarks clamav doc geoip gnome login syntax-check X"
+
+RDEPEND="
+ dev-python/dnspython
+ bash-completion? ( dev-python/optcomplete )
+ bookmarks? ( dev-python/pysqlite:2 )
+ clamav? ( app-antivirus/clamav )
+ geoip? ( dev-python/geoip-python )
+ gnome? ( dev-python/pygtk:2 )
+ login? ( dev-python/twill )
+ syntax-check? (
+ dev-python/cssutils
+ dev-python/utidylib
+ )
+ X? (
+ dev-python/PyQt4[X,assistant]
+ dev-python/qscintilla-python
+ )"
+DEPEND="
+ doc? ( x11-libs/qt-assistant )"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/7.4-missing-files.patch \
+ "${FILESDIR}"/7.0-unbundle.patch
+ distutils_src_prepare
+}
+
+src_compile() {
+ distutils_src_compile
+ if use doc; then
+ emake -C doc/html
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ delete_gui() {
+ rm -rf \
+ "${ED}"/usr/bin/linkchecker-gui* \
+ "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
+ }
+ python_execute_function -q delete_gui
+ fi
+ if use doc; then
+ dohtml doc/html/*
+ fi
+ use bash-completion && dobashcomp config/linkchecker-completion
+}