summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Barisani <lcars@gentoo.org>2005-12-18 11:25:50 +0000
committerAndrea Barisani <lcars@gentoo.org>2005-12-18 11:25:50 +0000
commit19e6697acea3f5a798760de6fa947ea5975fd728 (patch)
treeb2a7ce50557f8b181f281d28fb75ce5f41fba275 /net-analyzer/scapy/scapy-1.0.2-r1.ebuild
parentDon't use digilander, use Gentoo's mirror instead. (diff)
downloadgentoo-2-19e6697acea3f5a798760de6fa947ea5975fd728.tar.gz
gentoo-2-19e6697acea3f5a798760de6fa947ea5975fd728.tar.bz2
gentoo-2-19e6697acea3f5a798760de6fa947ea5975fd728.zip
new revision, install scapy as a python module
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-analyzer/scapy/scapy-1.0.2-r1.ebuild')
-rw-r--r--net-analyzer/scapy/scapy-1.0.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/scapy/scapy-1.0.2-r1.ebuild b/net-analyzer/scapy/scapy-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..4ec471bcf7ef
--- /dev/null
+++ b/net-analyzer/scapy/scapy-1.0.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/scapy-1.0.2-r1.ebuild,v 1.1 2005/12/18 11:25:50 lcars Exp $
+
+inherit python
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="http://www.secdev.org/projects/scapy/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="gnuplot pyx crypt graphviz imagemagick"
+
+DEPEND="virtual/python
+ net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py )
+ pyx? ( dev-python/pyx )
+ crypt? ( dev-python/pycrypto )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( media-gfx/imagemagick )"
+
+src_install() {
+ exeinto /usr/bin
+ newexe scapy.py scapy
+
+ # also install scapy as a importable python module
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins scapy.py
+
+ insinto /etc
+ doins ${FILESDIR}/ethertypes
+ dodoc AUTHORS COPYING README changelog.txt
+ doman scapy.1.*
+ }
+
+pkg_postinst() {
+ python_mod_optimize
+
+ einfo ""
+ einfo "- Check http://www.secdev.org/projects/scapy/ for additional info"
+ einfo ""
+ einfo "- To subscribe to the mailing-list, send a mail to scapy.ml-subscribe(at)secdev.org"
+ einfo "- To send a mail to the mailing-list: scapy.ml(at)secdev.org"
+ einfo "- Web archive : http://news.gmane.org/gmane.comp.security.scapy.general"
+ einfo "- NNTP, RSS, etc : http://gmane.org/info.php?group=gmane.comp.security.scapy.general"
+ einfo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}