summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-01-11 12:51:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-01-11 12:51:39 +0000
commit8454cd7d6f436e2066eaea17a547e8d578a6a2f7 (patch)
tree015373f45accc1ab76874e02f34e3a535a4fc0a3 /net-analyzer/ns
parentAdded debug IUSE flag. (diff)
downloadgentoo-2-8454cd7d6f436e2066eaea17a547e8d578a6a2f7.tar.gz
gentoo-2-8454cd7d6f436e2066eaea17a547e8d578a6a2f7.tar.bz2
gentoo-2-8454cd7d6f436e2066eaea17a547e8d578a6a2f7.zip
'Initial commit, original ebuild by Christophe Radovcic <christophe.radovcic@laposte.net>, heavily modified by robbat2@gentoo.org
Diffstat (limited to 'net-analyzer/ns')
-rw-r--r--net-analyzer/ns/ChangeLog10
-rw-r--r--net-analyzer/ns/Manifest2
-rw-r--r--net-analyzer/ns/files/digest-ns-2.261
-rw-r--r--net-analyzer/ns/ns-2.26.ebuild68
4 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/ns/ChangeLog b/net-analyzer/ns/ChangeLog
new file mode 100644
index 000000000000..8f0566e8281d
--- /dev/null
+++ b/net-analyzer/ns/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/ns
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ChangeLog,v 1.1 2004/01/11 12:51:39 robbat2 Exp $
+
+*ns-2.26 (11 Jan 2004)
+
+ 11 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> ns-2.26.ebuild:
+ Initial commit, original ebuild by Christophe Radovcic
+ <christophe.radovcic@laposte.net>, heavily modified by robbat2@gentoo.org
+
diff --git a/net-analyzer/ns/Manifest b/net-analyzer/ns/Manifest
new file mode 100644
index 000000000000..8495e94550be
--- /dev/null
+++ b/net-analyzer/ns/Manifest
@@ -0,0 +1,2 @@
+MD5 70bac822158530cacc0fb2c695be271e ns-2.26.ebuild 1665
+MD5 e50216b9efeff43a6e4ccadbc249ab44 files/digest-ns-2.26 65
diff --git a/net-analyzer/ns/files/digest-ns-2.26 b/net-analyzer/ns/files/digest-ns-2.26
new file mode 100644
index 000000000000..ae75367cf458
--- /dev/null
+++ b/net-analyzer/ns/files/digest-ns-2.26
@@ -0,0 +1 @@
+MD5 c75aa2047fa3e13ed2a43881c50e4c65 ns-src-2.26.tar.gz 41592248
diff --git a/net-analyzer/ns/ns-2.26.ebuild b/net-analyzer/ns/ns-2.26.ebuild
new file mode 100644
index 000000000000..4eab84a596a8
--- /dev/null
+++ b/net-analyzer/ns/ns-2.26.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ns/ns-2.26.ebuild,v 1.1 2004/01/11 12:51:39 robbat2 Exp $
+
+DESCRIPTION="Network Simulator"
+HOMEPAGE="http://www.isi.edu/nsnam/ns/"
+SRC_URI="http://www.isi.edu/nsnam/dist/${PN}-src-${PV}.tar.gz"
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc debug"
+DEPEND_COMMON=">=dev-lang/tcl-8.3.2
+ >=dev-lang/tk-8.3.2
+ >=dev-tcltk/otcl-1.0.8a
+ >=dev-tcltk/tclcl-1.0.13b
+ net-libs/libpcap
+ debug? ( =dev-lang/perl-5* >=media-gfx/xgraph-12.1 >=dev-libs/dmalloc-4.8.2 >=dev-tcltk/tcl-debug-2.0 )"
+DEPEND="doc? ( app-text/tetex app-text/ghostscript dev-tex/latex2html ) ${DEPEND_COMMON}"
+# for later
+#RDEPEND=">=net-analyzer/nam-1.9 ${DEPEND_COMMON}"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep -ri 'tcl\.result[[:space:]]*()' * -l | \
+ xargs -r -n1 sed -e 's|tcl\.result[[:space:]]*()|(char*)tcl.result()|' -i
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="${myconf} --with-tcldebug=/usr/lib/tcldbg2.0" || myconf="${myconf} --with-tcldebug=no"
+ myconf="${myconf} `use_with debug dmalloc`"
+ local mytclver=""
+ for i in 8.4 8.3; do
+ einfo "Testing TCL ${i}"
+ has_version "=dev-lang/tcl-${i}*" && mytclver=${i}
+ [ "${#mytclver}" -gt 2 ] && break
+ done
+ einfo "Using TCL ${mytclver}"
+ myconf="${myconf} --with-tcl-ver=${mytclver} --with-tk-ver=${mytclver}"
+
+ econf \
+ ${myconf} \
+ --mandir=/usr/share/man \
+ --enable-stl \
+ --enable-release || die "./configure failed"
+ emake CCOPT="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ make DESTDIR=${D} MANDEST=/usr/share/man install || die
+ dobin nse
+
+ dodoc BASE-VERSION COPYRIGHTS FILES HOWTO-CONTRIBUTE README VERSION
+ dohtml CHANGES.html TODO.html
+
+ if use doc; then
+ einfo "Generating extra docs"
+ cd doc
+ docinto doc
+ emake all
+ dodoc everything.dvi everything.ps.gz everything.html everything.pdf
+ fi
+}