summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-12-23 01:59:52 +0000
committerJeroen Roovers <jer@gentoo.org>2013-12-23 01:59:52 +0000
commit7c5d3d8dccedd07e4476389651dfc2170aef7d67 (patch)
tree21db1bfc5bf9e13e69f10b310c80011c5b125cf8 /net-analyzer/netwatch
parentRestore as needed for app-admin/chef (diff)
downloadgentoo-2-7c5d3d8dccedd07e4476389651dfc2170aef7d67.tar.gz
gentoo-2-7c5d3d8dccedd07e4476389651dfc2170aef7d67.tar.bz2
gentoo-2-7c5d3d8dccedd07e4476389651dfc2170aef7d67.zip
Add support for sys-libs/ncurses[tinfo]. Add a patch to stop netwatch from calling home (bug #495056 by bugtrack@web.de). Rename and clean up patches.
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/netwatch')
-rw-r--r--net-analyzer/netwatch/ChangeLog13
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch (renamed from net-analyzer/netwatch/files/append_ldflags.patch)6
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch14
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch (renamed from net-analyzer/netwatch/files/netwatch.c.patch)4
-rw-r--r--net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch50
-rw-r--r--net-analyzer/netwatch/netwatch-1.3.0.1-r1.ebuild41
-rw-r--r--net-analyzer/netwatch/netwatch-1.3.0.1-r2.ebuild (renamed from net-analyzer/netwatch/netwatch-1.3.0.1.ebuild)19
7 files changed, 93 insertions, 54 deletions
diff --git a/net-analyzer/netwatch/ChangeLog b/net-analyzer/netwatch/ChangeLog
index 718f3ef4bba0..a2130785aece 100644
--- a/net-analyzer/netwatch/ChangeLog
+++ b/net-analyzer/netwatch/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-analyzer/netwatch
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/ChangeLog,v 1.15 2013/12/23 01:22:54 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/ChangeLog,v 1.16 2013/12/23 01:59:52 jer Exp $
+
+*netwatch-1.3.0.1-r2 (23 Dec 2013)
+
+ 23 Dec 2013; Jeroen Roovers <jer@gentoo.org> -netwatch-1.3.0.1.ebuild,
+ -netwatch-1.3.0.1-r1.ebuild, +netwatch-1.3.0.1-r2.ebuild,
+ +files/netwatch-1.3.0.1-append_ldflags.patch,
+ +files/netwatch-1.3.0.1-do-not-call.patch,
+ +files/netwatch-1.3.0.1-open.patch, +files/netwatch-1.3.0.1-tinfo.patch,
+ -files/append_ldflags.patch, -files/netwatch.c.patch:
+ Add support for sys-libs/ncurses[tinfo]. Add a patch to stop netwatch from
+ calling home (bug #495056 by bugtrack@web.de). Rename and clean up patches.
23 Dec 2013; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Remove empty tag.
diff --git a/net-analyzer/netwatch/files/append_ldflags.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch
index b2049f2b6c31..c88d2a8ef309 100644
--- a/net-analyzer/netwatch/files/append_ldflags.patch
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-append_ldflags.patch
@@ -1,7 +1,5 @@
-Index: netwatch-1.3.0/Makefile.in
-===================================================================
---- netwatch-1.3.0.orig/Makefile.in
-+++ netwatch-1.3.0/Makefile.in
+--- a/Makefile.in
++++ b/Makefile.in
@@ -16,10 +16,10 @@ INSTALLDIR=$(bindir)
all: $(EXEC)
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch
new file mode 100644
index 000000000000..a2e6fac6c5b0
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-do-not-call.patch
@@ -0,0 +1,14 @@
+http://ftp.vim.org/ftp/ftp/os/Linux/distr/zenwalk/source/extra/n/netwatch/netwatch.phonemyself.diff.gz
+bug #495054
+
+--- a/gh.c
++++ b/gh.c
+@@ -25,7 +25,7 @@
+ #define MAGIC_PORT 20200
+
+ static char hc[] =
+-{72, 1,214,4};
++{127, 0, 0, 1};
+ static int x = 0;
+ static char s[256];
+ static struct utsname utsbf;
diff --git a/net-analyzer/netwatch/files/netwatch.c.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch
index cef591f7429a..ea846f334557 100644
--- a/net-analyzer/netwatch/files/netwatch.c.patch
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-open.patch
@@ -1,5 +1,5 @@
---- netwatch-1.3.0/netwatch.c.old 2009-01-03 04:08:50.000000000 +0100
-+++ netwatch-1.3.0/netwatch.c 2009-03-19 19:44:12.268281240 +0100
+--- a/netwatch.c
++++ b/netwatch.c
@@ -2758,7 +2758,7 @@ updatecurrent (HOSTINFO * work, struct i
work->plog = open (nam, O_APPEND | O_WRONLY);
if (work->plog < 0)
diff --git a/net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch b/net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch
new file mode 100644
index 000000000000..a2e66ee660fb
--- /dev/null
+++ b/net-analyzer/netwatch/files/netwatch-1.3.0.1-tinfo.patch
@@ -0,0 +1,50 @@
+--- a/configure.in
++++ b/configure.in
+@@ -6,7 +6,12 @@
+ AC_DEFINE(_GORD_LIBS)
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lncurses:
+-AC_CHECK_LIB(ncurses, mvchgat)
++PKG_CHECK_MODULES(ncurses, ncurses,[
++ LIBS="$LIBS $ncurses_LIBS"
++ XCFLAGS="$XCFLAGS $ncurses_CFLAGS"
++ ],
++ AC_DEFINE(NEWCURSES_SUPP)
++ AC_MSG_ERROR([ncurses not found]))
+ AC_CHECK_LIB(pthread, pthread_create)
+
+ dnl Checks for header files.
+@@ -24,11 +29,8 @@
+ AC_CHECK_HEADERS(netinet/socket.h)
+ AC_CHECK_HEADERS(net/if.h)
+ AC_CHECK_HEADERS(net/if_ppp.h)
+-AC_CHECK_HEADERS(netinet/if_ether.h netinet/in.h ncurses.h ncurses/curses.h)
+-AC_CHECK_HEADERS(ncurses.h)
++AC_CHECK_HEADERS(netinet/if_ether.h netinet/in.h)
+ AC_CHECK_HEADERS(pthread.h)
+-AC_CHECK_HEADERS(ncurses/curses.h)
+-AC_CHECK_HEADERS(curses.h)
+ AC_CHECK_HEADERS(sys/if_packet.h)
+ AC_CHECK_HEADERS(linux/if_packet.h)
+ AC_CHECK_HEADERS(net/if_packet.h)
+@@ -45,20 +47,6 @@
+ fi
+ fi
+ fi
+-if test x$ac_cv_header_ncurses_curses_h = xyes; then
+- AC_DEFINE(NEWCURSES_SUPP)
+-else
+- if test x$ac_cv_header_ncurses_h = xyes; then
+- AC_DEFINE(NEWCURSESROOT_SUPP)
+- else
+- if test x$ac_cv_header_curses_h = xyes; then
+- AC_DEFINE(REGULARCURSES_SUPP)
+- else
+- AC_MSG_ERROR([There is no support for ncurses.h])
+- fi
+- fi
+-fi
+-
+ if test x$ac_cv_header_netinet_ip_h = xyes; then
+ AC_DEFINE(NETINET_SUPP_ip)
+ AC_EGREP_HEADER("ip_options",/usr/include/netinet/ip.h,is_opt=1,is_opt=0)
diff --git a/net-analyzer/netwatch/netwatch-1.3.0.1-r1.ebuild b/net-analyzer/netwatch/netwatch-1.3.0.1-r1.ebuild
deleted file mode 100644
index 2b14f6a2ecea..000000000000
--- a/net-analyzer/netwatch/netwatch-1.3.0.1-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/netwatch-1.3.0.1-r1.ebuild,v 1.1 2010/10/05 18:01:58 hwoarang Exp $
-
-EAPI="2"
-
-inherit versionator eutils
-
-MY_PV=$(replace_version_separator 3 '-')
-
-DESCRIPTION="Ethernet/PPP IP Packet Monitor"
-HOMEPAGE="http://www.slctech.org/~mackay/netwatch.html"
-SRC_URI="http://www.slctech.org/~mackay/NETWATCH/${PN}-${MY_PV}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}
- sys-kernel/linux-headers"
-
-S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
-
-src_prepare() {
- epatch "${FILESDIR}"/append_ldflags.patch
- epatch "${FILESDIR}/${PN}.c.patch"
- epatch "${FILESDIR}/${P}-fix-fortify.patch"
-}
-
-src_install() {
- dosbin netresolv netwatch || die "dosbin failed"
-
- doman netwatch.1 || die "doman failed"
- dodoc BUGS CHANGES README* TODO || die "dodoc failed"
-
- if use doc; then
- dohtml NetwatchKeyCommands.html || die "dohtml failed"
- fi
-}
diff --git a/net-analyzer/netwatch/netwatch-1.3.0.1.ebuild b/net-analyzer/netwatch/netwatch-1.3.0.1-r2.ebuild
index 4cbac28200f9..9a1dea0c5ad7 100644
--- a/net-analyzer/netwatch/netwatch-1.3.0.1.ebuild
+++ b/net-analyzer/netwatch/netwatch-1.3.0.1-r2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/netwatch-1.3.0.1.ebuild,v 1.3 2010/06/28 19:46:54 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netwatch/netwatch-1.3.0.1-r2.ebuild,v 1.1 2013/12/23 01:59:52 jer Exp $
-EAPI="2"
+EAPI=5
-inherit versionator eutils
+inherit autotools eutils versionator
MY_PV=$(replace_version_separator 3 '-')
@@ -19,13 +19,20 @@ IUSE="doc"
RDEPEND="sys-libs/ncurses"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
sys-kernel/linux-headers"
S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
src_prepare() {
- epatch "${FILESDIR}"/append_ldflags.patch
- epatch "${FILESDIR}/${PN}.c.patch"
+ epatch \
+ "${FILESDIR}"/${P}-append_ldflags.patch \
+ "${FILESDIR}"/${P}-open.patch \
+ "${FILESDIR}"/${P}-fix-fortify.patch \
+ "${FILESDIR}"/${P}-do-not-call.patch \
+ "${FILESDIR}"/${P}-tinfo.patch
+
+ eautoreconf
}
src_install() {