summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-07 14:54:12 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-06-07 14:54:12 +0000
commit75833c10ecb5d2c4f0e8c3a68b7e8d23094eeb15 (patch)
treed13177e888265b3de985a83eaa88fe7ba3f82bfa /net-analyzer/net-snmp
parentRemoved old versions. (diff)
downloadgentoo-2-75833c10ecb5d2c4f0e8c3a68b7e8d23094eeb15.tar.gz
gentoo-2-75833c10ecb5d2c4f0e8c3a68b7e8d23094eeb15.tar.bz2
gentoo-2-75833c10ecb5d2c4f0e8c3a68b7e8d23094eeb15.zip
Add patch to fix bug #224251, remove filtering of --as-needed as it builds fine with it (plus it's the wrong way to avoid it), and _if there are bugs you can't solve, just ask me_.
(Portage version: 2.1.5.4)
Diffstat (limited to 'net-analyzer/net-snmp')
-rw-r--r--net-analyzer/net-snmp/ChangeLog8
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.4.1-perl-asneeded.patch33
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild13
3 files changed, 47 insertions, 7 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index fad8fb06a412..64350f135675 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.168 2008/06/06 20:06:33 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.169 2008/06/07 14:54:11 flameeyes Exp $
+
+ 07 Jun 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/net-snmp-5.4.1-perl-asneeded.patch, net-snmp-5.4.1-r4.ebuild:
+ Add patch to fix bug #224251, remove filtering of --as-needed as it builds
+ fine with it (plus it's the wrong way to avoid it), and _if there are bugs
+ you can't solve, just ask me_.
*net-snmp-5.4.1-r4 (06 Jun 2008)
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.4.1-perl-asneeded.patch b/net-analyzer/net-snmp/files/net-snmp-5.4.1-perl-asneeded.patch
new file mode 100644
index 000000000000..766436e3f9eb
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmp-5.4.1-perl-asneeded.patch
@@ -0,0 +1,33 @@
+Index: net-snmp-5.4.1/configure.in
+===================================================================
+--- net-snmp-5.4.1.orig/configure.in
++++ net-snmp-5.4.1/configure.in
+@@ -2,7 +2,7 @@
+ # the Net-SNMP's COPYING file for more details and other copyrights
+ # that may apply:
+ #
+-# Portions Copyright © 2003 Sun Microsystems, Inc. All rights reserved.
++# Portions Copyright © 2003 Sun Microsystems, Inc. All rights reserved.
+ # Use is subject to license terms specified in the COPYING file
+ # distributed with the Net-SNMP package.
+ #
+@@ -3097,8 +3097,8 @@ fi
+
+ # check needed functions
+ if test "x$embed_perl" != "xno" ; then
+- OLDLDFLAGS="$LDFLAGS"
+- LDFLAGS="$LDFLAGS $netsnmp_perlldopts"
++ OLDLIBS="$LIBS"
++ LIBS="$LIBS $netsnmp_perlldopts"
+
+ # newer perl vs older perl call functions
+ AC_CHECK_FUNCS(eval_pv)
+@@ -3109,7 +3109,7 @@ if test "x$embed_perl" != "xno" ; then
+ AC_CHECK_FUNC(perl_eval_pv, AC_DEFINE(HAVE_PERL_EVAL_PV_LC))
+ AC_CHECK_FUNC(Perl_eval_pv, AC_DEFINE(HAVE_PERL_EVAL_PV_UC))
+
+- LDFLAGS="$OLDLDFLAGS"
++ LIBS="$OLDLIBS"
+
+
+ if test "x$ac_cv_func_perl_eval_pv" != "xyes" -a "x$ac_cv_func_Perl_eval_pv" != "xyes" -a "x$ac_cv_func_eval_pv" != "xyes" ; then
diff --git a/net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild b/net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild
index 1e0abef54212..02b91a09f9a6 100644
--- a/net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild
+++ b/net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild,v 1.2 2008/06/06 21:33:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.4.1-r4.ebuild,v 1.3 2008/06/07 14:54:11 flameeyes Exp $
-inherit fixheadtails flag-o-matic perl-module python
+inherit fixheadtails flag-o-matic perl-module python autotools
DESCRIPTION="Software for generating and retrieving SNMP data"
HOMEPAGE="http://net-snmp.sourceforge.net/"
@@ -69,6 +69,11 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-CVE-2008-2292.patch #222265
epatch "${FILESDIR}"/${P}-process-count-race.patch #213415
epatch "${FILESDIR}"/${P}-incorrect-hrFSStorageIndex.patch #211660
+
+ epatch "${FILESDIR}"/${P}-perl-asneeded.patch #224251
+
+ eautoreconf
+
ht_fix_all
}
@@ -77,10 +82,6 @@ src_compile() {
strip-flags
- # filter for bug #145960
- # as it seems that the option is not enough
- filter-ldflags -Wl,--as-needed
-
mibs="host ucd-snmp/dlmod"
use smux && mibs="${mibs} smux"
use sendmail && mibs="${mibs} mibII/mta_sendmail"