summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-30 14:45:51 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-30 14:45:51 +0000
commit0d5b140cda9deb1529e091ce781df2c9609317ae (patch)
tree2b18600c53ca9cddd5523cff47129b80a89421fb /net-analyzer/honeyd/honeyd-1.0-r1.ebuild
parentkeepdir /var/lib/spool/prelude-manager, bug 94740. (diff)
downloadgentoo-2-0d5b140cda9deb1529e091ce781df2c9609317ae.tar.gz
gentoo-2-0d5b140cda9deb1529e091ce781df2c9609317ae.tar.bz2
gentoo-2-0d5b140cda9deb1529e091ce781df2c9609317ae.zip
Revision bump; fixed init script so that the webserver will start, bug 89348.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-analyzer/honeyd/honeyd-1.0-r1.ebuild')
-rw-r--r--net-analyzer/honeyd/honeyd-1.0-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/honeyd/honeyd-1.0-r1.ebuild b/net-analyzer/honeyd/honeyd-1.0-r1.ebuild
new file mode 100644
index 000000000000..b330d64bd3eb
--- /dev/null
+++ b/net-analyzer/honeyd/honeyd-1.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/honeyd/honeyd-1.0-r1.ebuild,v 1.1 2005/06/30 14:45:51 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="Honeyd is a small daemon that creates virtual hosts on a network"
+HOMEPAGE="http://www.citi.umich.edu/u/provos/honeyd/"
+SRC_URI="http://www.citi.umich.edu/u/provos/honeyd/${P}.tar.gz
+ http://www.tracking-hackers.com/solutions/honeyd/honeyd-0.7a-beta2.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc"
+IUSE="doc"
+
+DEPEND=">=dev-libs/libdnet-1.7
+ >=dev-libs/libevent-1.0
+ virtual/libpcap"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s:^CFLAGS = -O2:CFLAGS = ${CFLAGS}:g" Makefile.in || die "sed failed"
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
+src_compile() {
+ econf --with-libdnet=/usr || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc README TODO
+ dosbin honeyd || die "dosbin failed"
+
+ einstall || die "make install failed"
+
+ rm ${D}/usr/bin/honeyd
+ rm ${D}/usr/share/honeyd/README
+
+ insinto /etc
+ newins config.sample honeyd.conf || die "failed to install honeyd.conf"
+
+ newinitd ${FILESDIR}/${PN}.initd ${PN} || die
+ newconfd ${FILESDIR}/${PN}.confd ${PN} || die
+
+ # This adds all the services and example configurations collected
+ # by Lance Spitzer
+
+ # Install the white-papers if 'doc' USE flags are specified
+ use doc && dodoc ${WORKDIR}/honeyd-0.7a-beta2/contrib/*
+
+ # Install the example configurations
+ cd ${WORKDIR}/honeyd-0.7a-beta2
+ dodoc honeyd.conf nmap.prints nmap.assoc pf.os xprobe2.conf
+ dodoc honeyd.conf.simple honeyd.conf.bloat nmap.prints.new
+ dodoc xprobe2.conf.new honeyd.conf.networks
+
+ # Install all the example scripts
+ cp -R scripts ${D}/usr/share/honeyd/
+ find ${D}/usr/share/honeyd/scripts \
+ -type f -name '*.sh' -o -name '*.pl' -exec chmod +x {} \;
+}
+