summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2007-07-03 10:33:26 +0000
committerPeter Volkov <pva@gentoo.org>2007-07-03 10:33:26 +0000
commit3ab577c419672c5fe17f137a85abe63744108ecc (patch)
tree59cbc3285e52a114639dc6a8a9589f1fe28f6df3 /net-analyzer/cacti
parentAdd ~alpha wrt #182519 (diff)
downloadgentoo-2-3ab577c419672c5fe17f137a85abe63744108ecc.tar.gz
gentoo-2-3ab577c419672c5fe17f137a85abe63744108ecc.tar.bz2
gentoo-2-3ab577c419672c5fe17f137a85abe63744108ecc.zip
Added pcre and session php checks. Fixed bug #184057. Removed vulnerable to bug #181112 versions.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog7
-rw-r--r--net-analyzer/cacti/cacti-0.8.6i-r1.ebuild91
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r4.ebuild97
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r5.ebuild99
-rw-r--r--net-analyzer/cacti/cacti-0.8.6j-r6.ebuild6
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6i-r115
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6j-r415
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.6j-r515
8 files changed, 9 insertions, 336 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index ffb74fea7e18..bb5268d0ea92 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.109 2007/06/09 16:12:02 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.110 2007/07/03 10:33:26 pva Exp $
+
+ 03 Jul 2007; <pva@gentoo.org> -cacti-0.8.6i-r1.ebuild,
+ -cacti-0.8.6j-r4.ebuild, -cacti-0.8.6j-r5.ebuild, cacti-0.8.6j-r6.ebuild:
+ Added pcre and session php checks. Fixed bug #184057. Removed vulnerable to
+ bug #181112 versions.
09 Jun 2007; Markus Rothe <corsair@gentoo.org> cacti-0.8.6j-r6.ebuild:
Stable on ppc64; bug #181112
diff --git a/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild b/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
deleted file mode 100644
index 2a94b44f03ac..000000000000
--- a/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6i-r1.ebuild,v 1.9 2007/06/26 02:20:27 mr_bones_ Exp $
-
-inherit eutils webapp depend.apache depend.php
-
-# Support for _p* in version.
-MY_P=${P/_p*/}
-# (patched versions)
-HAS_PATCHES=1
-
-DESCRIPTION="Cacti is a complete frontend to rrdtool"
-HOMEPAGE="http://www.cacti.net/"
-SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
-
-# patches
-if [ $HAS_PATCHES == 1 ] ; then
- UPSTREAM_PATCHES="poller_output_remainder
- dec06-vulnerability-poller-0.8.6i
- dec06-vulnerability-scripts-0.8.6i
- import_template_argument_space_removal"
- for i in $UPSTREAM_PATCHES ; do
- SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
- done
-fi
-
-LICENSE="GPL-2"
-KEYWORDS="alpha ~amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="snmp"
-
-DEPEND=""
-
-want_apache
-need_php_cli
-need_php_httpd
-
-RDEPEND="!apache2? ( www-servers/lighttpd )
- snmp? ( net-analyzer/net-snmp )
- net-analyzer/rrdtool
- virtual/mysql
- virtual/cron"
-
-src_unpack() {
- if [ $HAS_PATCHES == 1 ] ; then
- unpack ${MY_P}.tar.gz
- [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
- # patches
- for i in ${UPSTREAM_PATCHES} ; do
- EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
- done ;
- else
- unpack ${MY_P}.tar.gz
- fi
-}
-
-pkg_setup() {
- webapp_pkg_setup
- has_php
- if [ $PHP_VERSION = 5 ] ; then
- require_php_with_use cli mysql xml
- elif [ $PHP_VERSION = 4 ] ; then
- require_php_with_use cli mysql xml expat
- fi
-}
-
-src_compile() {
- einfo "Nothing to compile."
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc LICENSE
- rm LICENSE README
-
- dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
- rm -rf docs
-
- edos2unix `find -type f -name '*.php'`
-
- dodir ${MY_HTDOCSDIR}
- cp -r . "${D}"${MY_HTDOCSDIR}
-
- webapp_serverowned ${MY_HTDOCSDIR}/rra
- webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
- webapp_configfile ${MY_HTDOCSDIR}/include/config.php
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild
deleted file mode 100644
index aae5a99c46e3..000000000000
--- a/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r4.ebuild,v 1.9 2007/06/26 02:20:27 mr_bones_ Exp $
-
-inherit eutils webapp depend.apache depend.php
-
-# Support for _p* in version.
-MY_P=${P/_p*/}
-HAS_PATCHES=1
-
-DESCRIPTION="Cacti is a complete frontend to rrdtool"
-HOMEPAGE="http://www.cacti.net/"
-SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
-
-# patches
-if [ $HAS_PATCHES == 1 ] ; then
- UPSTREAM_PATCHES="ping_php_version4_snmpgetnext
- tree_console_missing_hosts
- thumbnail_graphs_not_working
- graph_debug_lockup_fix"
- for i in $UPSTREAM_PATCHES ; do
- SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
- done
-fi
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="snmp bundled-adodb"
-
-DEPEND=""
-
-want_apache
-need_php_cli
-need_php_httpd
-
-RDEPEND="!apache2? ( www-servers/lighttpd )
- snmp? ( net-analyzer/net-snmp )
- net-analyzer/rrdtool
- !bundled-adodb? ( dev-php/adodb )
- virtual/mysql
- virtual/cron"
-
-src_unpack() {
- if [ $HAS_PATCHES == 1 ] ; then
- unpack ${MY_P}.tar.gz
- [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
- # patches
- for i in ${UPSTREAM_PATCHES} ; do
- EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
- done ;
- else
- unpack ${MY_P}.tar.gz
- fi
-
- use bundled-adodb || sed -i -e \
- 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"/usr/share/php/adodb/adodb.inc.php":' \
- "${S}"/include/config.php || die "Adodb sed failed."
-}
-
-pkg_setup() {
- webapp_pkg_setup
- has_php
- if [ $PHP_VERSION = 5 ] ; then
- require_php_with_use cli mysql xml
- elif [ $PHP_VERSION = 4 ] ; then
- require_php_with_use cli mysql xml expat
- fi
- use bundled-adodb || require_php_with_use sockets
-}
-
-src_compile() {
- einfo "Nothing to compile."
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc LICENSE
- rm LICENSE README
-
- dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
- rm -rf docs
- use bundled-adodb || rm -rf lib/adodb
-
- edos2unix `find -type f -name '*.php'`
-
- dodir ${MY_HTDOCSDIR}
- cp -r . "${D}"${MY_HTDOCSDIR}
-
- webapp_serverowned ${MY_HTDOCSDIR}/rra
- webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
- webapp_configfile ${MY_HTDOCSDIR}/include/config.php
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild
deleted file mode 100644
index c42f58028af9..000000000000
--- a/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r5.ebuild,v 1.4 2007/06/26 02:20:27 mr_bones_ Exp $
-
-inherit eutils webapp depend.apache depend.php
-
-# Support for _p* in version.
-MY_P=${P/_p*/}
-HAS_PATCHES=1
-
-DESCRIPTION="Cacti is a complete frontend to rrdtool"
-HOMEPAGE="http://www.cacti.net/"
-SRC_URI="http://www.cacti.net/downloads/${MY_P}.tar.gz"
-
-# patches
-if [ $HAS_PATCHES == 1 ] ; then
- UPSTREAM_PATCHES="ping_php_version4_snmpgetnext
- tree_console_missing_hosts
- thumbnail_graphs_not_working
- graph_debug_lockup_fix"
- for i in $UPSTREAM_PATCHES ; do
- SRC_URI="${SRC_URI} http://www.cacti.net/downloads/patches/${PV/_p*}/${i}.patch"
- done
-fi
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ppc64 sparc ~x86"
-IUSE="snmp bundled-adodb"
-
-DEPEND=""
-
-want_apache
-need_php_cli
-need_php_httpd
-
-RDEPEND="!apache2? ( www-servers/lighttpd )
- snmp? ( net-analyzer/net-snmp )
- net-analyzer/rrdtool
- !bundled-adodb? ( dev-php/adodb )
- virtual/mysql
- virtual/cron"
-
-src_unpack() {
- if [ $HAS_PATCHES == 1 ] ; then
- unpack ${MY_P}.tar.gz
- [ ! ${MY_P} == ${P} ] && mv ${MY_P} ${P}
- # patches
- for i in ${UPSTREAM_PATCHES} ; do
- EPATCH_OPTS="-p1 -d ${S} -N" epatch "${DISTDIR}"/${i}.patch
- done ;
- else
- unpack ${MY_P}.tar.gz
- fi
-
- epatch "${FILESDIR}/${P}"-dos-large-values.patch
-
- use bundled-adodb || sed -i -e \
- 's:$config\["library_path"\] . "/adodb/adodb.inc.php":"/usr/share/php/adodb/adodb.inc.php":' \
- "${S}"/include/config.php || die "Adodb sed failed."
-}
-
-pkg_setup() {
- webapp_pkg_setup
- has_php
- if [ $PHP_VERSION = 5 ] ; then
- require_php_with_use cli mysql xml
- elif [ $PHP_VERSION = 4 ] ; then
- require_php_with_use cli mysql xml expat
- fi
- use bundled-adodb || require_php_with_use sockets
-}
-
-src_compile() {
- einfo "Nothing to compile."
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc LICENSE
- rm LICENSE README
-
- dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
- rm -rf docs
- use bundled-adodb || rm -rf lib/adodb
-
- edos2unix `find -type f -name '*.php'`
-
- dodir ${MY_HTDOCSDIR}
- cp -r . "${D}"${MY_HTDOCSDIR}
-
- webapp_serverowned ${MY_HTDOCSDIR}/rra
- webapp_serverowned ${MY_HTDOCSDIR}/log/cacti.log
- webapp_configfile ${MY_HTDOCSDIR}/include/config.php
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
diff --git a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
index 805256cfda56..72d9123ff004 100644
--- a/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.8 2007/06/26 02:20:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6j-r6.ebuild,v 1.9 2007/07/03 10:33:26 pva Exp $
inherit eutils webapp depend.apache depend.php
@@ -64,9 +64,9 @@ pkg_setup() {
webapp_pkg_setup
has_php
if [ $PHP_VERSION = 5 ] ; then
- phpUseFlags="cli mysql xml"
+ phpUseFlags="cli mysql xml session pcre"
elif [ $PHP_VERSION = 4 ] ; then
- phpUseFlags="cli mysql xml expat"
+ phpUseFlags="cli mysql xml session pcre expat"
fi
use bundled-adodb || phpUseFlags="${phpUseFlags} sockets"
require_php_with_use ${phpUseFlags}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6i-r1 b/net-analyzer/cacti/files/digest-cacti-0.8.6i-r1
deleted file mode 100644
index 5518d1fcba6f..000000000000
--- a/net-analyzer/cacti/files/digest-cacti-0.8.6i-r1
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 341b5828d95db91f81f5fbba65411d63 cacti-0.8.6i.tar.gz 1122700
-RMD160 2c5ea7dc594c455c710f8c253a25805883395a2f cacti-0.8.6i.tar.gz 1122700
-SHA256 3998dae625314309c58cea0fc1e48fb08cf4c2973013413f2726cdc5cf1ac6ac cacti-0.8.6i.tar.gz 1122700
-MD5 17b2997b6708a8bcf99c702b6cec047d dec06-vulnerability-poller-0.8.6i.patch 5994
-RMD160 cf60d715e6ae9285c6a0bd562fcd65290dcd1bdb dec06-vulnerability-poller-0.8.6i.patch 5994
-SHA256 4bb02a9022be25a1340e328f3c911a5386a8fb0c23a95285fcc8d8912dacc605 dec06-vulnerability-poller-0.8.6i.patch 5994
-MD5 5ce8da430a63ea8e675d0eef46e8b60a dec06-vulnerability-scripts-0.8.6i.patch 4358
-RMD160 8daaaf3d7d743206551502c3945c81fc689999c1 dec06-vulnerability-scripts-0.8.6i.patch 4358
-SHA256 89d48d5758ef0517f8d34a95dee02662af80efc8f988b87cfbc68c6e169c9f36 dec06-vulnerability-scripts-0.8.6i.patch 4358
-MD5 c56da30a12487610393aa2eaa7fe8c6a import_template_argument_space_removal.patch 634
-RMD160 c0f8a1c135a58cd45a87549d2a170814f6f36337 import_template_argument_space_removal.patch 634
-SHA256 d0a64ebd1fba7a2dcd6e7b6bb08f4dbc39f238b6c492f4874451736344a6e460 import_template_argument_space_removal.patch 634
-MD5 3b7ad717cbf8874fd96ea9f45d97cfbc poller_output_remainder.patch 1891
-RMD160 7aab97b71d5915ca8085174f69318cb223eb6c5e poller_output_remainder.patch 1891
-SHA256 2d8053d90dd363f4822072e58713b7d5f4b23825de4df2e9d429bfb5e8ec8201 poller_output_remainder.patch 1891
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r4 b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r4
deleted file mode 100644
index fbccf1df186f..000000000000
--- a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r4
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 29436be46b289d13dfce48e7618129e2 cacti-0.8.6j.tar.gz 1126337
-RMD160 981d24753d440af1d3fcfdb20cd988f73fcc44fe cacti-0.8.6j.tar.gz 1126337
-SHA256 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46 cacti-0.8.6j.tar.gz 1126337
-MD5 85a95eaef5fac31d5ca87cb915493cdd graph_debug_lockup_fix.patch 927
-RMD160 8bf2112cb537b330547b8b571cc573a0f3135123 graph_debug_lockup_fix.patch 927
-SHA256 c8ea30c6bf5764663d106d28b3308377a8c2003cc2afd3d0ba0102ed5fddee1b graph_debug_lockup_fix.patch 927
-MD5 bedf583646e59dd628d4aced7e83fdf3 ping_php_version4_snmpgetnext.patch 1262
-RMD160 94882973199b8e59c40ad43a132548862654f312 ping_php_version4_snmpgetnext.patch 1262
-SHA256 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170 ping_php_version4_snmpgetnext.patch 1262
-MD5 1a3c9580a1f94d991502c8650d18b617 thumbnail_graphs_not_working.patch 1515
-RMD160 6b228cab1bc99b3f20ddb4e1d45b467fc8dadf35 thumbnail_graphs_not_working.patch 1515
-SHA256 3b18602aed1aa8b9773a75a4e89413cd12ce2670fd185eae113de1aa2c1186bd thumbnail_graphs_not_working.patch 1515
-MD5 109afedcd49dc173da8c27fb23c322fe tree_console_missing_hosts.patch 771
-RMD160 d33f3916317e989b379d1188f3ed23b7d61a7a9e tree_console_missing_hosts.patch 771
-SHA256 5807bb408227b1c9f2ebecf220c048eb7c7148eee41fcd06fdc086124a206180 tree_console_missing_hosts.patch 771
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r5 b/net-analyzer/cacti/files/digest-cacti-0.8.6j-r5
deleted file mode 100644
index fbccf1df186f..000000000000
--- a/net-analyzer/cacti/files/digest-cacti-0.8.6j-r5
+++ /dev/null
@@ -1,15 +0,0 @@
-MD5 29436be46b289d13dfce48e7618129e2 cacti-0.8.6j.tar.gz 1126337
-RMD160 981d24753d440af1d3fcfdb20cd988f73fcc44fe cacti-0.8.6j.tar.gz 1126337
-SHA256 0ddf8a740a5725de67eeea71c38433447ff75388e6e399ce92ccadc36d25bd46 cacti-0.8.6j.tar.gz 1126337
-MD5 85a95eaef5fac31d5ca87cb915493cdd graph_debug_lockup_fix.patch 927
-RMD160 8bf2112cb537b330547b8b571cc573a0f3135123 graph_debug_lockup_fix.patch 927
-SHA256 c8ea30c6bf5764663d106d28b3308377a8c2003cc2afd3d0ba0102ed5fddee1b graph_debug_lockup_fix.patch 927
-MD5 bedf583646e59dd628d4aced7e83fdf3 ping_php_version4_snmpgetnext.patch 1262
-RMD160 94882973199b8e59c40ad43a132548862654f312 ping_php_version4_snmpgetnext.patch 1262
-SHA256 1e19110c696eb56c6de68247c926c5ec7a2e7554df222f39a663556241644170 ping_php_version4_snmpgetnext.patch 1262
-MD5 1a3c9580a1f94d991502c8650d18b617 thumbnail_graphs_not_working.patch 1515
-RMD160 6b228cab1bc99b3f20ddb4e1d45b467fc8dadf35 thumbnail_graphs_not_working.patch 1515
-SHA256 3b18602aed1aa8b9773a75a4e89413cd12ce2670fd185eae113de1aa2c1186bd thumbnail_graphs_not_working.patch 1515
-MD5 109afedcd49dc173da8c27fb23c322fe tree_console_missing_hosts.patch 771
-RMD160 d33f3916317e989b379d1188f3ed23b7d61a7a9e tree_console_missing_hosts.patch 771
-SHA256 5807bb408227b1c9f2ebecf220c048eb7c7148eee41fcd06fdc086124a206180 tree_console_missing_hosts.patch 771