summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-23 14:48:37 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-23 14:48:37 +0000
commit093867db83811b195a6ff54664f539d5d52ad1b4 (patch)
tree028938c5734d43cbacfaf4a724e0874a8e67e533 /net-analyzer/cacti/cacti-0.6.8a.ebuild
parentnew ebuild going in (diff)
downloadgentoo-2-093867db83811b195a6ff54664f539d5d52ad1b4.tar.gz
gentoo-2-093867db83811b195a6ff54664f539d5d52ad1b4.tar.bz2
gentoo-2-093867db83811b195a6ff54664f539d5d52ad1b4.zip
Initial ebuild
Diffstat (limited to 'net-analyzer/cacti/cacti-0.6.8a.ebuild')
-rw-r--r--net-analyzer/cacti/cacti-0.6.8a.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/cacti/cacti-0.6.8a.ebuild b/net-analyzer/cacti/cacti-0.6.8a.ebuild
new file mode 100644
index 000000000000..fb871828cd36
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.6.8a.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.6.8a.ebuild,v 1.1 2002/10/23 14:48:37 vapier Exp $
+
+DESCRIPTION="Cacti is a complete frondend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${P}.tar.gz"
+
+IUSE="snmp"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND=""
+RDEPEND="net-www/apache
+ snmp? ( net-analyzer/ucd-snmp )
+ dev-db/mysql
+ dev-php/php
+ dev-php/mod_php"
+
+S="${WORKDIR}/${P}"
+
+INSTALL_DEST=/home/httpd/htdocs/cacti
+
+src_install() {
+ dodoc docs/{CHANGELOG,CONTRIB,README}
+ rm README LICENSE docs/{CHANGELOG,CONTRIB,README}
+
+ dodir ${INSTALL_DEST}
+ chown apache.apache * -R
+ mv * ${D}/${INSTALL_DEST}/
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The cacti has been copied to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must create the cacti database:"
+ einfo " mysqladmin -u root -p create cacti"
+ einfo " mysql -u root -p cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "And you must setup the config.php file:"
+ einfo " nano ${INSTALL_DEST}/include/config.php"
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+}