summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-08 20:44:56 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-08 20:44:56 +0000
commite9c69f80730487de2463ab999303c5f96c0cb413 (patch)
treed19b25da960a708681ccee3c4fc6da3c7f140b5b /media-video
parentSet SUPPORT_PYTHON_ABIS. (diff)
downloadgentoo-2-e9c69f80730487de2463ab999303c5f96c0cb413.tar.gz
gentoo-2-e9c69f80730487de2463ab999303c5f96c0cb413.tar.bz2
gentoo-2-e9c69f80730487de2463ab999303c5f96c0cb413.zip
Fixing build against glibc 2.10, bug #279787
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/SDLcam/ChangeLog8
-rw-r--r--media-video/SDLcam/SDLcam-0.7.3-r2.ebuild5
-rw-r--r--media-video/SDLcam/SDLcam-0.8.2.ebuild12
-rw-r--r--media-video/SDLcam/files/SDLcam-glibc210.patch15
4 files changed, 34 insertions, 6 deletions
diff --git a/media-video/SDLcam/ChangeLog b/media-video/SDLcam/ChangeLog
index dad5b9a7f5d5..b7bf1adff680 100644
--- a/media-video/SDLcam/ChangeLog
+++ b/media-video/SDLcam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/SDLcam
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/SDLcam/ChangeLog,v 1.11 2007/10/08 18:10:18 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/SDLcam/ChangeLog,v 1.12 2009/08/08 20:44:56 vostorga Exp $
+
+ 08 Aug 2009; Víctor Ostorga <vostorga@gentoo.org>
+ +files/SDLcam-glibc210.patch, SDLcam-0.7.3-r2.ebuild, SDLcam-0.8.2.ebuild:
+ Fixing build against glibc 2.10, bug #279787
*SDLcam-0.8.2 (08 Oct 2007)
diff --git a/media-video/SDLcam/SDLcam-0.7.3-r2.ebuild b/media-video/SDLcam/SDLcam-0.7.3-r2.ebuild
index ac84476ce750..8229d712c703 100644
--- a/media-video/SDLcam/SDLcam-0.7.3-r2.ebuild
+++ b/media-video/SDLcam/SDLcam-0.7.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/SDLcam/SDLcam-0.7.3-r2.ebuild,v 1.4 2006/10/30 00:56:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/SDLcam/SDLcam-0.7.3-r2.ebuild,v 1.5 2009/08/08 20:44:56 vostorga Exp $
inherit eutils
@@ -32,6 +32,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-build.patch
epatch "${FILESDIR}"/${P}-relax-asm.patch #152002
epatch "${FILESDIR}"/${P}-jpeg.patch
+ epatch "${FILESDIR}"/${PN}-glibc210.patch
# Don't you love hardcoded vars?
sed -i \
diff --git a/media-video/SDLcam/SDLcam-0.8.2.ebuild b/media-video/SDLcam/SDLcam-0.8.2.ebuild
index 8aa0596fef43..3304e316c9f8 100644
--- a/media-video/SDLcam/SDLcam-0.8.2.ebuild
+++ b/media-video/SDLcam/SDLcam-0.8.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/SDLcam/SDLcam-0.8.2.ebuild,v 1.1 2007/10/08 18:10:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/SDLcam/SDLcam-0.8.2.ebuild,v 1.2 2009/08/08 20:44:56 vostorga Exp $
+
+inherit eutils
DESCRIPTION="webcam application that uses the SDL library"
HOMEPAGE="http://sdlcam.raphnet.net/"
@@ -21,6 +23,12 @@ DEPEND="dev-libs/libxml2
S=${WORKDIR}/sdlcam-${PV}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-glibc210.patch
+}
+
src_install() {
emake install DESTDIR="${D}" || die
dodoc AUTHORS ChangeLog NEWS README TODO \
diff --git a/media-video/SDLcam/files/SDLcam-glibc210.patch b/media-video/SDLcam/files/SDLcam-glibc210.patch
new file mode 100644
index 000000000000..aa58556804ab
--- /dev/null
+++ b/media-video/SDLcam/files/SDLcam-glibc210.patch
@@ -0,0 +1,15 @@
+--- interface.cpp.original 2009-08-08 20:46:34.000000000 -0600
++++ interface.cpp 2009-08-08 20:46:42.000000000 -0600
+@@ -163,11 +163,11 @@
+ if (val != -1000000) return val;
+ if (0 == strcmp ("cur-fps" , name)) return (cnt_fps>0) ? sum_fps / cnt_fps : -1;
+ return -1000000;
+ }}}
+ void Set_Resolution (const char *res) {{{
+- char *w;
++ const char *w;
+ if (res == NULL) return;
+ w = strchr (res, 'x');
+ if (w == NULL) return;
+ v4l[v4l_akt]->Resolution(atoi (res), atoi (w + 1));
+ // V4L_resolution_set (atoi (res), atoi (w + 1));