summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-17 16:30:20 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-17 16:30:20 +0000
commita97a6a00c38ece3758910674d86eab63296c4814 (patch)
treec56fc317cf35d2b8edc20493a8f26a987cb0c42f /media-video
parentCorrect version bump, thanks to Samuli for noticing I was standing asleep yes... (diff)
downloadgentoo-2-a97a6a00c38ece3758910674d86eab63296c4814.tar.gz
gentoo-2-a97a6a00c38ece3758910674d86eab63296c4814.tar.bz2
gentoo-2-a97a6a00c38ece3758910674d86eab63296c4814.zip
Correct version bump, thanks to Samuli for noticing I was standing asleep yesterday.
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/em8300-modules/ChangeLog9
-rw-r--r--media-video/em8300-modules/em8300-modules-0.16.0_rc2.ebuild77
-rw-r--r--media-video/em8300-modules/files/digest-em8300-modules-0.16.0_rc23
3 files changed, 88 insertions, 1 deletions
diff --git a/media-video/em8300-modules/ChangeLog b/media-video/em8300-modules/ChangeLog
index 8a71b8ecc1d5..42bc81f66c35 100644
--- a/media-video/em8300-modules/ChangeLog
+++ b/media-video/em8300-modules/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/em8300-modules
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.27 2006/11/16 19:24:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/ChangeLog,v 1.28 2006/11/17 16:30:20 flameeyes Exp $
+
+*em8300-modules-0.16.0_rc2 (17 Nov 2006)
+
+ 17 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +em8300-modules-0.16.0_rc2.ebuild:
+ Correct version bump, thanks to Samuli for noticing I was standing asleep
+ yesterday.
*em8300-modules-0.15.3-r1 (16 Nov 2006)
diff --git a/media-video/em8300-modules/em8300-modules-0.16.0_rc2.ebuild b/media-video/em8300-modules/em8300-modules-0.16.0_rc2.ebuild
new file mode 100644
index 000000000000..0e9505c17ac2
--- /dev/null
+++ b/media-video/em8300-modules/em8300-modules-0.16.0_rc2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/em8300-modules/em8300-modules-0.16.0_rc2.ebuild,v 1.1 2006/11/17 16:30:20 flameeyes Exp $
+
+inherit eutils linux-info
+
+MY_P="${P/_/-}" ; MY_P="${MY_P/-modules/}"
+
+DESCRIPTION="em8300 (RealMagic Hollywood+/Creative DXR3) video decoder card kernel modules"
+HOMEPAGE="http://dxr3.sourceforge.net"
+SRC_URI="http://dxr3.sourceforge.net/download/${MY_P}.tar.gz"
+
+DEPEND="virtual/linux-sources"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile () {
+ check_KV
+ set_arch_to_kernel
+ for file in autotools/config.guess configure modules/ldm modules/Makefile modules/INSTALL; do
+ sed -i -e 's/uname[[:space:]]*-r/echo ${KV}/' $file
+ done
+ cd modules
+ emake || die "emake failed."
+ set_arch_to_portage
+}
+
+src_install () {
+ insinto "/usr/include/linux"
+ doins ../include/linux/em8300.h
+
+ check_KV
+
+ # The driver goes into the standard modules location
+ insinto "/lib/modules/${KV}/kernel/drivers/video"
+
+ if [ "${KV:0:3}" == "2.6" ]
+ then
+ doins em8300.ko bt865.ko adv717x.ko
+ else
+ doins em8300.o bt865.o adv717x.o
+ fi
+
+ dodoc README-modoptions README-modules.conf devfs_symlinks
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/modules.em8300 em8300
+
+ insinto /etc/udev/rules.d
+ newins em8300-udev.rules 15-em8300.rules
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = "/" ]
+ then
+ /sbin/modules-update
+ fi
+
+ elog "The em8300 kernel modules have been installed into the modules"
+ elog "directory of your currently running kernel. They haven't been"
+ elog "loaded. Please read the documentation, and if you would like"
+ elog "to have the modules load at startup, add em8300, bt865, adv717x"
+ elog "to your /etc/modules.autoload they may need module options to "
+ elog "work correctly on your system. You will also need to add"
+ elog "the contents of /usr/share/doc/${P}/devfs_symlinks.gz"
+ elog "to your devfsd.conf so that the em8300 devices will be linked"
+ elog "correctly."
+ elog
+ elog "You will also need to have the i2c kernel modules compiled for"
+ elog "this to be happy, no need to patch any kernel though just turn"
+ elog "all the i2c stuff in kernel config to M and you'll be fine."
+}
diff --git a/media-video/em8300-modules/files/digest-em8300-modules-0.16.0_rc2 b/media-video/em8300-modules/files/digest-em8300-modules-0.16.0_rc2
new file mode 100644
index 000000000000..15c8cba26a75
--- /dev/null
+++ b/media-video/em8300-modules/files/digest-em8300-modules-0.16.0_rc2
@@ -0,0 +1,3 @@
+MD5 3bf62282b50d98585cbf02fc34b83cd5 em8300-0.16.0-rc2.tar.gz 337262
+RMD160 3e96c2179de345e74e31ea0e847177f456596fbd em8300-0.16.0-rc2.tar.gz 337262
+SHA256 2002ff95924dff02490aafab890426551417eb6289ff23993e5b3bd0c83f282a em8300-0.16.0-rc2.tar.gz 337262