summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-12 15:59:30 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-12 15:59:30 +0000
commita02245886f70c05154a529a84a927a1301abfe6f (patch)
tree92d2d014a214c65616bfe6b36b31a2b563de5a8f /media-video
parentAdded XML-Parser to deps (diff)
downloadgentoo-2-a02245886f70c05154a529a84a927a1301abfe6f.tar.gz
gentoo-2-a02245886f70c05154a529a84a927a1301abfe6f.tar.bz2
gentoo-2-a02245886f70c05154a529a84a927a1301abfe6f.zip
Update
Diffstat (limited to 'media-video')
-rw-r--r--media-video/avifile/avifile-0.6.0.20011109.ebuild60
-rw-r--r--media-video/avifile/files/avifile-0.6.0.20011109-gentoo.diff105
-rw-r--r--media-video/avifile/files/digest-avifile-0.6.0.200111092
3 files changed, 167 insertions, 0 deletions
diff --git a/media-video/avifile/avifile-0.6.0.20011109.ebuild b/media-video/avifile/avifile-0.6.0.20011109.ebuild
new file mode 100644
index 000000000000..4ff18a6cee30
--- /dev/null
+++ b/media-video/avifile/avifile-0.6.0.20011109.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.6.0.20011109.ebuild,v 1.1 2001/11/12 15:59:30 achim Exp $
+
+P0=${PN}-0.6.0-20011109
+S=${WORKDIR}/${P0}
+DESCRIPTION="Library for AVI-Files"
+
+SRC_URI="http://avifile.sourceforge.net/${P0}.tgz
+ http://avifile.sourceforge.net/binaries-011002.tgz"
+
+HOMEPAGE="http://divx.euro.ru/"
+
+DEPEND="virtual/glibc qt? ( >=x11-libs/qt-x11-2.2.2 ) >=media-libs/libsdl-1.2.2 app-arch/unzip >=media-libs/divx4linux-20011025"
+RDEPEND="virtual/glibc qt? ( >=x11-libs/qt-x11-2.2.2 ) >=media-libs/libsdl-1.2.2 >=media-libs/divx4linux-20011025"
+
+src_unpack() {
+ unpack ${P0}.tgz
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ local myconf
+ if [ -z "`use qt`" ] ; then
+ myconf="$myconf --disable-qt"
+ fi
+ if [ "`use nas`" ] ; then
+ LDFLAGS="-L/usr/X11R6/lib -lXt"
+ fi
+ export CFLAGS=${CFLAGS/-O?/-O2}
+ export LDFLAGS
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --enable-quiet --disable-tsc $myconf
+# cp Makefile Makefile.orig
+# sed -e "s:/usr/lib/win32:${D}/usr/lib/win32:" \
+# Makefile.orig > Makefile
+ try make
+}
+
+src_install () {
+
+ dodir /usr/lib /usr/bin
+ dodir /usr/lib/win32
+
+ make prefix=${D}/usr install
+
+ cd ${D}/usr/lib/win32
+ unzip ${DISTDIR}/binaries-011002.zip
+ cd ${S}
+ dodoc COPYING README
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS
+}
+
+
+
+
+
diff --git a/media-video/avifile/files/avifile-0.6.0.20011109-gentoo.diff b/media-video/avifile/files/avifile-0.6.0.20011109-gentoo.diff
new file mode 100644
index 000000000000..110c8a99222c
--- /dev/null
+++ b/media-video/avifile/files/avifile-0.6.0.20011109-gentoo.diff
@@ -0,0 +1,105 @@
+--- avifile-0.6.0-20011109/plugins/libdivx4/divx4.cpp~ Sat Nov 24 12:36:00 2001
++++ avifile-0.6.0-20011109/plugins/libdivx4/divx4.cpp Sat Nov 24 12:36:11 2001
+@@ -172,7 +172,7 @@
+ return 0;
+ DEC_FRAME param;
+ // leave here for some time - until all users will use new headers
+- CONST_VOID param.bitstream = src;
++ param.bitstream = src;
+ unsigned char* pc[3];
+ param.bmp=pImage?pImage->Data():0;
+ param.length=size;
+--- avifile-0.6.0-20011109/samples/qtvidcap/parsecl.h~ Mon Apr 9 16:17:03 2001
++++ avifile-0.6.0-20011109/samples/qtvidcap/parsecl.h Mon Nov 12 15:38:09 2001
+@@ -25,7 +25,7 @@
+ #include <qlist.h>
+ #include <qstrlist.h>
+
+-struct option
++struct option2
+ {
+ QString olong, oshort;
+ QString options, help;
+@@ -53,7 +53,7 @@
+
+ QStrList * list;
+
+- QList<option> * oplist;
++ QList<option2> * oplist;
+ };
+
+ #endif
+--- avifile-0.6.0-20011109/samples/qtvidcap/parsecl.cpp~ Sat Sep 29 19:08:47 2001
++++ avifile-0.6.0-20011109/samples/qtvidcap/parsecl.cpp Mon Nov 12 15:38:58 2001
+@@ -37,7 +37,7 @@
+ argv=_argv;
+
+ list= new QStrList; // do deep copies
+- oplist= new QList<option>;
++ oplist= new QList<option2>;
+ }
+
+ parsecl::~parsecl()
+@@ -94,7 +94,7 @@
+ QString outstr;
+
+ fprintf(stderr,"usage: kWinTV [options]\noptions:\n");
+- option *op= oplist->first();
++ option2 *op= oplist->first();
+ while( op ) {
+ outstr.remove( 0, outstr.length() );
+ outstr+=op->oshort;
+@@ -139,7 +139,7 @@
+ bool parsecl::addOption( int oid, const char * oshort, const char * olong,
+ const char * options, const char * help )
+ {
+- option *op;
++ option2 *op;
+ if ( !oplist->isEmpty() ) {
+ op= oplist->first();
+ while( op ) {
+@@ -152,7 +152,7 @@
+ }
+ }
+
+- op= new option;
++ op= new option2;
+ op->oshort= oshort;
+ op->olong= olong;
+ op->options= options;
+@@ -169,7 +169,7 @@
+ debug("parsecl: checkOptionBool %d, default %d",oid,odefault);
+ #endif
+ if ( !oplist->isEmpty() ) {
+- option *op= oplist->first();
++ option2 *op= oplist->first();
+ while( op ) {
+ if ( ( op->oid == oid ) ) break;
+ op= oplist->next();
+@@ -188,7 +188,7 @@
+ debug("parsecl: checkOptionInt %d, default %d",oid,odefault);
+ #endif
+ if ( !oplist->isEmpty() ) {
+- option *op= oplist->first();
++ option2 *op= oplist->first();
+ while( op ) {
+ if ( ( op->oid == oid ) ) break;
+ op= oplist->next();
+@@ -218,7 +218,7 @@
+ debug("parsecl: checkOptionBool %d, default %s",oid,odefault);
+ #endif
+ if ( !oplist->isEmpty() ) {
+- option *op= oplist->first();
++ option2 *op= oplist->first();
+ while( op ) {
+ if ( ( op->oid == oid ) ) break;
+ op= oplist->next();
+@@ -236,7 +236,7 @@
+ debug("parsecl: checkOptionSwitch %d, default %d",oid,odefault);
+ #endif
+ if ( !oplist->isEmpty() ) {
+- option *op= oplist->first();
++ option2 *op= oplist->first();
+ while( op ) {
+ if ( ( op->oid == oid ) ) break;
+ op= oplist->next();
diff --git a/media-video/avifile/files/digest-avifile-0.6.0.20011109 b/media-video/avifile/files/digest-avifile-0.6.0.20011109
new file mode 100644
index 000000000000..cd33cc2d90f8
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.6.0.20011109
@@ -0,0 +1,2 @@
+MD5 d90d285597ac47fb156077a579c844b6 avifile-0.6.0-20011109.tgz 1900544
+MD5 4db4edeeceefb9353b15b047207fa6d3 binaries-011002.tgz 4407296