summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerm@gentoo.org>2007-02-23 12:42:39 +0000
committerZaheer Abbas Merali <zaheerm@gentoo.org>2007-02-23 12:42:39 +0000
commit7a3dfae5a4d8fc0913171bf4f699520a3de457c0 (patch)
treef0fca3c3a25df1027f032dcfffd7ec65a252e2a0 /media-video
parentversion bump (diff)
downloadgentoo-2-7a3dfae5a4d8fc0913171bf4f699520a3de457c0.tar.gz
gentoo-2-7a3dfae5a4d8fc0913171bf4f699520a3de457c0.tar.bz2
gentoo-2-7a3dfae5a4d8fc0913171bf4f699520a3de457c0.zip
version bump
(Portage version: 2.1.2-r9)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/istanbul/ChangeLog8
-rw-r--r--media-video/istanbul/files/digest-istanbul-0.2.23
-rw-r--r--media-video/istanbul/istanbul-0.2.2.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/media-video/istanbul/ChangeLog b/media-video/istanbul/ChangeLog
index 79736b62b087..aabc5df2841a 100644
--- a/media-video/istanbul/ChangeLog
+++ b/media-video/istanbul/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/istanbul
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.9 2007/01/22 02:20:49 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/ChangeLog,v 1.10 2007/02/23 12:42:39 zaheerm Exp $
+
+*istanbul-0.2.2 (23 Feb 2007)
+
+ 23 Feb 2007; Zaheer Abbas Merali <zaheerm@gentoo.org>
+ +istanbul-0.2.2.ebuild:
+ version bump
22 Jan 2007; Saleem Abdulrasool <compnerd@gentoo.org>
istanbul-0.2.0.ebuild, istanbul-0.2.0-r1.ebuild, istanbul-0.2.1.ebuild:
diff --git a/media-video/istanbul/files/digest-istanbul-0.2.2 b/media-video/istanbul/files/digest-istanbul-0.2.2
new file mode 100644
index 000000000000..bb4570d8f767
--- /dev/null
+++ b/media-video/istanbul/files/digest-istanbul-0.2.2
@@ -0,0 +1,3 @@
+MD5 8ddcfd5a29dcd10fdafc10af9f66848b istanbul-0.2.2.tar.bz2 349075
+RMD160 79ece5e4f2f9dd673fce5d326ad3b4009e54ccfe istanbul-0.2.2.tar.bz2 349075
+SHA256 3baa2462ecf1b13d0d95cd035fe0f0fc0fcc3df8cb04a3b7f237e90e9a40acd5 istanbul-0.2.2.tar.bz2 349075
diff --git a/media-video/istanbul/istanbul-0.2.2.ebuild b/media-video/istanbul/istanbul-0.2.2.ebuild
new file mode 100644
index 000000000000..09afd1231f01
--- /dev/null
+++ b/media-video/istanbul/istanbul-0.2.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/istanbul/istanbul-0.2.2.ebuild,v 1.1 2007/02/23 12:42:39 zaheerm Exp $
+
+inherit eutils gnome2 python autotools
+
+KEYWORDS="~x86 ~amd64"
+
+HOMEPAGE="http://live.gnome.org/Istanbul"
+LICENSE="GPL-2"
+SLOT=0
+DESCRIPTION="Istanbul is a screencast application for the Unix desktop"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.8
+ dev-lang/python
+ >=dev-python/pygtk-2.6
+ >=dev-python/gnome-python-extras-2.11.3
+ >=gnome-base/gconf-2.0
+ >=dev-python/gst-python-0.10.0
+ =media-plugins/gst-plugins-ogg-0.10*
+ =media-plugins/gst-plugins-theora-0.10*
+ >=media-libs/libtheora-1.0_alpha6
+ =media-plugins/gst-plugins-gconf-0.10*
+ dev-python/python-xlib"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0"
+
+SRC_URI="http://zaheer.merali.org/${P}.tar.bz2"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv ${S}/py-compile ${S}/py-compile.orig
+ ln -s /bin/true ${S}/py-compile
+ echo "py_compile = /bin/true" > common/python.mk
+
+ intltoolize --force --copy || die
+ AT_M4DIR="common" eautoreconf
+}
+
+src_compile() {
+ mkdir -p "${T}/home"
+ export HOME="${T}/home"
+ export GST_REGISTRY=${T}/home/registry.cache.xml
+ addpredict /root/.gconfd
+ addpredict /root/.gconf
+ addpredict /root/.gnome2
+ econf
+ emake
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/istanbul
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}