summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-01 10:47:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-01 10:47:24 +0000
commit89d66e609b595ab6adf20442d24abc1af646f571 (patch)
treec9c06f43020b4b72743526ec392730dd46dfac74 /media-video/subtitleeditor
parentStable on alpha, bug #249703 (diff)
downloadgentoo-2-89d66e609b595ab6adf20442d24abc1af646f571.tar.gz
gentoo-2-89d66e609b595ab6adf20442d24abc1af646f571.tar.bz2
gentoo-2-89d66e609b595ab6adf20442d24abc1af646f571.zip
Initial commit of subtitleeditor, thanks for contributors of bug #125714. Adding gnome as backing herd, maintained by <eva@gentoo.org>.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-video/subtitleeditor')
-rw-r--r--media-video/subtitleeditor/ChangeLog11
-rw-r--r--media-video/subtitleeditor/metadata.xml13
-rw-r--r--media-video/subtitleeditor/subtitleeditor-0.30.0.ebuild56
3 files changed, 80 insertions, 0 deletions
diff --git a/media-video/subtitleeditor/ChangeLog b/media-video/subtitleeditor/ChangeLog
new file mode 100644
index 000000000000..0b64e6731d89
--- /dev/null
+++ b/media-video/subtitleeditor/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-video/subtitleeditor
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/ChangeLog,v 1.1 2009/02/01 10:47:24 eva Exp $
+
+*subtitleeditor-0.30.0 (01 Feb 2009)
+
+ 01 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org> +metadata.xml,
+ +subtitleeditor-0.30.0.ebuild:
+ Initial commit of subtitleeditor, thanks for contributors of bug #125714.
+ Adding gnome as backing herd, maintained by <eva@gentoo.org>.
+
diff --git a/media-video/subtitleeditor/metadata.xml b/media-video/subtitleeditor/metadata.xml
new file mode 100644
index 000000000000..58bbb44bf7bc
--- /dev/null
+++ b/media-video/subtitleeditor/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<maintainer>
+ <email>eva@gentoo.org</email>
+ <name>Gilles Dartiguelongue</name>
+</maintainer>
+<longdescription lang="en">
+Subtitle Editor is a GTK+2 tool to edit subtitles for GNU/Linux/*BSD. It can be used for new subtitles or as a tool to transform, edit, correct and refine existing subtitle. This program also shows sound waves, which makes it easier to synchronise subtitles to voices.
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-video/subtitleeditor/subtitleeditor-0.30.0.ebuild b/media-video/subtitleeditor/subtitleeditor-0.30.0.ebuild
new file mode 100644
index 000000000000..65baae99b8b5
--- /dev/null
+++ b/media-video/subtitleeditor/subtitleeditor-0.30.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitleeditor/subtitleeditor-0.30.0.ebuild,v 1.1 2009/02/01 10:47:24 eva Exp $
+
+EAPI="1"
+
+inherit eutils
+
+DESCRIPTION="GTK+2 subtitle editing tool."
+HOMEPAGE="http://home.gna.org/subtitleeditor/"
+SRC_URI="http://download.gna.org/${PN}/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-cpp/gtkmm-2.12
+ >=dev-cpp/glibmm-2.16.3
+ >=dev-cpp/libglademm-2.4
+ >=dev-cpp/libxmlpp-2.10
+ >=app-text/enchant-1.1.0
+ opengl? ( >=dev-cpp/gtkglextmm-1.2 )
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-good-0.10
+ >=media-plugins/gst-plugins-meta-0.10-r2:0.10
+ app-text/iso-codes"
+#>=media-plugins/gst-plugins-pango-0.10
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+src_compile() {
+ intltoolize --copy --force --automake || die "intltoolize failed"
+ export GST_REGISTRY="${T}/home/registry.cache.xml"
+
+ # USE="debug" seems to turn on some debug path
+ econf \
+ $(use_enable debug) \
+ $(use_enable opengl gl)
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If ${PN} doesn't play some video format, please check your"
+ ewarn "USE flags on media-plugins/gst-plugins-meta"
+ ewarn
+}