summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Doty <kingtaco@gentoo.org>2006-10-22 15:04:58 +0000
committerMike Doty <kingtaco@gentoo.org>2006-10-22 15:04:58 +0000
commit2eeb87a83080622702edd3f9188447444c140cfe (patch)
treecfeb40da6fd50c0606c445c729e6d1d3a95902e8 /media-video/spca5xx
parentVersion bump, bug #133798. (diff)
downloadgentoo-2-2eeb87a83080622702edd3f9188447444c140cfe.tar.gz
gentoo-2-2eeb87a83080622702edd3f9188447444c140cfe.tar.bz2
gentoo-2-2eeb87a83080622702edd3f9188447444c140cfe.zip
bump to 20060501-r1 for kernel >2.6.17 support. see bug 148425
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'media-video/spca5xx')
-rw-r--r--media-video/spca5xx/ChangeLog9
-rw-r--r--media-video/spca5xx/files/digest-spca5xx-20060501-r13
-rw-r--r--media-video/spca5xx/files/spca-20060501-2.6.18.patch13
-rw-r--r--media-video/spca5xx/spca5xx-20060501-r1.ebuild38
4 files changed, 62 insertions, 1 deletions
diff --git a/media-video/spca5xx/ChangeLog b/media-video/spca5xx/ChangeLog
index 075f9f64ed03..2aabf188d6ca 100644
--- a/media-video/spca5xx/ChangeLog
+++ b/media-video/spca5xx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/spca5xx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/ChangeLog,v 1.24 2006/07/16 22:56:24 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/ChangeLog,v 1.25 2006/10/22 15:04:58 kingtaco Exp $
+
+*spca5xx-20060501-r1 (22 Oct 2006)
+
+ 22 Oct 2006; Mike Doty <kingtaco@gentoo.org>
+ +files/spca-20060501-2.6.18.patch, +spca5xx-20060501-r1.ebuild:
+ Added 20060501-r1 for support of >2.6.17 kernels. see bug 148425. spca5xx
+ will soon be replaced by gspca.
16 Jul 2006; Daniel Black <dragonheart@gentoo.org>
+files/spca-20060501-defines.patch, spca5xx-20060501.ebuild:
diff --git a/media-video/spca5xx/files/digest-spca5xx-20060501-r1 b/media-video/spca5xx/files/digest-spca5xx-20060501-r1
new file mode 100644
index 000000000000..7700fdc72b15
--- /dev/null
+++ b/media-video/spca5xx/files/digest-spca5xx-20060501-r1
@@ -0,0 +1,3 @@
+MD5 8fcec25715aea10f9ebec5728c37e752 spca5xx-20060501.tar.gz 192817
+RMD160 68997c92f29f4abf7487bd6d80662738aadb6471 spca5xx-20060501.tar.gz 192817
+SHA256 b8049142742cc81bc945aadefb40d173aeb447e428ec62a93e781032ea9b40c2 spca5xx-20060501.tar.gz 192817
diff --git a/media-video/spca5xx/files/spca-20060501-2.6.18.patch b/media-video/spca5xx/files/spca-20060501-2.6.18.patch
new file mode 100644
index 000000000000..2a188b6c2c98
--- /dev/null
+++ b/media-video/spca5xx/files/spca-20060501-2.6.18.patch
@@ -0,0 +1,13 @@
+--- spca5xx/drivers/usb/spca5xx.h 2006-05-08 07:01:40.000000000 -0400
++++ spca5xx.new/drivers/usb/spca5xx.h 2006-09-05 13:42:26.000000000 -0400
+@@ -14,6 +14,10 @@
+ #include <linux/usb.h>
+ #include <linux/version.h>
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,18)
++#include <media/v4l2-common.h>
++#endif
++
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,20) && LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
+
+ #define urb_t struct urb
diff --git a/media-video/spca5xx/spca5xx-20060501-r1.ebuild b/media-video/spca5xx/spca5xx-20060501-r1.ebuild
new file mode 100644
index 000000000000..846f10c0d024
--- /dev/null
+++ b/media-video/spca5xx/spca5xx-20060501-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/spca5xx/spca5xx-20060501-r1.ebuild,v 1.1 2006/10/22 15:04:58 kingtaco Exp $
+
+inherit linux-mod
+
+DESCRIPTION="spca5xx driver for webcams."
+HOMEPAGE="http://mxhaard.free.fr/spca5xx.html"
+SRC_URI="http://mxhaard.free.fr/spca50x/Download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT=""
+DEPEND=""
+RDEPEND=""
+
+MODULE_NAMES="spca5xx(usb/video:)"
+BUILD_TARGETS="default"
+CONFIG_CHECK="VIDEO_DEV VIDEO_V4L1_COMPAT"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ convert_to_m ${S}/Makefile
+ cd "${S}"
+ epatch "${FILESDIR}"/spca-20060501-defines.patch
+ epatch "${FILESDIR}"/spca-20060501-2.6.18.patch
+}
+
+src_install() {
+ dodoc CHANGELOG INSTALL README
+ linux-mod_src_install
+}