summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-02-13 13:33:15 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-02-13 13:33:15 +0000
commit016a6dc493a6952bf3b64580020ae71060afce33 (patch)
tree2c933cb5d4c6bad92f8574d78769cbdb60885cf6 /media-video/qdvdauthor
parentMake maildrop use courier-authlib and clean the ebuild. Re-Closes #81391. (diff)
downloadgentoo-2-016a6dc493a6952bf3b64580020ae71060afce33.tar.gz
gentoo-2-016a6dc493a6952bf3b64580020ae71060afce33.tar.bz2
gentoo-2-016a6dc493a6952bf3b64580020ae71060afce33.zip
Initial ebuild as per bug #81826
(Portage version: 2.0.51.16)
Diffstat (limited to 'media-video/qdvdauthor')
-rw-r--r--media-video/qdvdauthor/ChangeLog9
-rw-r--r--media-video/qdvdauthor/Manifest4
-rw-r--r--media-video/qdvdauthor/metadata.xml9
-rw-r--r--media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild63
4 files changed, 85 insertions, 0 deletions
diff --git a/media-video/qdvdauthor/ChangeLog b/media-video/qdvdauthor/ChangeLog
new file mode 100644
index 000000000000..6a233f288701
--- /dev/null
+++ b/media-video/qdvdauthor/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-video/qdvdauthor
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/ChangeLog,v 1.1 2005/02/13 13:33:15 dragonheart Exp $
+
+*qdvdauthor-0.0.9 (13 Feb 2005)
+
+ 13 Feb 2005; Daniel Black <dragonheart@gentoo.org> +qdvdauthor-0.0.9.ebuild:
+ Initial ebuild as per bug #81826 thanks to Marco Morales <soulse@gmail.com>
+
diff --git a/media-video/qdvdauthor/Manifest b/media-video/qdvdauthor/Manifest
new file mode 100644
index 000000000000..53d1ab577252
--- /dev/null
+++ b/media-video/qdvdauthor/Manifest
@@ -0,0 +1,4 @@
+MD5 a8f156864180de09a9bce4e897eb1c41 qdvdauthor-0.0.9.ebuild 2002
+MD5 670f8ee68d87b77afc83f1d7cc451249 metadata.xml 346
+MD5 0e0844b9dba3eaa4da49e6c5ad814001 ChangeLog 314
+MD5 6d09c05eb5f5caa3cd56c0a70a2fc21d files/digest-qdvdauthor-0.0.9 68
diff --git a/media-video/qdvdauthor/metadata.xml b/media-video/qdvdauthor/metadata.xml
new file mode 100644
index 000000000000..1b850b495d70
--- /dev/null
+++ b/media-video/qdvdauthor/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>video</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild b/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
new file mode 100644
index 000000000000..364e0c04d3f2
--- /dev/null
+++ b/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/qdvdauthor/qdvdauthor-0.0.9.ebuild,v 1.1 2005/02/13 13:33:15 dragonheart Exp $
+
+inherit kde-functions
+
+DESCRIPTION="QDVDAuthor, the GUI frontend for dvdauthor and other related tools."
+HOMEPAGE="http://qdvdauthor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/qdvdauthor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=media-video/dvdauthor-0.6.10
+ >=media-gfx/imagemagick-5.5.7.11
+ >=media-video/mjpegtools-1.6.2
+ >=media-libs/xine-lib-1_rc5
+ >=media-video/dvd-slideshow-0.6.0
+ media-sound/sox
+ media-sound/lame
+ media-libs/libogg"
+
+# xine-libs or mplayer libs or media-video/vlc - mplayer use flags?
+
+need-qt 3.2
+
+# >=media-video/dvd-slideshow-0.6.0 -> optional
+
+src_compile() {
+
+ ./configure --with-xine-support || die "config fault"
+ #export IMAGE_LIB="imagemagicklib" # QTDIR="$QTDIR" QT_LIB="$QT_LIB"
+ # fixing defaults from /usr/local/bin to gentoo default /usr/bin
+ #export VIDEO_LIB="xine"
+ #export QT_LIB="$QTDIR"
+ sed -i "s|/usr/local/bin|/usr/bin|g" qdvdauthor/qdvdauthor.cpp qdvdauthor/dialogexecute.cpp doc/sound.txt
+ cd qdvdauthor
+ qmake qdvdauthor.pro
+
+ # fixing Makefile, so that we can use our CFLAGS
+ sed -i -e "s|^CFLAGS.*-O2|CFLAGS = ${CFLAGS} |g" -e "s|^CXXFLAGS.*-O2|CXXFLAGS = ${CXXFLAGS} |g" Makefile
+ emake || die "emake qdvdauthor failed"
+
+ cd qslideshow
+ qmake qslideshow.pro
+ # fixing Makefile, so that we can use our CFLAGS
+ sed -i -e "s|^CFLAGS.*-O2|CFLAGS = ${CFLAGS} |g" -e "s|^CXXFLAGS.*-O2|CXXFLAGS = ${CXXFLAGS} |g" Makefile
+ emake || die "emake qslideshow failed"
+}
+
+src_install() {
+ make -C qdvdauthor INSTALL_ROOT=${D} install || die "qdvdauthor install failed"
+ make -C qdvdauthor/qslideshow INSTALL_ROOT=${D} install || die "qslideshow install failed"
+
+ #had to prevent it from trying to install dvdproject link
+ dobin bin/q*
+ dodoc CHANGELOG COPYING INSTALL README TODO doc/*
+ insinto "/usr/share/applications"
+ doins qdvdauthor.desktop
+ insinto "/usr/share/pixmaps"
+ doins qdvdauthor.png
+}