summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-06 15:25:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-06 15:25:54 +0000
commitb56447b2daf7f95f0f4fc44eceeaf5d4543d40cf (patch)
treec85005fd91c89c7fb1745b0723fa2669cd85f269 /media-video/pitivi
parentNeeds to be rebuilt with systemd subslot bumps (diff)
downloadgentoo-2-b56447b2daf7f95f0f4fc44eceeaf5d4543d40cf.tar.gz
gentoo-2-b56447b2daf7f95f0f4fc44eceeaf5d4543d40cf.tar.bz2
gentoo-2-b56447b2daf7f95f0f4fc44eceeaf5d4543d40cf.zip
Version bump, bug #486980.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/ChangeLog8
-rw-r--r--media-video/pitivi/pitivi-0.14.1.ebuild15
-rw-r--r--media-video/pitivi/pitivi-0.93.ebuild79
3 files changed, 95 insertions, 7 deletions
diff --git a/media-video/pitivi/ChangeLog b/media-video/pitivi/ChangeLog
index f52f04992017..59a0ec6b59bb 100644
--- a/media-video/pitivi/ChangeLog
+++ b/media-video/pitivi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-video/pitivi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.33 2014/03/11 20:05:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/ChangeLog,v 1.34 2014/04/06 15:25:54 eva Exp $
+
+*pitivi-0.93 (06 Apr 2014)
+
+ 06 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> pitivi-0.14.1.ebuild,
+ +pitivi-0.93.ebuild:
+ Version bump, bug #486980.
11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due #239126
diff --git a/media-video/pitivi/pitivi-0.14.1.ebuild b/media-video/pitivi/pitivi-0.14.1.ebuild
index 9a8d1fd675a2..d901b539f069 100644
--- a/media-video/pitivi/pitivi-0.14.1.ebuild
+++ b/media-video/pitivi/pitivi-0.14.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.14.1.ebuild,v 1.3 2012/10/25 20:53:48 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.14.1.ebuild,v 1.4 2014/04/06 15:25:54 eva Exp $
EAPI="3"
GCONF_DEBUG="no"
PYTHON_DEPEND="2:2.5"
-inherit gnome2 python eutils virtualx multilib
+inherit eutils gnome2 multilib python virtualx
DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
HOMEPAGE="http://www.pitivi.org"
@@ -27,7 +27,8 @@ COMMON_DEPEND="
>=media-libs/gstreamer-0.10.28:0.10
>=dev-python/gst-python-0.10.19:0.10
- >=media-libs/gnonlin-0.10.16:0.10"
+ >=media-libs/gnonlin-0.10.16:0.10
+"
RDEPEND="${COMMON_DEPEND}
dev-python/dbus-python
>=dev-python/gconf-python-2.12
@@ -42,11 +43,13 @@ RDEPEND="${COMMON_DEPEND}
>=media-plugins/gst-plugins-xvideo-0.10.31:0.10
>=media-plugins/gst-plugins-libpng-0.10.24:0.10
- v4l? ( media-plugins/gst-plugins-v4l2:0.10 )"
+ v4l? ( media-plugins/gst-plugins-v4l2:0.10 )
+"
DEPEND="${RDEPEND}
dev-python/setuptools
sys-devel/gettext
- >=dev-util/intltool-0.35.5"
+ >=dev-util/intltool-0.35.5
+"
pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS RELEASE"
diff --git a/media-video/pitivi/pitivi-0.93.ebuild b/media-video/pitivi/pitivi-0.93.ebuild
new file mode 100644
index 000000000000..5359a4a4d334
--- /dev/null
+++ b/media-video/pitivi/pitivi-0.93.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/pitivi/pitivi-0.93.ebuild,v 1.1 2014/04/06 15:25:54 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-single-r1 eutils virtualx multilib
+
+DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
+HOMEPAGE="http://www.pitivi.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="v4l test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Test fails by not finding audiosink ?
+#RESTRICT="test"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pycairo-1.10[${PYTHON_USEDEP}]
+ >=x11-libs/cairo-1.10
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib:2
+
+ >=dev-libs/gobject-introspection-1.34
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-1.1.90:1.0
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+
+ gnome-base/librsvg:=
+
+ >=media-libs/clutter-1.12:1.0[introspection]
+ >=media-libs/clutter-gst-2:2.0[introspection]
+ >=media-libs/clutter-gtk-1.4:1.0[introspection]
+ >=media-libs/gnonlin-1.2:1.0
+ >=media-libs/gstreamer-1.2:1.0[introspection]
+ >=media-libs/gstreamer-editing-services-1.2:1.0[introspection]
+ >=media-libs/gst-plugins-base-1.2:1.0
+ >=media-libs/gst-plugins-good-1.2:1.0
+ >=media-plugins/gst-plugins-libav-1.2:1.0
+
+ x11-libs/libnotify[introspection]
+ >=x11-libs/gtk+-3.8:3
+
+ v4l? ( media-plugins/gst-plugins-v4l2:0.10 )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ >=app-text/gnome-doc-utils-0.18.0
+ >=dev-util/intltool-0.35.5
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+src_configure() {
+ gnome2_src_configure ITSTOOL="$(type -P true)"
+}
+
+src_test() {
+ # Force Xvfb to be used
+ unset DISPLAY
+ unset DBUS_SESSION_BUS_ADDRESS
+ export PITIVI_TOP_LEVEL_DIR="${S}"
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${D}"
+}